Results 1 to 7 of 7

Thread: compiz problem

  1. #1
    Join Date
    Apr 2010
    Location
    algeria
    Posts
    45

    Post compiz problem

    hi guys

    I just installed compiz on my opensuse 11.2 and the problem is that I'm having this error message:

    Code:
    compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
    thx in advance

  2. #2
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: compiz problem

    Hi,

    Which desktop environment are you using? How did you install compiz?

    Take Care,

    Ian
    Last edited by ijbreakey; 02-Jun-2010 at 08:17. Reason: OP posted openSUSE version
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,520
    Blog Entries
    15

    Default Re: compiz problem

    Quote Originally Posted by ilvista
    hi guys

    I just installed compiz on my opensuse 11.2 and the problem is that I'm
    having this error message:
    Hi
    What desktop are you trying to run compiz with? If it's KDE4, use kwin
    instead?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 1 day 16:43, 2 users, load average: 0.33, 0.19, 0.09
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  4. #4
    Join Date
    Apr 2010
    Location
    algeria
    Posts
    45

    Default Re: compiz problem

    right I'm using KDE 4.3.5

    I downloaded the compiz repository from the opensuse website("http://en.opensuse.org/Compiz_Fusion") and uesed Yast to install it

  5. #5
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: compiz problem

    I've made a step by step guide on how to install and configure compiz for KDE4. You can find it here:

    Installing and Configuring Compiz - openSUSE Forums

    Basically, the one-click installer doesn't automatically download emerald anymore, so you need to go back into Yast and mark compiz-emerald and compiz-emerald-themes for download. Then follow my guide for how to properly set compiz as the window manager.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: compiz problem

    So by default KDE 4 user kwin for special effects. Now you must tell it to use compiz. Look in personal settings.

    The question is why?? Are the special effects provided by kwin not eye candy enough for you? If you have not seen them perhaps you need to look closer in personal settings.

  7. #7
    Join Date
    Apr 2010
    Location
    algeria
    Posts
    45

    Thumbs up Re: compiz problem

    thx guys for the help and the tutorial is great ijbreakey,
    and about your question gogalthorp,Yes I've seen Kwin and I liked it but I want a specefic effect (make windows burn when they are closed) tha's all.

    thx and see you around

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •