Results 1 to 6 of 6

Thread: How do I dissable CLI SAPI

  1. #1

    Question How do I dissable CLI SAPI

    Hello,
    I made some setting changes in my php.ini but they did not take affect even after a reboot. I then realized these settings are being overriden by CLI SAPI. I searched the web for how to dissable this. I found many posts that said to run the ./configure --dissable cli. However, I cannot find the configure command or file anywhere in SuSE 11.2. The txt below is a section of my php.ini I'm trying to configure. However, as you can see the description text says its being overriden by CLI SAPI. I checked yast breifly but could not find anything either. I'm a linux newbee so detailed steps would be great . Please help. Thx

    ; Maximum amount of time each script may spend parsing request data. It's a good
    ; idea to limit this time on productions servers in order to eliminate unexpectedly
    ; long running scripts.
    ; Note: This directive is hardcoded to -1 for the CLI SAPI
    ; Default Value: -1 (Unlimited)
    ; Development Value: 60 (60 seconds)
    ; Production Value: 60 (60 seconds)
    ; PHP: Runtime Configuration - Manual
    max_input_time = 1000

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: How do I dissable CLI SAPI

    I can not answer your question, but I have some guesses here.

    The ./configure --dissable cli is a statement belonging to the sequence of building the product yourself from source. This also means that, onece the product is build, this most probably is "hard-coded" (as you also show above) and not configurable from a run time configuration file.

    Thus I am afraid that getting the source (a tarball) from somewhere and building yourself is the only option.
    Henk van Velden

  3. #3

    Unhappy Re: How do I dissable CLI SAPI

    Wow. So basically, php.ini is worthless for making changes in opensuse out of the box?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Default Re: How do I dissable CLI SAPI

    Quote Originally Posted by ktsuse View Post
    Wow. So basically, php.ini is worthless for making changes in opensuse out of the box?
    openSUSE is linux, php5 is php5, so settings things in /etc/php5/apache2/php.ini should work. Sure it's not overruled by one of the other settings? If you want to check, simply rename the 2 instances of php.ini:
    Code:
    /etc/php5/apache2/php.ini
    
    /etc/php5/cli/php.ini
    I don't have much experience on the technical part of php you're referring to, yet have done quite some manual changes to php.ini, as a habit I restart apache2.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: How do I dissable CLI SAPI

    ; Note: This directive is hardcoded to -1 for the CLI SAPI
    When you say you have the above from the PHP manual, then I do not quite understand who you want to blame for it. It is hard-coded by the PHP people. And web-sites told you that you can remove the whole functionality by building the product with ./configure --dissable cli. That is clear enough imho.

    It is not openSUSE, it is not Linux (the kernel) it is the PHP programmers who made it like that. When you want it different, build for yourself and be glad that it can be done with just one parameter. The alternative would have been to change the source itself. Which is the ultimate goal of Open Source: when you are not satisfied how it is, you can have the source and change to your taste.
    Henk van Velden

  6. #6

    Default Re: How do I dissable CLI SAPI

    Hey Knurpt,
    Thanks for the clarification. I was able to modify the php.ini at /etc/php5/apache2/php.ini and the changes took affectI'm a linux newbee so I didn't realize there were different php.ini files. Thanks much!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •