Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: ERROR: translation is neither enabled nor disabled  for this file

  1. #1

    Default ERROR: translation is neither enabled nor disabled  for this file

    Hi,

    I've got the above error when building for 11.1. The question is how to enable or disable translation for desktop files?

    BTW I use %suse_update_desktop_file -n in %install section.

    Regards,
    Mikhail

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,175
    Blog Entries
    15

    Default Re:

    Quote Originally Posted by termim
    Hi,

    I've got the above error when building for 11.1. The question is how to
    enable or disable translation for desktop files?

    BTW I use %suse_update_desktop_file -n in %install section.

    Regards,
    Mikhail
    Hi
    Can you provide a link to your package, or the name?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 15:58, 2 users, load average: 0.32, 0.20, 0.12
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  3. #3

    Default Re: ERROR: translation is neither enabled nor disabled  for this file


  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,175
    Blog Entries
    15

    Default Re:

    Hi
    You need to add the GenericName= entry to the desktop file, you might
    also want to remove the png extension from the icon references as well.

    I think when you translate, it greates the GenericName, since your
    not, it needs to be included otherwise it won't pass the brp checks.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 17:39, 3 users, load average: 0.11, 0.07, 0.08
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,175
    Blog Entries
    15

    Default Re:

    Quote Originally Posted by malcolmlewis
    Hi
    You need to add the GenericName= entry to the desktop file, you might
    also want to remove the png extension from the icon references as well.

    I think when you translate, it greates the GenericName, since your
    not, it needs to be included otherwise it won't pass the brp checks.
    Hi
    This should help, use the -G option;
    http://en.opensuse.org/SUSE_Package_...e_desktop_file

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 17:48, 3 users, load average: 0.08, 0.10, 0.09
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  6. #6

    Default Re: ERROR: translation is neither enabled nor disabled  for this file

    Thanks Malcolm, providing a generic name did the trick. Do you know what gives this misleading error message? I couldn't find it in brp-check-syse-1.0. Whatever it is it probably deserves a bug report.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,175
    Blog Entries
    15

    Default Re:

    Quote Originally Posted by termim
    Thanks Malcolm, providing a generic name did the trick. Do you know what
    gives this misleading error message? I couldn't find it in
    brp-check-syse-1.0. Whatever it is it probably deserves a bug report.
    Hi
    No bug, it told you in the raw log the exact error about the
    GenericName I see you have rebuilt and I never captured the output
    myself....

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 21:59, 2 users, load average: 0.47, 0.25, 0.15
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  8. #8

    Default Re: ERROR: translation is neither enabled nor disabled  for this file

    Whatever you call it, it is gone now. Just to test your explanation I've removed GenericName from the desktop files and the build was successful now! It gives two warnings for every desktop file - one for missing GenericName (from brp-desktop) and one for untranslated-desktop-file (from rpmlint I suppose).

    I've noticed also another misleading message in the build log:
    "Your desktop file hasn't been handled by %suse_update_desktop_file Please use
    it to make the desktop file translate-able by Novell translations."
    While several hundreds lines above this message there are logged calls to suse_update_desktop_file.

    You can see the raw log here https://build.opensuse.org/package/rawlog?arch=i586&package=wxpython&project=home:termim:branches:devel:languagesython&repository=openSUSE_11.1

    It would be very interesting to understand where this unstable behavior came from.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,175
    Blog Entries
    15

    Default Re:

    Quote Originally Posted by termim
    Whatever you call it, it is gone now. Just to test your explanation I've
    removed GenericName from the desktop files and the build was successful
    now! It gives two warnings for every desktop file - one for missing
    GenericName (from brp-desktop) and one for untranslated-desktop-file
    (from rpmlint I suppose).

    I've noticed also another misleading message in the build log:
    "Your desktop file hasn't been handled by %suse_update_desktop_file
    Please use
    it to make the desktop file translate-able by Novell translations."
    While several hundreds lines above in this message there are logged
    calls to suse_update_desktop_file.

    You can see the raw log here http://tinyurl.com/22ooqy9
    Hi
    You can get rid of the WARNING: file extension in Icon line by
    removing .png from icon=

    Why not let it translate the desktop entry?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 1 day 16:27, 2 users, load average: 0.01, 0.05, 0.07
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  10. #10

    Default Re: ERROR: translation is neither enabled nor disabled  for this file

    Why not let it translate the desktop entry?
    Because there is no meaningful translation for Editra for example and I doubt it could invent one?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •