Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: OpenOffice Writer problems

  1. #1
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    198

    Thumbs down OpenOffice Writer problems

    1. Cannot paste URL
      When I middle-paste into the URL box in the Hyperlink toolbar, nothing happens.
    2. Misleading support link
      The support link in Help/Support shows the general Novell support page. It is not clear how to get support for OpenOffice from there (especially for openSuSE).
    3. Hyperlink toolbar button performs no action
      In order to place a hyperlink at the cursor, you have to click the pull-down menu by the hyperlink button on the toolbar. Clicking on the button has no effect. I think it should be equivalent to inserting the hyperlink as text.
    4. Persistent extending hyperlink mode
      When you place the insertion point immediately following a hyperlink and start typing, the hyperlink text extends; there is no way to cancel that effect.
      In particular, in the situation when a new document contains only a hyperlink, everything you type, either in front or at the end, becomes a part of it. The only way out of this situtation is to clear the hyperlink text and press Enter; the hyperlink is then replaced with an explicit URL and you can type further without extending the hyperlink.
    5. No apply on Close
      There is another undocumented button in the Standard Toolbar that opens the Hyperlink dialog box. This box behaves in a very peculiar way: when you click on the button [Close], the box closes without updating anything. In order to apply the changes you have to press [Apply] and only then [Close]. This is rather surprising (at least for me), although it is better understandable when you consider that the Hyperlink dialog box is modeless.
    6. Travelling paste
      Steps to reproduce:
      1. Edit a long document (containing several pages).
      2. Mark some text on Page 1.
      3. Middle-paste the text on Page 3.
      Observe how you get transferred back to Page 1.

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,044

    Default Re: OpenOffice Writer problems

    Sounds like something that should be reported as a bug at openoffice.org.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator

  3. #3
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    198

    Thumbs down Re: OpenOffice Writer problems

    Quote Originally Posted by hendersj View Post
    Sounds like something that should be reported as a bug at openoffice.org.
    #2 is a Novell thing. I hoped to get the directions how to report these things but #2 got in the way.

  4. #4
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    198

    Default Re: OpenOffice Writer problems

    #5 is invalid; it turns out it works as documented, so my surprise is my problem :-(

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,654

    Default Re: OpenOffice Writer problems

    Did you install the help package. AFAIK help is not installed by default. Most likely because of limited space on the install media and a bunch of potential languages. Check in Yast

    As to copy and paste if you run KDE check the settings in Klipper. In my opinion the defaults are weird. For Gnome I don't know.

  6. #6
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    198

    Question Re: OpenOffice Writer problems

    #1: It turns out that middle-paste is undocumented and probably unsupported. This leaves the question open how to officially paste marked text into OO. I tried xcutsel but it does not seem to work either way.

  7. #7
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    198

    Post Re: OpenOffice Writer problems

    Quote Originally Posted by gogalthorp View Post
    Did you install the help package. AFAIK help is not installed by default.
    Yes, OO online help is installed, only it was sort of hard to find the right page.

  8. #8
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,044

    Default Re: OpenOffice Writer problems

    On Tue, 01 Jun 2010 16:16:02 +0000, yecril71pl wrote:

    > hendersj;2171625 Wrote:
    >> Sounds like something that should be reported as a bug at
    >> openoffice.org.
    >>
    >>

    > #2 is a Novell thing. I hoped to get the directions how to report these
    > things but #2 got in the way.


    I see - you didn't ask about how to report these things, so it wasn't
    clear what you were asking.

    bugzilla.novell.com tracks bugs in openSUSE.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator

  9. #9
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    198

    Lightbulb Re: OpenOffice Writer problems

    Quote Originally Posted by yecril71pl View Post
    I tried xcutsel but it does not seem to work either way.
    Of course, xcutsel is a tool for converting between X11R2 and X11R3. However, as described there, xclipboard does the trick. Equivalent functionality is available as Klipper: in order to be able to paste into OO, it suffices to click on the text in the Klipper. Problem solved.
    Last edited by yecril71pl; 01-Jun-2010 at 11:47. Reason: additional information

  10. #10
    Join Date
    Apr 2010
    Location
    Warsaw, Poland
    Posts
    198

    Angry Re: OpenOffice Writer problems

    Ouch! An attempt to add a comment to Novel Documentation produces the following error, exposing the internals of the Novell server:

    Warning: file_get_contents(http://doccomments.provo.novell.com/...nance/incoming) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error in /inet/developer/docroot/docadd/add.php on line 22

    Warning: Cannot modify header information - headers already sent by (output started at /inet/developer/docroot/docadd/add.php:22) in /inet/developer/docroot/docadd/add.php on line 23

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •