Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: HotKeys won't turn back on

  1. #1

    Default HotKeys won't turn back on

    I accidentally turned off hotkeys (so now print screen button won't work) so I turned the service back on (in "configure desktop") by hitting "start" but the "print screen" button still won't work. Any ideas how to get it restarted?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,871

    Default Re: HotKeys won't turn back on

    Do you mind telling which desktop, KDE, Gnome, other? Then people who know more about that particular one can concentrate on this problem and others can do other usefull things.

    Did you logout / login after the change?
    Henk van Velden

  3. #3

    Default Re: HotKeys won't turn back on

    Quote Originally Posted by hcvv View Post
    Do you mind telling which desktop, KDE, Gnome, other? Then people who know more about that particular one can concentrate on this problem and others can do other usefull things.

    Did you logout / login after the change?
    KDE and no I didn't log out. Thanks, I'll try that.

    UPDATE: Logging out/in doesn't fix it.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,871

    Default Re: HotKeys won't turn back on

    OK, I have openSUSE 11.2 and KDE 4.3.5 here (you realy should try to remember that people like to know those sort of basic data when you ask for help). But I have a translation, thus the wording you see might be a bit different because of my "reversed translating".

    In Kmenu > Configure Desktop I find the General tab and then in Computer management: Keyboard and mouse. Within there I see Standard hotkeys and Global hotkeys. Is it there where you changed things? I ask because i do not see a "Switch off all Hotkeys" thingy nor a "Start" one that you say you "hit".
    Henk van Velden

  5. #5

    Default Re: HotKeys won't turn back on

    Quote Originally Posted by hcvv View Post
    OK, I have openSUSE 11.2 and KDE 4.3.5 here (you realy should try to remember that people like to know those sort of basic data when you ask for help). But I have a translation, thus the wording you see might be a bit different because of my "reversed translating".

    In Kmenu > Configure Desktop I find the General tab and then in Computer management: Keyboard and mouse. Within there I see Standard hotkeys and Global hotkeys. Is it there where you changed things? I ask because i do not see a "Switch off all Hotkeys" thingy nor a "Start" one that you say you "hit".
    Sorry.

    * OpenSUSE 11.2
    * KDE 4.3.5

    Configure Desktop -> (Advanced Tab) -> Service Manager

    At the bottom, you'll find the KHotKeys service.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,871

    Default Re: HotKeys won't turn back on

    Yeah! Found it (one learns something new every day).

    And I see the "Start" you mean also. Hmpf, never ventured there. I suppose you checked that it is checked and that "active" is shown. I agree with you that when you switch this off and then on, it should work as before. Looks like a bug.

    I am afraid we should go for try, error and intelligent guessing. I went to ~.kde4/share/config/ and searched for files with 'hotk' (case insensitive) in it. Found kglobalshortcutsrc and khotkeysrc. In both I find references to PrintScreen. Both are some hundreds of lines and a bit to big to post here.

    You could use YaST > Security and Users > Users to create a new user. Log in there to create fresh default ~/.kde4/... files. Then you could compare the corresponding files in both $HOME/.kde4/.... with e.g. diff. And then comes the intelligent guessing part .

    HTH

    PS. When you think you found it but are not sure, post here first before editing.

    PPS. Of course make copies of a file before you go editing, if it becomes worse, just copy back (a bit of a superfluous remark, but better save then sorrow).
    Henk van Velden

  7. #7

    Default Re: HotKeys won't turn back on

    Quote Originally Posted by hcvv View Post
    I am afraid we should go for try, error and intelligent guessing. I went to ~.kde4/share/config/ and searched for files with 'hotk' (case insensitive) in it. Found kglobalshortcutsrc and khotkeysrc. In both I find references to PrintScreen. Both are some hundreds of lines and a bit to big to post here.
    Ok, in ~/.kde4/share/config/khotkeysrc:

    There were a number of diff's with uuid's, I'm leaving those alone.

    The only (I believe) relevant diffs:

    Code:
    ...line 45...
    
    /* Problem file */
    Comment=Basic Konqueror gestures.
    DataCount=14
    Enabled=false
    Name=Konqueror Gestures
    SystemGroup=0
    Type=ACTION_DATA_GROUP
    
    /* OK file */
    Comment=Basic Konqueror gestures.
    DataCount=14
    Enabled=true
    Name=Konqueror Gestures
    SystemGroup=0
    Type=ACTION_DATA_GROUP
    
    
    ...line 860...
    
    /* Problem file */
    [Data_4]
    Comment=This group contains actions that are set up by default.
    DataCount=1
    Enabled=false
    Name=Preset Actions
    SystemGroup=0
    Type=ACTION_DATA_GROUP
    
    /* OK file */
    [Data_4]
    Comment=This group contains actions that are set up by default.
    DataCount=1
    Enabled=true
    Name=Preset Actions
    SystemGroup=0
    Type=ACTION_DATA_GROUP

  8. #8

    Default Re: HotKeys won't turn back on

    Argh! Changing that to true did nothing. And the ref. to PrintScreen key is set to true!

    Code:
    [Data_4_1]
    Comment=Launches KSnapShot when PrintScrn is pressed.
    Enabled=true
    Name=PrintScreen
    Type=SIMPLE_ACTION_DATA
    BUT, I did find smoething interesting! I have no "kglobalshortcutsrc" file in my current .kde4!!

    What should I do? Is there a way to generate this via some KDE GUI?

  9. #9

    Default Re: HotKeys won't turn back on

    Well, I got it working again, but in a round-about way. I went to Menu Editor (right click on the kickoff launcher's icon and select "Menu Editor"). Then I found ksnapshot under

    Utilities->Desktop-KSnapshot

    Then on the "Advanced Tab", I clicked to give it a shortcut key and pressed the "PrintScreen" button and now it works!

    Still no idea why I couldn't re-enable all the hot keys by toggling what undid them.

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,871

    Default Re: HotKeys won't turn back on

    Did you make a test user? And does it also not have a kglobalshortcutsrc?

    Strange. Just looked to mine. The timestamp was at the loggin time this morning, thus I guess it is changed "normalY' at KDE login.

    It is 269 lines long. I am willing to spend you a copy. You can find it here:
    http://www.xs4all.nl/~hcvv/kglobalshortcutsrc

    EDIT: you wre justt one minute to early!
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •