Results 1 to 8 of 8

Thread: Here we go again - Java not working

  1. #1

    Unhappy Here we go again - Java not working

    Running on openSUSE 11.0.

    So in order to fix major problems with Firefox 3.6.3 crashing on YouTube and Gmail, I downloaded and placed Firefox 3.6.4 beta in one of my directories out of the PATH, so I have to run it manually (for the moment).

    I have 64-bit Flash installed and that works - YouTube doesn't crash, nor does Gmail.

    Now I want to get 64-bit Java Firefox plugin working.

    I installed using Yast the 64-bit Java. For some reason the Java plugin libnpjp2.so was NOT installed, so I used Zypper to install it.

    I ran update-alternatives --config java and selected the lib64 Java.

    Then I placed a symlink between every place involving Firefox plugins I could thinks of - meaning the plugins directory in my Firefox 3.6.4 directory, ~/.mozilla/plugins, /usr/lib64/mozilla/plugins, /usr/lib64/firefox/plugins - and STILL Firefox 3.6.4 cannot see Java anywhere, neither in Add-Ons or in about plugins.

    What am I doing wrong?

  2. #2
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Here we go again - Java not working

    Quote Originally Posted by richardstevenhack View Post
    I installed using Yast the 64-bit Java. For some reason the Java plugin libnpjp2.so was NOT installed, so I used Zypper to install it.
    That doesn't sound right. As far as I know, Sun's Java plugin is the only package that provides libpjp2.so, so there is something wrong here, for sure.

    Unless you installed the openJDK version? That one doesn't come with libnpjp2, I believe.
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  3. #3

    Default Re: Here we go again - Java not working

    OK, now I'm confused. Maybe I installed a developer's bundle? Apparently so, since the JRE description in Yast says "intended for software developers", although that's what it always says, I think, since that's what the JRE is for. However, the packages URL site says the bundles are also only for developers.

    Whatever. I'm going to delete that, download a new package from Sun and set that up using their instructions. We'll see.

  4. #4

    Default Re: Here we go again - Java not working

    Why does Sun's site say use the 32-bit version for Java applet and Web Start support? It still says "For Java Plug-in and Java Web Start on 64-bit Linux systems, support is not offered at this time." I thought they HAD a 64-bit plugin finally!

    As an aside, I wish Web sites would put a DATE on EVERY PAGE they have, so I can tell when things are happening! Reading about something you can't tell if it's "this month" or "last year".

    Every **** piece of info I can find is from 2009, 2008, 2007 or bloody hell 2005!

    Can't anybody please post a SIMPLE description of how to use 64-bit Java on openSUSE that is current for the current Java release?

    IS there a 64-bit browser PLUGIN - not just 64-bit JAVA - for Linux or not?

  5. #5

    Default Re: Here we go again - Java not working

    I'm going to try this guy's advice exactly as he did it (minus the 32-bit versioning): Install Java JRE 1.6.0 (Update x) in Linux as the Default Java Runtime, including Firefox Browser Plugin PVA – Archives

    Back in a minute.

  6. #6

    Default Re: Here we go again - Java not working

    Nope. Didn't work. I get the java -version response fine.

    Firefox 3.6.4 STILL can't see it at all.

    This is a total nightmare.

    NOBODY knows how to get CURRENT Java working in openSUSE!

    I give up.

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Here we go again - Java not working

    3.6.4 is still beta right? Try dropping back a version. ANd on OpenSuse 11.0?? So you are trying cutting edge tech on a OS that is just about to retire.

    I to am surprised it does not work

  8. #8

    Default Re: Here we go again - Java not working

    Yes, 3.6.4 is still beta, but it's been very stable so far. No crashes yet, although the Bugzilla bug list is unnerving. But the reason I'm using it is that it isolates plugins so a Flash crash doesn't bring down the whole browser, supposedly. And that's exactly what was happening to me on 3.6.3 - both YouTube and Gmail would instantly crash it!

    Yes, I'm still on 11.0. Until I backup all my **** onto an external hard drive, then I'll move to 11.2. Should be soon.

    I think the problem may be that the Firefox 3.6.4 beta is probably 32-bit, not 64-bit. It says it's "i686 (x86_64)", but that may just be referring to the Linux it's running on. Maybe 32-bit Firefox just doesn't work with 64-bit plugins. Only I don't know why the Flash 64-bit plugin works...

    The hell with it. In a short while I'll upgrade to 11.2 and maybe it won't matter then - maybe everything will "just work".

    Yeah, right... Never in my thirty years of working with computers has anything "just worked". It's like Woody Allen said: "Nothing works and nobody cares."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •