Results 1 to 9 of 9

Thread: Update problems

  1. #1
    Join Date
    Nov 2008
    Location
    Sweden
    Posts
    60

    Default Update problems

    When i was about to update it came up:

    Code:
    DBus error : Unable to get transaction id from packagekit.
    Then it asked if i will start YaST and install the updates manual and i then took OK and this came up?

    Code:
    DBus error : Unable to get transaction id from packagekit.
    openSUSE 11.2 x64 KDE 4.3.5

  2. #2
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Default Re: Update problems

    Quote Originally Posted by RimFrost View Post
    When i was about to update it came up:

    Code:
    DBus error : Unable to get transaction id from packagekit.
    Then it asked if i will start YaST and install the updates manual and i then took OK and this came up?

    Code:
    DBus error : Unable to get transaction id from packagekit.
    RimFrost, we need more information. How were you trying to update, using zypper, yast, or other? What was the output before the dbus message? What version of openSUSE were you trying to update and to what? Be verbose, we can filter out what isn't needed. Many tend to bypass messages that don't have relevant info.

    Post more info and we'll try to help.

    Tom
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  3. #3
    Join Date
    Nov 2008
    Location
    Sweden
    Posts
    60

    Default Re: Update problems

    Quote Originally Posted by tommyttt View Post
    RimFrost, we need more information. How were you trying to update, using zypper, yast, or other? What was the output before the dbus message? What version of openSUSE were you trying to update and to what? Be verbose, we can filter out what isn't needed. Many tend to bypass messages that don't have relevant info.

    Post more info and we'll try to help.

    Tom

    If you have read my signature you had known what openSUSE version i run. It stands there.

    To start with, it seems that the updater applet cant scan/download updates.

    It tells me that there is updates available for the system and when i click the icon for the updater applet and try to start update the message starts to appear as i told you. I did try to restart the system to see if there where any more messages that came, but no only this:

    Code:
    DBus error : Unable to get transaction id from packagekit.
    And there isnt any other messages!
    It just tells me the message above when i click the updater applet icon and will try to start update the system.

    I have post the rong message from the updater applet exactly as it appears.
    If it had been more messages i had posted them.
    openSUSE 11.2 x64 KDE 4.3.5

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: Update problems

    Just a passing thought: sometimes over the years in various versions of openSUSE when the updater applet plays up for me I use yast instead and that seems to fix the situation. I goto Yast --> software --> online update and run it from there. Then the applet seems to correct itself.

    Maybe that will fix it for you, maybe it won't, worth a try.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Nov 2008
    Location
    Sweden
    Posts
    60

    Default Re: Update problems

    Quote Originally Posted by swerdna View Post
    Just a passing thought: sometimes over the years in various versions of openSUSE when the updater applet plays up for me I use yast instead and that seems to fix the situation. I goto Yast --> software --> online update and run it from there. Then the applet seems to correct itself.

    Maybe that will fix it for you, maybe it won't, worth a try.
    Ok thanks.

    I did try that now and when i go YaST >> Software >> Online Update
    another message comes up from Kdialog:

    Code:
    Error while creating client module online_update
    And nothing happens? My opeSUSE system is new-installed, i did a clean fresh install of it yesterday, at first the updates worked fine and out of nowhere this error messages start to came

    However after google the problem i came across this link: [Bug 551648] kupdateapplet fails with "DBus error : Unable to get transa

    This dude seems to have the same problem as me with this "DBus error". Dont know if any solution is in the link, i dont understand german that good.
    openSUSE 11.2 x64 KDE 4.3.5

  6. #6
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Update problems

    You can use swerdna's advice using the ncurses version of Yast. Just open a terminal and type

    Code:
    sudo yast
    or

    Code:
    su
    It will ask for root password
    Code:
    yast
    You have to use tab to navigate through but I've never had a failure using this version of Yast.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  7. #7
    Join Date
    Nov 2008
    Location
    Sweden
    Posts
    60

    Default Re: Update problems

    Quote Originally Posted by ijbreakey View Post
    You can use swerdna's advice using the ncurses version of Yast. Just open a terminal and type

    Code:
    sudo yast
    or

    Code:
    su
    It will ask for root password
    Code:
    yast
    You have to use tab to navigate through but I've never had a failure using this version of Yast.

    Take Care,

    Ian

    I try it now and navigate to "Online Update" and its the same error message even in the terminal:

    Code:
    # yast
    Error while creating client module online_update
    Then i try to go to Add/Remove Software (its the second option in the list) and it gave me:

    Code:
    # yast
    Error while creating client module sw_single

    On Online Update Configuration it was:

    Code:
    # yast
    error while creating client module online_update_configuration
    Im starting to think that YaST might be broken?
    openSUSE 11.2 x64 KDE 4.3.5

  8. #8
    Join Date
    Nov 2008
    Location
    Sweden
    Posts
    60

    Default Re: Update problems

    I did a new install of it, so now it seem to work as it shall again.
    openSUSE 11.2 x64 KDE 4.3.5

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: Update problems

    Quote Originally Posted by RimFrost View Post
    I did a new install of it, so now it seem to work as it shall again.
    That does sound like an injury in Yast's sotware management module.

    Perhaps the result of getting a dependency issue wrong, or of attaching the wrong repository, or a hiccup in downloads/power during the installation.

    Anyway, great it's going now after the reinstall.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •