Results 1 to 9 of 9

Thread: Wireless network not working !!

  1. #1

    Default Wireless network not working !!

    Hi, I'm having trouble getting wireless internet access. Here is information about my problem and my hardware (64 bit Dell M1330 shipped with Windows):

    'Wireless LAN' entry not found under YaST =>Hardware=>Hardware Information

    Under PCI entry:
    UDI: /org/freedesktop/Hal/devices/pci_14e4_4328

    /usr/sbin/iwconfig ==>
    lo no wireless extensions.
    Eth0 no wireless extensions.

    /sbin/lspci | grep Network ==>
    0c:00.0 Network controller: Broadcom Corporation BCM4328 802.11a/b/g/n (rev 03)

    Command dmesg | grep firmware returned no results, and I have run the command to install the 48xx firmware.

    dmesg ==> *These were the only lines I found related to my card, rest omitted*
    [ 5.903041] b43-pci-bridge 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 5.903050] b43-pci-bridge 0000:0c:00.0: setting latency timer to 64

    /usr/sbin/iwlist scan ==>
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    I'm not really sure what the problem is, but my guess is that the wireless card is found in a PCI slot but is not being recognized as a wireless card for some reason. Any help would be greatly appreciated, and let me know if I can obtain more information that will be useful in finding a solution. Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Wireless network not working !!

    If you have a wired connection we can sort this easily. But please post result of this from a terminal

    Code:
    uname -a
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Wireless network not working !!

    Your problem is that Broadcom BCM4328 does not work with the loaded drivers (ssb, bl43). You need to use the wl driver for this.

    As suggested by caf4926, see the kernel version. It should be 2.6.31.12-0.2
    If it is not, make sure that you update the system via the wired connection.

    Once, this is done, add Packman repo and install broadcom-wl drivers:
    Code:
    zypper broadcom-wl
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  4. #4

    Default Re: Wireless network not working !!

    Code:
    xait9@linux-1kp7:/usr/src/linux> uname -a
    Linux linux-1kp7 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux
    I have been trying to upgrade my kernel version to the one that you guys specified, but I ran into problems (posted here)

    Any advice for upgrading my kernel? Is there a way to patch the part needed for wireless internet? Thanks for your responses, I am confident that I will be able to get the wireless working once I can figure out how to update the kernel.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Wireless network not working !!

    The latest kernel has built in support for your needs. I have tried it, but find the driver from packman better.

    Please do this. If you know you have the Packman repo you can skip this part: In a su - terminal do

    Code:
    zypper ar -f http://packman.unixheads.com/suse/11.2/ packman
    Code:
    zypper ref
    accept key/licence

    Once you have Packman repo:

    Code:
    zypper in broadcom-wl broadcom-wl-kmp-desktop
    when it's done, reboot
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Wireless network not working !!

    Nice! I made some progress by installing the packman repo and run
    Code:
    zypper in broadcom-wl broadcom-wl-kmp-desktop
    Now, the wlan interface is at least recognized, but when I first selected to connect to my home network, it starts to load up but gets stuck on "Configuring interface" and fails to fully connect, then kind of restarts and keeps trying to connect without success.

    Now, after a reboot, it isn't even finding my home network (although it is present under Manage Connections [V3xT3 -- Last used: Never] presumably from the time I was able to pick up the signal), which my brother verifies from right next to me is working with a strong signal (and we are only about 10 meters away from the access point).

    Code:
    xait9@linux-1kp7:~> dmesg | grep eth
    [    7.905041] eth0: Broadcom BCM4328 802.11 Hybrid Wireless Controller 5.60.48.36 
    [    7.959335] eth1: Tigon3 [partno(BCM95906) rev c002] (PCI Express) MAC address 00:21:9b:e8:e0:46
    [    7.959342] eth1: attached PHY is 5906 (10/100Base-TX Ethernet) (WireSpeed[0])                  
    [    7.959346] eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[0]                            
    [    7.959350] eth1: dma_rwctrl[76180000] dma_mask[64-bit]                                         
    [    7.964661] eth0 renamed to eth0_rename by udevd [380]
    [    8.010401] eth1 renamed to eth0 by udevd [371]
    [    8.011500] udev: renamed network interface eth1 to eth0
    [    8.015832] eth0_rename renamed to eth1 by udevd [380]
    [    8.016975] udev: renamed network interface eth0_rename to eth1
    [   32.047507] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   42.881262] eth1: no IPv6 routers present
    [  302.707812] tg3: eth0: Link is up at 100 Mbps, full duplex.
    [  302.707812] tg3: eth0: Flow control is on for TX and on for RX.
    [  302.709350] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [  304.849414] martian source 255.255.255.255 from 169.254.1.192, on dev eth0
    [  313.579174] eth0: no IPv6 routers present
    [  789.295246] tg3: eth0: Link is down.
    [  803.872257] tg3: eth0: Link is up at 100 Mbps, full duplex.
    [  803.872257] tg3: eth0: Flow control is on for TX and on for RX.
    [  805.413684] martian source 255.255.255.255 from 169.254.1.192, on dev eth0
    [ 1027.118865] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 1028.728726] tg3: eth0: Link is up at 100 Mbps, full duplex.
    [ 1028.728726] tg3: eth0: Flow control is on for TX and on for RX.
    [ 1028.729367] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 1039.182086] eth0: no IPv6 routers present
    [ 1045.388067] eth1: no IPv6 routers present
    [ 1090.520934] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 1092.106315] tg3: eth0: Link is up at 100 Mbps, full duplex.
    [ 1092.106330] tg3: eth0: Flow control is on for TX and on for RX.
    [ 1092.107166] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 1095.770909] martian source 255.255.255.255 from 169.254.1.192, on dev eth0
    [ 1102.729471] eth0: no IPv6 routers present
    [ 1127.228806] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 1128.817482] tg3: eth0: Link is up at 100 Mbps, full duplex.
    [ 1128.817482] tg3: eth0: Flow control is on for TX and on for RX.
    [ 1128.819031] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 1137.286297] eth1: no IPv6 routers present
    [ 1139.246147] eth0: no IPv6 routers present
    [ 1257.848011] SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.1.10 DST=130.57.4.15 LEN=40 TOS=0x00 PREC=0x00 TTL=64 ID=0 DF PROTO=TCP SPT=48293 DPT=443 WINDOW=0 RES=0x00 RST URGP=0
    [ 1406.165019] tg3: eth0: Link is down.
    [ 1521.956995] tg3: eth0: Link is up at 100 Mbps, full duplex.
    [ 1521.956995] tg3: eth0: Flow control is on for TX and on for RX.
    [ 1523.338968] martian source 255.255.255.255 from 192.168.1.4, on dev eth0
    ^^^^This output was generated while I was connected to the working wired connection.

    Code:
    xait9@linux-1kp7:~> /usr/sbin/iwconfig
    lo        no wireless extensions.
    
    eth1      IEEE 802.11  Access Point: Not-Associated
              Link Quality:5  Signal level:0  Noise level:0
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    
    eth0      no wireless extensions.
    Code:
    xait9@linux-1kp7:~> sudo /usr/sbin/iwlist scan
    root's password:                              
    lo        Interface doesn't support scanning. 
    
    eth1      Failed to read scan data : Invalid argument
    
    eth0      Interface doesn't support scanning.
    Any suggestions? Hopefully I didn't mess up any necessary files while trying to upgrade kernel versions. My /usr/src/ directory only has a directory called packages in it now, as I deleted all the files that I had put in it to try to upgrade to 2.6.31.12.0.2

    Code:
    xait9@linux-1kp7:~> uname -a
    Linux linux-1kp7 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux
    Although I didn't finish upgrading properly, the uname commmand returns the version number that I was trying to upgrade to... Maybe I should do a clean install from the dvd and add the packman driver again from there? Thanks for any help.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Wireless network not working !!

    Although I didn't finish upgrading properly,
    I don't like the sound of that!
    What do you mean?

    Signal level:0
    Is the wireless switched on at the router? are you within range?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Wireless network not working !!

    Hi sorry in my previous post, I think I posted output while my wireless switch was turned off (how embarrassing...).

    When I say that I didn't finish installing properly, I mean that while I was tryingg to upgrade, I wasn't able to make the "make mrproper" command work (as I posted here), so all I really did was download the source for a new kernel into a couple different directories, extracted the files, created some config files, then deleted them all because it didn't work and I was able to make progress on my wireless by installing the packman repo (thanks caf! ).

    Here is the code that I should have previously posted:

    Code:
    xait9@linux-1kp7:~> /usr/sbin/iwconfig
    lo        no wireless extensions.
    
    eth1      IEEE 802.11  Access Point: Not-Associated
              Link Quality:5  Signal level:0  Noise level:165
              Rx invalid nwid:0  invalid crypt:0  invalid misc:0
    
    eth0      no wireless extensions.
    Code:
    xait9@linux-1kp7:~> sudo /usr/sbin/iwlist scan
    root's password:
    lo        Interface doesn't support scanning.
    
    eth1      Scan completed :
              Cell 01 - Address: 00:1F:90:FE:02:58
                        ESSID:"V3XT3"
                        Mode:Managed
                        Frequency:2.437 GHz (Channel 6)
                        Quality:4/5  Signal level:-63 dBm  Noise level:-93 dBm
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                                  11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
    
    eth0      Interface doesn't support scanning.
    Code:
    xait9@linux-1kp7:~> uname -a
    Linux linux-1kp7 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Wireless network not working !!

    Obviously you know how to setup the connection in network manager, putting in the ESSID and network key.

    Have you tried switching off encryption just to see if you can connect to it without?

    Have a look at this
    Getting Your Wireless to Work - openSUSE Forums
    from the heading 'Making a Connection'
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •