Quote Originally Posted by plodder View Post
Very sorry. I appear to have fouled up the thread a little. I rather hoped everybody else had gone to bed (I am in Oz).
LOL! I understand... my eyes are very tired.

I had deleted my last post because I was a little concerned about the boot.ini file which is why I deleted the following post (whilst you were reading and replying to it):

I am not sure why you think grub does not find your partitions. Grub counts its partitions from zero whilst fdisk counts from 1. Hence:

When you get to the grub prompt (grub>) why not try booting your Windows XP directly with the following commands
I just exhausted all the possibilites from 0 thru 5.
4 is the only one that boots up something and that something is the Sony Recovery partition. :sigh:

If that works the solution is fairly simple. We can just change the boot flag to /dev/sda5 using something called cfdisk.
This should be very simple... but, of course, it is on one of MY machines, so it is destined to find some obscure abnormality to plague my day.

Unless I have not understood what the problem is. However maybe boot.ini needs to be modified as well.
I'm going to try modifying the boot.ini file...


I am not sure if the windows boot.ini file lists the partitions in definition order or cylinder order. If it is cylinder order then partition(2) is correct. If it is definition order then partition(3) is correct.

Hence if it is booting into the wrong partition, then I would suggest editing the boot.ini file and changing boot.ini to read partition(3) at the end of the line.

The fact that it is booting into something from (hd0,4) means it is finding an ntldr etc there so we must be close (I hope).
I'm with you on the 'hope'.

So keep using rootnoverify (hd0,4) and change boot.ini.
I may have to quit lest I fall asleep... but will try one chance at it now.