Results 1 to 10 of 10

Thread: libzypp Not found after update

  1. #1

    Default libzypp Not found after update

    Hi,

    First of all i'd like to say hello as this is my first post here. I tried tons of linux distros before i decided on openSuse as it was the first to work out of the box with all my hardware.

    Anyway, to my question/problem, i just run a system update which seemed to complete correctly, however, whenever i try and run the'Install Software' tool i'm given the following error:

    libzypp.so.619=>not found
    warning: the gtk frontend is installed but does not work
    GTK GUI wanted but not found falling back to Qt.
    Error while creating client module online_update_configuration

    I've googled but can't find anything to help with my problem.

    Could somebody here please help a complete linux noob.



    Thanks,
    Andrew

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,857

    Default Re: libzypp Not found after update

    Welcome to our forums.

    As it seems that the "systems update" was instrumental in causing your problem, could you tell what you did. "System update" is a rather vague expression I am afraid. Also, before certain people come her to ask you, an you please post the output of
    Code:
    zypper lr -d
    Henk van Velden

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,518
    Blog Entries
    37

    Default Re: libzypp Not found after update

    I helped an IRC #suse chat user the other day who borgued their zypper by having the update of zypper fail in mid-update, such that they had no zypper and no yast software management.

    We solved the problem by having the user download zypper (and its dependencies) from the "UPDATE" repos, and install zypper (and its dependencies) via rpm command (which was painful) and then fix the problem with yast by running:
    Code:
    zypper ve
    Note that PRIOR to doing this zypper command, we ensured they ONLY had the repos: OSS, Non-OSS, Update and Packman enabled.

    But we succeeded in the end.

  4. #4

    Default Re: libzypp Not found after update

    Thanks guys, i ran the command oldcpu mentioned and it fixed the problem i was having.

    Thanks again.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,518
    Blog Entries
    37

    Default Re: libzypp Not found after update

    Quote Originally Posted by andrewtayloruk View Post
    Thanks guys, i ran the command oldcpu mentioned and it fixed the problem i was having.
    Thats good news. I am glad to read this worked.

  6. #6

    Default Re: libzypp Not found after update

    Quote Originally Posted by oldcpu View Post
    zypper (and its dependencies)
    Do you mean only "Zypper" & "libzypp" ?
    openSUSE.ir

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,518
    Blog Entries
    37

    Default Re: libzypp Not found after update

    Quote Originally Posted by sina_saeedi82 View Post
    Do you mean only "Zypper" & "libzypp" ?
    I mean what ever the rpm command asks for when you try to install with:
    rpm -Uvh < application01.rpm > < application02.rpm > ...
    It will give you dependency warnings ....

    You may need more than just those 2 (I can not remember). When I type: rpm -qR zypper #I get:
    Code:
    procps                          
    libzypp >= 6.31.4               
    permissions                     
    /bin/sh                         
    /bin/sh                         
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1 
    /bin/sh                                
    libaugeas.so.0()(64bit)                
    libaugeas.so.0(AUGEAS_0.1.0)(64bit)    
    libaugeas.so.0(AUGEAS_0.8.0)(64bit)    
    libc.so.6()(64bit)                     
    libc.so.6(GLIBC_2.2.5)(64bit)          
    libc.so.6(GLIBC_2.3.4)(64bit)          
    libc.so.6(GLIBC_2.4)(64bit)            
    libgcc_s.so.1()(64bit)                 
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libm.so.6(GLIBC_2.2.5)(64bit)
    libpthread.so.0()(64bit)
    libpthread.so.0(GLIBC_2.2.5)(64bit)
    libreadline.so.6()(64bit)
    librt.so.1()(64bit)
    librt.so.1(GLIBC_2.2.5)(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(CXXABI_1.3.1)(64bit)
    libstdc++.so.6(GLIBCXX_3.4)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.10)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
    libzypp.so.631()(64bit)
    rpmlib(PayloadIsLzma) <= 4.4.6-1
    and when I type: rpm -qR libzypp #I get:
    Code:
    satsolver-tools = 0.14.17        
    uuid-runtime                     
    gpg2                             
    aria2 >= 1.1.2                   
    libcurl4 >= 7.19.4               
    /bin/sh                          
    /sbin/ldconfig                   
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1 
    /bin/sh                                
    libc.so.6()(64bit)                     
    libc.so.6(GLIBC_2.2.5)(64bit)          
    libc.so.6(GLIBC_2.3)(64bit)            
    libc.so.6(GLIBC_2.3.4)(64bit)          
    libc.so.6(GLIBC_2.4)(64bit)            
    libc.so.6(GLIBC_2.8)(64bit)            
    libcrypto.so.0.9.8()(64bit)            
    libcurl.so.4()(64bit)                  
    libdbus-1.so.3()(64bit)                
    libexpat.so.1()(64bit)                 
    libgcc_s.so.1()(64bit)                 
    libgcc_s.so.1(GCC_3.0)(64bit)          
    libhal-storage.so.1()(64bit)           
    libhal.so.1()(64bit)                   
    libm.so.6()(64bit)
    libm.so.6(GLIBC_2.2.5)(64bit)
    libpthread.so.0()(64bit)
    libpthread.so.0(GLIBC_2.2.5)(64bit)
    librpm.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(GLIBCXX_3.4)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.10)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
    libutil.so.1()(64bit)
    libutil.so.1(GLIBC_2.2.5)(64bit)
    libxml2.so.2()(64bit)
    libz.so.1()(64bit)
    libzypp.so.631()(64bit)
    rpmlib(PayloadIsLzma) <= 4.4.6-1
    but you likely have most if not all of those already installed.

    I don't think the rabbit hole is too deep.

  8. #8
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: libzypp Not found after update

    Quote Originally Posted by oldcpu View Post
    I helped an IRC #suse chat user the other day who borgued their zypper by having the update of zypper fail in mid-update, such that they had no zypper and no yast software management.
    I've read at least 3 posts today about problems with Online Update and "borgued" zypper. As per the famous line from The Marathon Man: "Is it safe?" to run Online Update, or is there a confirmed problem with a package in the latest updates regarding zypper...?

    I haven't run update in a couple of days, so before I do that, I was just wondering...
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,649

    Default Re: libzypp Not found after update

    For what it is worth I have no problems.

    Several of the problems seem to have happened when a update did not instantly happen and the person aborted midstream

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,518
    Blog Entries
    37

    Default Re: libzypp Not found after update

    Quote Originally Posted by twelveeighty View Post
    I've read at least 3 posts today about problems with Online Update and "borgued" zypper. As per the famous line from The Marathon Man: "Is it safe?" to run Online Update, or is there a confirmed problem with a package in the latest updates regarding zypper...?

    I haven't run update in a couple of days, so before I do that, I was just wondering...
    Its safe to run. Just don't abort in the middle of the update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •