Results 1 to 5 of 5

Thread: Installing Mathlab for Linux (32bit) into openSUSE11.1 (64bit) - error with xsetup

  1. #1
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Installing Mathlab for Linux (32bit) into openSUSE11.1 (64bit) - error with xsetup

    Hi, I am trying to install the Linux version of Mathlab (32bit) into my openSUSE 11.1 (64bit). With STATA this was at the time possible, having installed the 32bit GTK. This is a program running Java. So since I have both 32bit and 64bit Java installed it should work, no?
    Copying files to /usr/local/temp as indicated OK
    Decompressing O.K.
    Code:
    su -
    cd /usr/local/temp
    ./install
    Executing ./install gives following error:
    An error status was returned by the program 'xsetup',
    the X Window System version of 'install'. The following
    messages were written to standard error:

    /usr/local/temp/update/install/main.sh: line 86: /usr/local/temp/update/bin/glnxa64/xsetup: No such file or directory

    Attempt to fix the problem and try again. If X is not available
    or 'xsetup' cannot be made to work then try the terminal
    version of 'install' using the command:

    install* -t or INSTALL* -t
    If I well understand in line 86 the script is calling the 64 bit version of the file gnlxa64 to call the 64 bit version of the program that is not available (as academic version).
    I tried then the command line version.
    Code:
    linux-xu0v:/usr/local/temp # install* -t
    install: option requires an argument -- 't'
    Try `install --help' for more information.
    The only argument I could imagine would be to indicate a directory name? But which one in this case, the one where install is located?

    Anybody succeeded with an install before? Any help appreciated.



    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: Installing Mathlab for Linux (32bit) into openSUSE11.1 (64bit) - error with xsetup

    Could it be a space is missing between 'install' and '*' ? My guess is it should be:
    Code:
    install * -t
    Note the 'glnxa64' in the error message.....Does the installer 'get' the arch?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Re: Installing Mathlab for Linux (32bit) into openSUSE11.1 (64bit) - error with xsetup

    Quote Originally Posted by Knurpht View Post
    Could it be a space is missing between 'install' and '*' ? My guess is it should be:
    Code:
    install * -t
    Note the 'glnxa64' in the error message.....Does the installer 'get' the arch?
    Hello my friend. Thank you for helping. The updater cannot get this directory because in the 32 bit version it does not exist. It was designed to install on a 32bit and 64bit system and then the file is simply not available. I would suppose the fact that no 64bit version is available for academic pricing is linked to a "crippling" of the files provided. So the installer (which comes with a different package) does "understand" to be in the 64 bit OS and searches for the correct directory.....that is naturally not there. This is my guess. The installer did create /usr/local/temp/update/bin/glnx86 where xsetup is then located. Since openSUSE to my knowledge is able to run 64 bit and 32 bit Java applications it should be however possible to run the command line version.


    The install instructions given are as follows:
    1.Create a temporary directory into which you can download files, and then cd into it. For example, to install into the location /usr/local/temp, use these commands:
    cd /usr/local
    mkdir temp
    cd temp
    Subsequent instructions refer to this directory as $TEMP.
    2.Click the Download button for each product and save the file to your $TEMP directory. Some browsers, such as Firefox, save files to a default location, so you may need to configure your browser to prompt for the location to save downloaded files.
    3.In the $TEMP directory, run the command tar -xf matlab_installer_glnx86.tar to expand the installer.
    4.Once you have expanded the installer files in the $TEMP directory, run ./install to install the products. During the installation process, provide the information requested on each screen. For example, on the MATLAB Root Directory screen enter your installation location, such as /usr/local/matlab.
    5.When the installer asks if you want to proceed with activation, click Continue. Activating right after installation is recommended. To get help for any part of the process, click Help on that screen.
    I will now try with the space between install and *.

    Edit:
    linux-xu0v:/usr/local/temp # install * -t
    install: option requires an argument -- 't'

  4. #4
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Re: Installing Mathlab for Linux (32bit) into openSUSE11.1 (64bit) - error with xsetup

    I contacted the official support service and will report an eventual solution provided. Seems not so easy as I thought.

  5. #5
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Thumbs up Re: Installing Mathlab for Linux (32bit) into openSUSE11.1 (64bit) - error with xsetup

    1) Open a terminal window.
    2) In the terminal window, change directories to the location of the installation files. Ex:

    /usr/local/temp (as suggested by the producer)

    3) Launch the installer in text mode with the -glnx86 flag:

    ./install -glnx86 -t

    4) Once the installer is finished, you will need to activate manually from the website as the activation client
    will not launch on a 64-bit Linux machine. To activate manually, see the Related Solution, 1-3YZBZ6.
    (Works as described there, for Linux you have to recover the mac address of the primary Ethernet adapter with
    Code:
    /sbin/ifconfig eth0
    and to activate on the website manually.

    5) Once MATLAB is installed and activated, you will need to run MATLAB using the same -glnx86 flag that
    you used to install. For example:

    $MATLAB/bin/matlab -glnx86 (so here /usr/local/temp/bin/matlab

    (where $MATLAB is the MATLAB installation folder)

    NOTE: Some users have problems loading the JRE when running in this configuration. Creating a symlink
    in $MATLAB/sys/java/jre named 'glnxa64' pointing to 'glnx86' should resolve this issue. You can do this
    with the following command:

    ln -s $MATLAB/sys/java/jre/glnx86 $MATLAB/sys/java/jre/glnxa64

    (where $MATLAB is the MATLAB installation folder)


    When you do all this you can run it from a terminal. But currently I created a link in the start menu KDE3. The icon is in the matlab directory, goes well. In command I put the full path, but the program opens to run a shell window and only then matlab. Just for curiosity, why is this the case? Would like to make it without opening the shell. But for who reads this, the program runs fine with the procedure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •