Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: two questions

  1. #1

    Default two questions

    Hey all, not sure if this is the best place to put it or not, so feel free to move it if you need to, sorry for any inconvenience. I have 2 questions.

    The first is I can't seem to install software. By that I mean I can get into the installer, choose the software and click install, and it installs, but when I go to look for the software its not there. For example, I tried to download wine. I clicked it, and installed it, it went through the installation process, then automatically closed (no window saying installation complete) then when I go to try and install a program with wine (COD4 in this case) I can't fine wine-anywhere. its not in the applications, not in the pop up menu to open with this program, etc. its like this with all software I try to install, updates, or otherwise

    Second question i guess is more media though I think its linked to the first one, when I try to play a movie on DVD I get this message: No URI handler implemented for "DVD" from what I can find it suggests I need to download codecs for it, but Im not sure what codecs, and the codecs I did find it wont let me install due to previous problem.

    Thanks for your time.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: two questions

    Quote Originally Posted by the_patriot2010 View Post
    Hey all, not sure if this is the best place to put it or not, so feel free to move it if you need to, sorry for any inconvenience. I have 2 questions.
    The problem is not where you posted. The problem is your title.

    You need to summarize the specifics of a problem in your title. The experts in our forum want to focus on the area they know best, and answering a question that says "Two questions" is NOT what they want to do.

    So if you have 2 questions you should start 2 threads, with a different more relevant subject in each.

    Quote Originally Posted by the_patriot2010 View Post
    The first is I can't seem to install software. By that I mean I can get into the installer, choose the software and click install, and it installs, but when I go to look for the software its not there.
    I'm not a believe in point and click. Here is a guide with some hints on software installation.
    openSUSE software installation hints - openSUSE Forums

    Quote Originally Posted by the_patriot2010 View Post
    For example, I tried to download wine. I clicked it, and installed it, it went through the installation process, then automatically closed (no window saying installation complete) then when I go to try and install a program with wine (COD4 in this case) I can't fine wine-anywhere. its not in the applications, not in the pop up menu to open with this program, etc. its like this with all software I try to install, updates, or otherwise
    To see if it is installed, query the rpm database for it. You can do that by typing:
    Code:
    rpm -q wine
    or go to YaST > Software > Software Management and search for wine.

    To find where wine is located type:
    Code:
    which wine
    or
    Code:
    whereis wine
    To execute wine ... Lets say you have an MS-Windows program called "autostitch.exe" in the directory /home/patriot2010/pan. To run the program type:
    Code:
    wine /home/patriot2010/pan/autostitch.exe
    Quote Originally Posted by the_patriot2010 View Post
    Second question i guess is more media though I think its linked to the first one, when I try to play a movie on DVD I get this message: No URI handler implemented for "DVD" from what I can find it suggests I need to download codecs for it, but Im not sure what codecs, and the codecs I did find it wont let me install due to previous problem.
    To play a DVD you need libdvdcss (which provides the needed decryption).

    You can install that by copying and pasting and running in a terminal with root permissions the following 3 commands:
    Code:
    zypper ar http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/ videolan
    zypper install libdvdcss
    zypper rr videolan

  3. #3

    Default Re: two questions

    sorry about that, will keep it in mind next time

    I found wine using that search function, but can't seem to get it to run and can't find it at all in the software management.

    I tried downloading the codec manually like you suggested and it gave me a message that cannot access installation media and to check whether the server is accessible or not.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: two questions

    Quote Originally Posted by the_patriot2010 View Post
    I tried downloading the codec manually like you suggested and it gave me a message that cannot access installation media and to check whether the server is accessible or not.
    libdvdcss is NOT a codec. Its a decryption package. There is guidance on codecs here: Multi-media and Restricted Format Installation Guide - openSUSE Forums

    Reference your error message, note you need to have internet running when you send that command. Please copy and paste from the terminal used, the EXACT command you used. I am suspicious of a syntax error.

    Note in the command:
    Code:
    zypper ar http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/ videolan
    between "/11.2/" and "videolan" is a space.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: two questions

    Quote Originally Posted by the_patriot2010 View Post
    I found wine using that search function, but can't seem to get it to run and can't find it at all in the software management.
    If it showed up with "rpm -q wine", then its there in software management. I think you need to search again.

    What is the name of the MS windows executable you are trying to run? What directory is this executable located?

  6. #6

    Default Re: two questions

    ok i looked again and did find wine under software management, sry bout that was looking for the wrong thing, it just wont initialize. what I am trying to do is install COD4MW on the machine using my DVD drive. as far as installing the software, I couldn't remember what exactly the message said so I re ran it.

    david@linux-aiek:~> su
    Password:
    linux-aiek:/home/david # zypper ar Index of /pub/vlc/SuSE/11.2/ videolan
    Adding repository 'videolan' [done]
    Repository named 'videolan' already exists. Please use another alias.
    linux-aiek:/home/david # install libdvdcss
    install: missing destination file operand after `libdvdcss'
    Try `install --help' for more information.
    linux-aiek:/home/david # zypper install libdvdcss
    Download (curl) error for 'http://download.video.org/pub/videolan/vlc/SuSE/11.2/repodata/repomd.xml':
    Error code: Connection failed
    Error message: Couldn't resolve host 'download.video.org'

    Abort, retry, ignore? [a/r/i/?] (a): ^Clinux-aiek:/home/david # ^C
    linux-aiek:/home/david #

    i mistyped the second command the first time as you can see but finally got it right and this is what I got. notice, I never did get to zypper rr videolan

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: two questions

    Quote Originally Posted by the_patriot2010 View Post
    Repository named 'videolan' already exists. Please use another alias.
    I quoted the error. it does not like the alias I used. So type these 4 lines:
    Code:
    zypper rr videolan
    zypper ar http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/ videolan
    zypper install libdvdcss
    zypper rr videolan

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: two questions

    Quote Originally Posted by the_patriot2010 View Post
    linux-aiek:/home/david # zypper install libdvdcss
    Download (curl) error for 'http://download.video.org/pub/videolan/vlc/SuSE/11.2/repodata/repomd.xml':
    Error code: Connection failed
    clearly, the URL is WRONG there.

    It is NOT video.org ! Look again at the exact commands I gave.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: two questions

    Quote Originally Posted by the_patriot2010 View Post
    ok i looked again and did find wine under software management, sry bout that was looking for the wrong thing, it just wont initialize. what I am trying to do is install COD4MW on the machine using my DVD drive.
    I think you should post in our games area Games - openSUSE Forums for that with a title like:
    Code:
    Need help to run COD4MW under wine

  10. #10

    Default Re: two questions

    To play a DVD you need libdvdcss (which provides the needed decryption).

    You can install that by copying and pasting and running in a terminal with root permissions the following 3 commands:
    Code:
    zypper ar http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/ videolan
    zypper install libdvdcss
    zypper rr videolan
    [/QUOTE]


    these are the exact commands you gave me. if it is not .org what is it then?

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •