Results 1 to 4 of 4

Thread: Desktop goes blank after boot, then re-appears when shutdown. How do I fix?

  1. #1
    Join Date
    Jul 2008
    Location
    Melbourne, Australia
    Posts
    64

    Question Desktop goes blank after boot, then re-appears when shutdown. How do I fix?

    Desktop goes blank after boot, then re-appears when shutdown. How do I fix?
    Hi, I turn on computer, it starts fine with the usual green boot screen, the little bar progresses then the screen goes blank. Then when I go to turn off (push power button), the desktop re-appears. What can i do to fix? I need my desktop back (I haven't made any changes to my system since last boot, and I have turned off, pulled cables out, put them in etc...it must be a software issue)
    Thanks if you can suggest something!
    I'm using OpenSuse 11.1 Gnome 32 bit
    Last edited by adstaryoung; 10-May-2010 at 01:55. Reason: .

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Desktop goes blank after boot, then re-appears when shutdown.How do I fix?

    adstaryoung wrote:
    > I haven't made any changes to my system since last boot


    since computers, like a mom's prized vase, don't normally break
    themselves you have only a couple of choices:

    hardware malfunction, or something changed in software..

    those changes can come in several ways:

    -YaST Online Update (YOU) installed some new, updated software
    -a hardware (disk maybe) failure wrote bad info
    -there was a freeze (or something) that caused bad writes
    -there was a forced shutdown not allowing completed writes

    YOU always asks permission prior to updating--did it during the last
    session prior to trouble? if so, maybe it installed a new kernel...do
    you remember if it said to reboot to complete the update?

    if so, and you are using a proprietary graphics driver from nVidia or
    ATI, you probably need to reinstall it to match the new
    kernel....thousands of examples of how to do that already exist in
    these form...._almost_ every thread with the word "blank" or "black"
    in the subject will get you there..

    try a google using the site specifier like this:

    Code:
    site:opensuse.org blank OR black screen OR graphics OR desktop "after
    update" [ati] [nvidia]
    and use ati *or* nvidia, depending on which you have..

    read several from the last few months, along with oldcpu's great
    review in openSUSE Graphic Card Practical Theory Guide for Users
    http://tinyurl.com/ydggvdw i then ask questions if you need..

    --
    DenverD (Linux Counter 282315)
    CAVEAT: http://is.gd/bpoMD
    posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
    2.6.22.19-0.4-default SMP i686
    AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
    CMedia 9761 AC'97 Audio

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,124

    Default Re: Desktop goes blank after boot, then re-appears when shutdown. How do I fix?

    It is not the desktop you see (because you only see that after login), but in both cases the so called Boot splash. The boot splash is shown again when the system shuts dow.

    After the boot, can you go to the console by using Ctrl-Alt-F1 and do you see any messages about problems there? Can also login into the CLI there?
    Henk van Velden

  4. #4
    Join Date
    Jul 2008
    Location
    Melbourne, Australia
    Posts
    64

    Thumbs up Re: Desktop goes blank after boot, then re-appears when shutdown. How do I fix?

    Thanks, I have avoided any updates than security and I haven't had any problems since. If it happans again I'll try your idea in consol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •