Results 1 to 6 of 6

Thread: i can't update packages in opensuse 11.2, error

  1. #1
    Join Date
    Mar 2010
    Location
    Quilpue, quinta region, Chile
    Posts
    27

    Default i can't update packages in opensuse 11.2, error

    1.- sorry if my english is too bad but my native lenguage is spanish(chile)
    2.- i need help to resolve this problem, i can't update opensuse 11.2, becouse show me a download error...i tried do it manually but still give me that error.
    i opened a terminal and they show me this,

    #zypper up
    Retrieving repository 'openSUSE-11.2-Debug' metadata [\]Download (curl) error for 'http://download.opensuse.org/debug/distribution/11.2/repo/oss/repodata/repomd.xml':
    Error code: Connection failed
    Error message: couldn't connect to host

    but if a lock in software repositories, the direction is only this:
    Index of /debug/distribution/11.2/repo/oss,
    and if i start the software manager, this continue give me that message.
    soo please i need help, becouse this is my first time installing this, and i need to give a very quickly s solution....

    regards
    Carolina

  2. #2
    Join Date
    Mar 2010
    Location
    Quilpue, quinta region, Chile
    Posts
    27

    Default Re: i can't update packages in opensuse 11.2, error

    ANYONE
    PLEASE
    ......
    I WANT TO INSTALL SOME PROGRAMS BUT I CAN'T
    BECOUSE THAT SHOW ME A ERROR...
    PLEASE

  3. #3
    palladium NNTP User

    Default Re: i can't update packages in opensuse 11.2, error

    zero linux wrote:
    > ANYONE
    > PLEASE
    > .....
    > I WANT TO INSTALL SOME PROGRAMS BUT I CAN'T
    > BECOUSE THAT SHOW ME A ERROR...
    > PLEASE


    first: welcome!

    second: this is not chat room and you should not expect instant response..

    third: everyone here is a volunteer...so, please don't shout

    fourth: your english is great! so, again -=welcome=-

    do this in a terminal and copy paste back to here:

    Code:
    zypper lr -d
    and then we can help you, probably..

    --
    palladium

  4. #4
    palladium NNTP User

    Default Re: i can't update packages in opensuse 11.2, error

    zero linux wrote:
    > ANYONE
    > PLEASE
    > .....
    > I WANT TO INSTALL SOME PROGRAMS BUT I CAN'T
    > BECOUSE THAT SHOW ME A ERROR...
    > PLEASE


    PLEASE DO NOT POST THE SAME PROBLEM TO MORE THAN ONE FORUM!!!

    --
    palladium

  5. #5

    Default Re: i can't update packages in opensuse 11.2, error

    hi to all,i new to linux so i have a problem,i can not install any application,not even up-dates because of this error "system management is locked by application with pid 4393 (/usr/sbin/pakagekitd).Close this application before trying again." Can anybody help,pls .
    I have entered the comand line you posted up and if it helps any way here is the copy - paste:
    scooty@linux-j9mi:~> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+--------------+-----------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    2 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    3 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    4 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    5 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
    scooty@linux-j9mi:~>

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: i can't update packages in opensuse 11.2, error

    scooty trance wrote:
    > hi to all,i new to linux so i have a problem,i can not install any
    > application,not even up-dates because of this error "system management
    > is locked by application with pid 4393 (/usr/sbin/pakagekitd).Close this
    > application before trying again." Can anybody help,pls .


    your repo selections look good for getting started [that is to say,
    they are not part of this update fail problem]...eventually, you will
    need to add packman to get the codecs for multimedia etc (when ready
    for music etc, join the multimedia forum and read the stickies at the
    top of the fourm..

    the problem you ask about is all too common...here is what is
    happening: when you get that error it means that for some reason the
    application which does all the update work is already in use--and
    therefore can not be started up again..

    there are a couple (or more) ways that can happen: just by chance you
    happened to try to install which the YaST Online Updater (round green
    icon with lizard head near bottom tray's clock) was being used
    (automatically) to seek updates, *OR* you had tried an install and
    (maybe) got tired of waiting for it to finish (or thought it was
    frozen) and aborted the install....do NOT do that. depending on
    network traffic, the speed of your machine, connection, how busy the
    server is which holds updates etc etc etc etc it can look like nothing
    is happening....WAIT anyway...do NOT press the abort button...instead
    go for a walk...take a nap...whatever..

    anyway, to fix this problem:

    -if it is from the first situation (clash with the Updater) just wait
    until the updated is finished and try again..

    -if due to an aborted or otherwise failed install, in a command line enter

    Code:
    su -
    kill [PID given in error]
    exit
    when you enter su do not forget the space after the u and then the
    dash -, it will ask for your password, give it the root password, you
    will not see what you type as you enter it...but, the machine will
    'see' it..

    remember, as root you must be CAREFUL when entering commands, check
    the screen for any typing mistakes BEFORE hitting the enter key,
    everytime!!

    in the case of your question, the next like would be

    Code:
    kill 4393
    --
    DenverD (Linux Counter 282315)
    CAVEAT: http://is.gd/bpoMD
    posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
    2.6.22.19-0.4-default SMP i686
    AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
    CMedia 9761 AC'97 Audio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •