Results 1 to 4 of 4

Thread: ATI graphics driver problems,,,

  1. #1

    Default ATI graphics driver problems,,,

    Hello all,

    I'm having problems running games on my system. I think the problems are connected to the ATI drivers I've installed. I used the ones I got off of the ATI graphics driver repository specifically for OpenSuse. I would like to try the latest drivers off ATI's website again. I understand they are much more recent than the ones in the repository. The first time I tried them they didn't work, though they have worked in the past for me on a previous incarnation of this system.

    Do I have to uninstall the current drivers first? If so, how do I be certain I have uninstalled all that is necessary since I didn't keep track of the details in the first place? I can find some of them using the search function but perhaps not all. I would imagine there is a way to do that using YaST since I got everything off that one repository.

    Lastly, which option in the ATI graphics driver installer (ati-driver-installer-10-4-x86.x86_6.run) should I use? I'm using 11.2-64 on an Intel based system. Will the 32 bit drivers work on a 64 system? As I noted, the automatic option doesn't work for me. From reading some of the other posts here it seems perhaps I should start in level 3 and use the cli from there. That's not what I did before. Or should I try the latest 11.3 milestone since that seems to have better graphics card support? Any suggestions? Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: ATI graphics driver problems,,,

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,550
    Blog Entries
    37

    Default Re: ATI graphics driver problems,,,

    Quote Originally Posted by Subsidiarity View Post
    Do I have to uninstall the current drivers first?
    If you previous had the proprietary ATI drivers installed, then you MUST remove the *fglrx* rpm BEFORE you attempt a re-install.

    Quote Originally Posted by Subsidiarity View Post
    If so, how do I be certain I have uninstalled all that is necessary since I didn't keep track of the details in the first place?
    You keep track of the details. Paper notebooks, or notes in a text file are easy to maintain.

    But note if you type:
    Code:
    rpm -qa '*fglrx*'
    it will tell you if the fglrx rpm was removed.

    Quote Originally Posted by Subsidiarity View Post
    Lastly, which option in the ATI graphics driver installer (ati-driver-installer-10-4-x86.x86_6.run) should I use? I'm using 11.2-64 on an Intel based system.
    I think you need:
    Code:
    sh ati*.run --buildpkg SuSE/SUSE112-AMD64

    Quote Originally Posted by Subsidiarity View Post
    Will the 32 bit drivers work on a 64 system?
    If you have 64-bit hardware with a 32-bit openSUSE, then you MUST install 32-bit drivers. But if you have 64-bit hardware with a 64-bit openSUSE, then you MUST install 64-bit drivers. Do NOT install 32-bit drivers on a 64-bit openSUSE. Clear as mud?

    Quote Originally Posted by Subsidiarity View Post
    Or should I try the latest 11.3 milestone since that seems to have better graphics card support? Any suggestions? Thanks in advance.
    Stop. You stated your previous questions were the last !! Not fair !!

    11.3 should be better for ATI graphic users for non-proprietary graphic drivers, but for proprietary graphic drivers I do not think for most ATI hardware it will make any difference. Hence 11.2 should work.

    I do NOT recommend a Milestone release. Wait until late summer or autumn 2010 before installing 11.3.

  4. #4

    Default Re: ATI graphics driver problems,,,

    Thanks for the replies. I'm reading through that page gradually. I'm going to have to do some cleaning up. I think I originally tried the 64 bit drivers and they didn't work. I've been focused by some rl issues so I haven't had time to get back to getting my comp to work with games that I don't have time for now anyway.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •