Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: opensuse issues right off the bat

  1. #1

    Default opensuse issues right off the bat

    I just installed OpenSUSE 11.2
    I figure that all the bugs haven't been weeded out yet, because I've got a couple and where one answer was straightforward its solution substance is M.I.A. and the others sounded experimental.

    I have at present, 3 main issues with the OS. And they are as follows:

    k3b: fails at writing dvd's. It starts, md5sum checks, and then when I click burn with all settings on auto (or changed to DAO and a specified write speed) it says the device or media does not support writing at 16x moving it up to 17x. It then begins write, and fails with the error that K3b has no permission to open the device.I tried updating and reinstalling k3b, but neither has worked.

    update: I keep getting the error that dbus unable to get transaction id from package kit. One solution said to add a package kit repository which I searched for and could not find an address for, although I found the package kit website; as I don't really know SUSE yet, I'm hesitant to mess with the updater applet.

    The wierdest part about updating though, has been that initially I was prompted to install an update to stop yast from spamming the desktop, which failed with the above error. Then, I was prompted there were 27 or so updates available which failed with the above error. Finally, there are no updates available on checking and intermittently, I get the above error when trying to start the updater applet at all.

    kde4 desktop environment: at various times during using the desktop environment, windows or menu bars are freezing; refusing to close although they will minimize.

    Needless to say its not going to work like this. Can someone please offer me some advice as to solutions while I continue to surf the net for answers?

  2. #2

    Default Re: opensuse issues right off the bat

    one last note: package kit is installed as with its dependencies, although I have a later version of dbus than the packagekit website calls for, I assume it is for 11.2 compatability. Thanks again.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,393
    Blog Entries
    1

    Default Re: opensuse issues right off the bat

    Those symptoms sound like a bad install, often due to a problem with the install dvd. I would check the md5sum first.

    ISO image - openSUSE

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: opensuse issues right off the bat

    Let's just establish where you are.

    Please open a terminal and enter the following, and post results:

    Code:
    zypper lr -d
    Code:
    kde4-config -v
    Code:
    uname -a
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jul 2008
    Location
    in front of the keyboard
    Posts
    90

    Wink Re: opensuse issues right off the bat

    I dont think it is a bad install. You should try the following.

    1. K3b - yast - Security and users - Users and group management - click on your username then click Edit - choose Detail tab at the window that appears and check the "disk" group in the right side group list... Finish then logout and login again in kde
    2. Open konsole as root then zypper ref, and the zypper up. Install the update that appears then zypper in kupdateapplet-zypp. This will install a different backend for kupdateapplet. Logout from kde login again and right click the kupdateapplet then choose Configure Applet then choose Zypp plugin in the backend combo menu.. logout and login to kde again.
    Dell Latitude E6520 - openSuSE 13.1 & Windows 8.1

  6. #6

    Default Re: opensuse issues right off the bat

    @adminalright there, finally some proactive assistance! haha

    uh...the output for your commands is long, just so you know (not the last two just the zypper command)

    Zypper

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+---------------------------------+---------------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------+--------
    1 | download.opensuse.org-Backports | openSUSE BuildService - KDE:Backports | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.2 |
    2 | download.opensuse.org-Community | openSUSE BuildService - KDE:KDE4:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2 |
    3 | download.opensuse.org-STABLE | openSUSE BuildService - OpenOffice.org | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.2 |
    4 | download.opensuse.org-Wine | openSUSE BuildService - Wine CVS Builds | Yes | Yes | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.2 |
    5 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.2 |
    6 | download.opensuse.org-webcam | openSUSE BuildService - Drivers for webcams | Yes | Yes | 99 | rpm-md | Index of /repositories/drivers:/webcam/openSUSE_11.2 |
    7 | download.videolan.org-SuSE | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.2/ |
    8 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    9 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    10 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    11 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    12 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2

    kde4 – config

    linux-78pb:~ # kde4-config -v
    Qt: 4.5.3
    KDE: 4.3.5 (KDE 4.3.5) "release 0"
    kde4-config: 1.0

    uname
    Linux linux-78pb 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

    some of those repositories I added to keep software/hardware up to date. They haven't been of use yet though, I might add I got two updates this monring, one for BNC and one for a key of some sort (I kept the details in case anyone would ask) and then on checking for more updates, got the error aforementioned.

    @darkmack what do you mean it will change the kupdateapplet? Like the program used to initilize YAST for updating will change entirely? I don't mean to be hasty, I think it might be more productive to ascertain what is wrong with the present program. Of course, I could have what you're saying all wrong, in which case kindly disregard my ubernoobness.

    @Ferrari In response to the bad install, I thought about that. Downloaded a new disc and the md5sums checked and verified and whatnot. Then k3b and brasero (after update via software install and reinstallation) failed with the same error, no permission to open device? The write speed was set to auto, but anyway...In short, couldn't get a new disk and I like the feel of OpenSUSE so I wasn't going to just thrash it away. Someone on the local network has been pwning people daily (namely me) which is why I thought to myself the original disc could have been corrupted.

    If the issue comes down to hardware let me know, I have a smolts profile online.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: opensuse issues right off the bat

    Do the following in a su - terminal

    Code:
    zypper rr 7
    That will remove VideoLan, which you do not need.
    Now we add what you DO need
    Code:
    zypper ar -f http://packman.unixheads.com/suse/11.2/ packman
    now close all this
    -------------------------------------------

    Now the tricky part. Open Yast Software Management, you may be asked to accept / allow Packman, just say YES, When in the UI, filter the view to repositories, and select Packman

    And do this
    http://tinyurl.com/yejwull

    Also, whilst in here make sure k3b-codecs is installed.

    This is the guide you should have followed originally.
    Multi-media and Restricted Format Installation Guide - openSUSE Forums

    Any problems get back.

    *Tip: If asked - Choose Packman as the vendor
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: opensuse issues right off the bat

    ok the repositories bit managed;

    and by do this I presume you mean to install each of these codecs? The thing here is that I have gstreamer codecs installed already. I guess I might ask where the difference lay?

    I began to simply check box away, but it started naming off conflict after conflict; all codec related.

    Now, I can see how VLC repository is unnecessary; however, I don't see how installed codecs is going to resolve my update issues...so I guess this portion of our conversation is aimed at resolving the cd burner troubles?

    Yet, I can't see how codecs are going to remit permissions for device access tyhrough k3b. Do I have permissions and ability to 'open' the device confused as one and the same then?

  9. #9

    Default Re: opensuse issues right off the bat

    when I say conflict after conflict; I mean HUNDREDS! of conflicts to resolve.

    The safe bet is just to install those items listed in the image; but, I'm unsure as to what conflicts will be resolved through doing this and how its going to affect other programs.

    Namely those items I would like to keep in tact are k3b or brasero if they can work properly, google earth, wine, openoffice.org, any default performance tools and absolute dependencies for OS functionality and hardware compatability.

    Of course if this might present issues simply for reinstallation that isn't a problem, it is creating an unresolvable conflict that I am concerned about and where I can pass a command or two and edit some variables; etc. when the names are three consonance followed by a vowel and version, revision, experimentation numbers, I get lost as to how important the packages are.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: opensuse issues right off the bat

    I see where you are coming from, but...

    We have to start with a correctly set up system.

    As for the update applet. Right click it and configure it NOT to start at boot, and then quit it. It's a darn nuisance.

    If you find it difficult switching, you may have to methodically do it one or two packages at a time, or as many as you can before it spits dummy. Then apply those. Do it like this:
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    You may have some packages installed from VLC that are no longer available, they will be red and have no provider, - Delete them.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •