Results 1 to 7 of 7

Thread: Configuring fluxbox - newbie question

  1. #1

    Default Configuring fluxbox - newbie question

    Hi, I'm setting up vnc so I can access my laptop from my Android phone.
    I can access the standard kde desktop fine, but it is very slow due to its complexity.
    The vnc HOWTO here mentions using fluxbox as a simpler window manager.
    Again, I managed to get this working, but it gives a pretty blank interface. The article also mentions the following:

    If you want to enable Gnome or KDE desktop, you'll have to configure Fluxbox with the extra option:
    ./configure --enable-kde


    My rather basic question is what do I do with the above line of code? I don't know when/where to enter it.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,649

    Default Re: Configuring fluxbox - newbie question

    That appears to be a compile line. Are you compiling something?

  3. #3

    Default Re: Configuring fluxbox - newbie question

    I tried compiling it - unsuccessfully, so I downloaded an RPM for the fluxbox package. I think the RPM was designed with Fedora in mind, as it threw up a few dependency issues. Once I resolved these, it installed fine and runs fine.
    So if the command relates to compiling, does this mean that the option to enable kde cannot be modified once the program is installed?
    I might try to compile it again once I get home.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,649

    Default Re: Configuring fluxbox - newbie question

    Why did you do that?? Do you know that this can be done with Suse repositories? Do you know how to use Yast to install software??

    Do a search with Yast-Package Search (Webpin) and you will find the Suse Fluxbox package.

  5. #5

    Default Re: Configuring fluxbox - newbie question

    Regarding the last post, I searched in yast and could not find fluxbox.

    Also, tried to compile from source again.
    I'm getting the following error when I try ./configure
    configure: error: Fluxbox requires the X Window System libraries and headers.
    I checked and I have xorg-x11-libs installed.
    Any idea why it might not be compiling?

  6. #6

    Default Re: Configuring fluxbox - newbie question

    Quote Originally Posted by gogalthorp View Post
    Why did you do that?? Do you know that this can be done with Suse repositories? Do you know how to use Yast to install software??

    Do a search with Yast-Package Search (Webpin) and you will find the Suse Fluxbox package.
    ...actually, hadn't used the webpin search before. FOund fluxbox there sure enough, thanks.
    ...although this doesn't let me compile so can't enable the --enable-kde option.

  7. #7

    Default Re: Configuring fluxbox - newbie question

    Ok, got it working in the end.
    It seems my lack of experience at compiling ingeneral was the issue.

    ./configure... started to work once I installed several x-related packages

    Then I discovered that the make command didn't work. After a bit of googling, installed patterns-openSUSE-devel_C_C++ (alot of packages!!!).
    After that, "make" started to work but came up with a load of errors.
    Then installed "kernel-source" and tried again.

    Worked fine after this.
    400mb of packages later, and the 1mb or so fluxbox package is compiled and installed!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •