Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Nautilus does not open openoffice files direct

  1. #1

    Default Nautilus does not open openoffice files direct

    Hi,
    I have observed the following on different machines, using opensuse 10.3 and 11 - different accounts - same behavior. It is strange but I have searched for a solution several times spent hours found nothing.

    OK the problem is: openoffice files are not correctly associated with openoffice in nautilus. I know the open-with thing but it does not help:

    Every time I click on .odt .ods .od... nautilus asks me: Do you want to run "Filename.odt" or display its contents? "Filename.odt" is an executable text file. [Run in Terminal] [Display] [Cancel] [Run]

    Frustrating. RMB/Openwith/Other.../Openoffice works, but it does not allow to save that as a default decision.

    As it does happen on fresh created new accouts too, I do not think it is a pernonal settings problem or is it?

    All my 5 machines are either OpenSuse10.3 or updated to OpenSuse11 same behavior everywhere ...

    Please Help!!!

    Thanks!

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Nautilus does not open openoffice files direct

    There's an "Open With" tab in the properties for the file. Set the file association there.

  3. #3

    Default Re: Nautilus does not open openoffice files direct

    Hi,

    yes, thanks, but as I sad the open with dialog does not help. Shure I can open the filer with by pressing RMB/Openwith/.../.../ but there is _NO_ possibility to say "remember that" or similar. So this does not help.

    Meanwhile I could find out a very interesting thing. The described behavior ONLY happens on FAT16 (USB disks) pluged in and auto mounted in nautilus.

    Can someone reproduce this issue?

    (To make it clear: open by dobbleclick on a local odt file works. copy the same file to the usb drive. double click on it nautilus says its an executeable text file ... no "reassigning possible" via open with ...)

    Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Nautilus does not open openoffice files direct

    On Mon, 25 Aug 2008 21:56:01 GMT
    oidawappler <oidawappler@no-mx.forums.opensuse.org> wrote:

    >
    > Hi,
    >
    > yes, thanks, but as I sad the open with dialog does not help. Shure I
    > can open the filer with by pressing RMB/Openwith/.../.../ but there is
    > _NO_ possibility to say "remember that" or similar. So this does not
    > help.
    >
    > Meanwhile I could find out a very interesting thing. The described
    > behavior ONLY happens on FAT16 (USB disks) pluged in and auto mounted in
    > nautilus.
    >
    > Can someone reproduce this issue?
    >
    > (To make it clear: open by dobbleclick on a local odt file works. copy
    > the same file to the usb drive. double click on it nautilus says its an
    > executeable text file ... no "reassigning possible" via open with ...)
    >
    > Thanks!
    >
    >


    FAT, in any of its variations, does not support the READ/WRITE/EXEC flags
    present in linux's ext2/3 and variants. The system emulates R/W/X and forces
    them on for the files... which is why you'll always see 'executable jpg's and
    whatnot, since the filesystem defaults to emulating those permissions for the
    FAT filesystems.

    When the file is copied to the FAT16 (or FAT32) filesystem, it gains the
    execute flag automatically. Nautilus senses the executable flag first, then
    interprets the magic numbers for each filetype... which kills the 'open with
    openoffice' magic.

    Copying the file to the hard drive doesn't help, since the RWX flags are
    copied along with it... so you end up with a file marked as executable,
    although it's not executable (in any manner). If you right click on the
    file, choose properties and clear the 'is executable' flag on the permissions
    tab, all will be good.

    This is a "bug/feature" associated with Microsoft's FAT filesystem formats.
    msdos/fat16/fat32/vfat are all affected by this. Adding the 'mode=0644' or
    'fmask=0644' option to the mount options can help.

    Again, this isn't an issue with Nautilus, this is an issue concerning using
    FAT based filesystems to convey files.

    Loni

    --
    L R Nix
    lornix@lornix.com


  5. #5

    Default Re: Nautilus does not open openoffice files direct

    Thanks Loni,
    you made my day! that is exactly the issue. I got lazy since I switched from gentoo to suse 6 moths ago...

    I still need to figure out how to change mount options (the options in the volume tab of the USB stick does not work - I put in 'fmask=0644' but he told me "wrong mount option" ...

    However I am still wondering why I couln'd find anything in the web about this issue ...

    Cheers oida

  6. #6

    Default Re: Nautilus does not open openoffice files direct

    Hi Loni, hi everyone,

    well Loni might be right, but sometimes you cannot do anything against having .odt files marked executable (i.e. our heterogeneous Network here having Windows and Linux machines mounting the same "fileserver"). For example I do not have permissions to change file attributes on the server. What am I do than?

    I do think there is another solution, since our Gentoo workstations do not show this behavior, it is only my Openoffice 11.[012] which just annoys me everytimes with asking if I do what to execute my odt file.

    Since this happens with all USB sticks as well, I do not understand why I should be the only one annoyed with this?

    I do use the default settings to mount USB sticks in Opensuse (at least I did not change anything) ... I didn't found anything in the forums here ...


    Please help! Thanks

  7. #7

    Exclamation Re: Nautilus does not open openoffice files direct

    Hi, gnomevfs-info test.odt tells me:

    Name : test.odt
    Type : Regular
    MIME type : application/vnd.oasis.opendocument.text
    Default app : writer.desktop
    Size : 146336
    Blocks : 288
    I/O block size : 8192
    Local : YES
    SUID : NO
    SGID : NO
    Sticky : NO
    Permissions : 1600755
    Link count : 1
    UID : 1000
    GID : 100
    Access time : Wed May 26 00:00:00 2010
    Modification time : Thu May 20 17:10:22 2010
    Change time : Wed May 26 09:15:42 2010
    Device # : 2065
    Inode # : 36132
    Readable : YES
    Writable : YES
    Executable : YES

    well the point is, I cannot change the permissions gettig rid of "Executable: YES" is not an option.

    "Open with" doe not help, is still asks me everytime whether I do what to execute that file or view it ...

    This is the default behaviour of using Openoffice with an USB stick - is there no option to get rid of the "Do you want to run "Filename.odt" or display its contents? " Dialog?


    cheers!

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,856
    Blog Entries
    14

    Default Re: Nautilus does not open openoffice files direct

    Please, start a new thread. This way you will not get the attention for your problems. Be clear in your threads title, give as much info on your problem.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Nautilus does not open openoffice files direct

    Quote Originally Posted by oidawappler View Post
    Hi, gnomevfs-info test.odt tells me:

    Name : test.odt
    Type : Regular
    MIME type : application/vnd.oasis.opendocument.text
    Default app : writer.desktop
    Size : 146336
    Blocks : 288
    I/O block size : 8192
    Local : YES
    SUID : NO
    SGID : NO
    Sticky : NO
    Permissions : 1600755
    Link count : 1
    UID : 1000
    GID : 100
    Access time : Wed May 26 00:00:00 2010
    Modification time : Thu May 20 17:10:22 2010
    Change time : Wed May 26 09:15:42 2010
    Device # : 2065
    Inode # : 36132
    Readable : YES
    Writable : YES
    Executable : YES

    well the point is, I cannot change the permissions gettig rid of "Executable: YES" is not an option.

    "Open with" doe not help, is still asks me everytime whether I do what to execute that file or view it ...

    This is the default behaviour of using Openoffice with an USB stick - is there no option to get rid of the "Do you want to run "Filename.odt" or display its contents? " Dialog?


    cheers!
    This might help: Open Nautilus --> edit --> preferences --> Behaviour --> Executable text files ---> view
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  10. #10

    Thumbs up Re: Nautilus does not open openoffice files direct

    Thanks, that is it.
    Hmm so easy, and I was struggeling with mime types and gnome-conf for ages ...

    Cheers!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •