Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Why do I have to manually keep starting mysql and mythbackend??

Hybrid View

  1. #1

    Default Why do I have to manually keep starting mysql and mythbackend??

    As the title states.

    Code:
    # /etc/init.d/mysql status
    Checking for service MySQL:                                                                                                       unused
     # /etc/init.d/mythbackend status
    Checking for service MythTV backend                                                                                               unused

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    Did you set mysql to start at boot in YaST? Ditto for mythbackend.

  3. #3

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    i thought that was what "System Services runlevel" was

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    Sorry, didn't see the screenshot first time. I block images.

    So you're saying it keeps dying? You'd have to work out why then.

    Or are you saying you have to start it up manually after boot and then it stays up?

  5. #5

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    Quote Originally Posted by ken_yap View Post
    Or are you saying you have to start it up manually after boot and then it stays up?
    yep.567890

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    Do this:

    Code:
    /sbin/chkconfig --list mysql
    My result:

    Code:
    mysql                     0:off  1:off  2:on   3:on   4:off  5:on   6:off

  7. #7

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    Code:
    # /sbin/chkconfig --list mysql
    mysql                     0:off  1:off  2:on   3:on   4:off  5:on   6:off

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    Sorry, I'm stumped. Only thing I can think if is it has some issues starting at boot. You'll have to watch the process for any errors. Or maybe look in /var/log/boot.msg.

  9. #9

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    ken yap wrote:
    > Sorry, I'm stumped. Only thing I can think if is it has some issues
    > starting at boot. You'll have to watch the process for any errors. Or
    > maybe look in /var/log/boot.msg.


    At the top of the rcscript, is a section with init info. See if there
    are some required start entries that aren't present/enabled. May be
    that mysql is trying to start too early in the game.

    Here at work my box is running Debian, but the relevant section for
    mysql is:
    #!/bin/bash
    #
    ### BEGIN INIT INFO
    # Provides: mysql
    # Required-Start: $remote_fs $syslog mysql-ndb
    # Required-Stop: $remote_fs $syslog mysql-ndb
    # Should-Start: $network $named $time
    # Should-Stop: $network $named $time
    # Default-Start: 2 3 4 5
    # Default-Stop: 0 1 6
    # Short-Description: Start and stop the mysql database server daemon
    # Description: Controls the main MySQL database server daemon "mysqld"
    # and its wrapper script "mysqld_safe".
    ### END INIT INFO

    I'd expect something similar in the SUSE scripts.


    --
    Kevin Miller
    Juneau, Alaska
    http://www.alaska.net/~atftb
    In a recent poll, seven out of ten hard drives preferred Linux.

  10. #10

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    well, mine is
    Code:
    ### BEGIN INIT INFO   
    # Provides:       mysql
    # Required-Start: $network $remote_fs
    # Required-Stop: $network $remote_fs
    # Default-Start:  2 3 5
    # Default-Stop:
    # Description:    Start the MySQL database server
    ### END INIT INFO
    Ah, ok. So it has to do with mysql starting before I get the binded LAN address.

    So I just make mysql start after the network, or how do I bring the network to the front (because it seems the case for mythtv as well)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •