Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Why do I have to manually keep starting mysql and mythbackend??

  1. #11
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    $network means networking is up, not that you have a eth address. At that point at least lo should be up with a localhost address even if you get a eth address later with network manager or something like that. Mysql works fine on hosts with no eth inteface at all, and connection is to localhost. Do you not have lo up at that point?

    Are you just guessing from looking at the header or did you actually monitor the bootup to see what the problem is? You may have to insert some debugging in the start script or turn on some debugging in mysql.

  2. #12

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    Quote Originally Posted by ken_yap View Post
    Are you just guessing from looking at the header or did you actually monitor the bootup to see what the problem is?
    From googling. And also that mythtv and mysql are both set to bind to 10.0.0.3, not localhost

  3. #13
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Why do I have to manually keep starting mysql and mythbackend??

    But did you stop mysql from also binding to a Unix socket and also 127.0.0.1? Normally you don't need to change the listening address in /etc/my.cnf because it will listen on all interfaces. If you did change it to listen on only 10.0.0.3 then it would fail if the interface is not up. If you had left it alone, it would bind to *:3306 and when 10.0.0.3 comes it it would be available. Looks like you were too clever by half.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •