Results 1 to 3 of 3

Thread: Device Actions - cdrom

  1. #1

    Default Device Actions - cdrom

    Installed v11.2 kde 4.3.5 from Live CD (not DVD).

    Although my cd-rw recognizes and plays audio cd's, it will not recognize data cd's. Either purchased software installation disks or home made data cd's - they are not recognized. The cd drive light shows the cd being read.

    The cd-rw drive worked fine with Suse v10 & whatever flavor of kde was packaged with that distro.

    I get a popup from the device notifier for 'optical disk' called 'volume' but that actually points to /media/disk and that is a hpfs partition (sda2) for os/2 on my hard drive .

    When I look at the Device Actions there are listed 3 filemanager choices. One does not work, giving an error message: Device conditions are not valid, blah, blah. I cannot edit this one to see what the conditions are. The other 2 filemanager operations are for audio CD and Floppy disk or another storage device (usb works so I presume that this is for usb). A screen shot of my device settings and cd-rw info is at temp :: Device Actions picture by Jon229 - Photobucket

    I have checked my group membership and added cdrom & disk. I have also tried creating a new user. I previously created a mount point and successfully mounted data cd's. I now understand this is not necessary and have removed the mount point.

    I am wondering if the filemanager selection that does not work is the cause of my problme and I'd like to find out what settings I could use to add to the device actions or any other suggestion for something to try.

    jon

  2. #2
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Default Re: Device Actions - cdrom

    Quote Originally Posted by 6520302 View Post
    Installed v11.2 kde 4.3.5 from Live CD (not DVD).

    Although my cd-rw recognizes and plays audio cd's, it will not recognize data cd's. Either purchased software installation disks or home made data cd's - they are not recognized. The cd drive light shows the cd being read.

    The cd-rw drive worked fine with Suse v10 & whatever flavor of kde was packaged with that distro.

    I get a popup from the device notifier for 'optical disk' called 'volume' but that actually points to /media/disk and that is a hpfs partition (sda2) for os/2 on my hard drive .

    When I look at the Device Actions there are listed 3 filemanager choices. One does not work, giving an error message: Device conditions are not valid, blah, blah. I cannot edit this one to see what the conditions are. The other 2 filemanager operations are for audio CD and Floppy disk or another storage device (usb works so I presume that this is for usb). A screen shot of my device settings and cd-rw info is at temp :: Device Actions picture by Jon229 - Photobucket

    I have checked my group membership and added cdrom & disk. I have also tried creating a new user. I previously created a mount point and successfully mounted data cd's. I now understand this is not necessary and have removed the mount point.

    I am wondering if the filemanager selection that does not work is the cause of my problme and I'd like to find out what settings I could use to add to the device actions or any other suggestion for something to try.

    jon
    Are you able to mount the device from command line?
    Code:
    sudo mount -type auto /dev/cdrom /media
    Also, from a terminal, please post the results of:
    Code:
    cat /etc/fstab
    Does it exhibit this behavior with all data disks? Not a likely cause, but have you tried using a lens cleaning disk in the CD?
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  3. #3

    Default Re: Device Actions - cdrom

    Quote Originally Posted by tommyttt View Post
    Are you able to mount the device from command line?
    Code:
    sudo mount -type auto /dev/cdrom /media
    Only if I change the command parameter to -t. So yes, mount -t auto /dev/cdrom /media works. I am able to list contents and view text files using cat.

    Also, from a terminal, please post the results of:
    Code:
    cat /etc/fstab
    # cat /etc/fstab
    /dev/disk/by-id/ata-ST340014A_5JXF0RK0-part5 swap swap defaults 0 0
    /dev/disk/by-id/ata-ST340014A_5JXF0RK0-part6 / ext4 acl,user_xattr 1 1
    /dev/disk/by-id/ata-ST340014A_5JXF0RK0-part7 /home ext4 acl,user_xattr 1 2
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0

    Does it exhibit this behavior with all data disks? Not a likely cause, but have you tried using a lens cleaning disk in the CD?
    I have not tried a lens cleaner. Audio disks, both manufactured & home-made work fine, offering me a notification popup where I can choose which app to use on the CD.

    Every data disk that I've tried fails (nothing happens except the read light indicates the disk is read), both manufactured & home made. However, 3 home-made data disks that I just now checked worked with your mount command.

    Tommyttt: Thanks so much for the help you've given so far. Do you think if I added an entry to the device actions this can be made to work correctly?

    Jon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •