Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Akonadi warnings allways appear at start up

  1. #1
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Akonadi warnings allways appear at start up

    Hello.
    When I start up my computer I always get the Akonadi message window with some errors. If I just close it, launch "akonadi configuration" and ask for a test, some of the errors have already disappeared. It looks like the first test is made too soon, before everything is running.

    It's not a big issue but I would like to get rid of the akonadi warnings window. Does anybody know how?

    Thanks in advance.

    I enclose the report for one test during the start up, and the same test one minute later. If needed I can post the whole report. There are other errors, but this one seems to me the most relevant.

    During start up, I get:
    Code:
    Test 14:  ERROR
    --------
    
    No resource agents found.
    Details: No resource agents have been found, Akonadi is not usable without at least one. This usually means that no resource agents are installed or that there is a setup problem. The following paths have been searched: '/usr/share/akonadi/agents'. The XDG_DATA_DIRS environment variable is set to '/usr/share:/etc/opt/kde3/share:/opt/kde3/share', make sure this includes all paths where Akonadi agents are installed to.
    
    Directory listing of '/usr/share/akonadi/agents':
    birthdaysresource.desktop
    contactsresource.desktop
    gcalresource.desktop
    googledataresource.desktop
    icalresource.desktop
    imapresource.desktop
    kabcresource.desktop
    kcalresource.desktop
    kolabproxyresource.desktop
    localbookmarksresource.desktop
    maildirresource.desktop
    maildispatcheragent.desktop
    mboxresource.desktop
    microblog.desktop
    mtdummyresource.desktop
    nepomukcalendarfeeder.desktop
    nepomukcontactfeeder.desktop
    nepomuktagresource.desktop
    nntpresource.desktop
    notesresource.desktop
    pop3resource.desktop
    vcarddirresource.desktop
    vcardresource.desktop
    
    Environment variable XDG_DATA_DIRS is set to '/usr/share:/etc/opt/kde3/share:/opt/kde3/share'
    One minute later I get
    Code:
    Test 14:  SUCCESS
    --------
    
    Resource agents found.
    Details: At least one resource agent has been found.
    
    Directory listing of '/usr/share/akonadi/agents':
    birthdaysresource.desktop
    contactsresource.desktop
    gcalresource.desktop
    googledataresource.desktop
    icalresource.desktop
    imapresource.desktop
    kabcresource.desktop
    kcalresource.desktop
    kolabproxyresource.desktop
    localbookmarksresource.desktop
    maildirresource.desktop
    maildispatcheragent.desktop
    mboxresource.desktop
    microblog.desktop
    mtdummyresource.desktop
    nepomukcalendarfeeder.desktop
    nepomukcontactfeeder.desktop
    nepomuktagresource.desktop
    nntpresource.desktop
    notesresource.desktop
    pop3resource.desktop
    vcarddirresource.desktop
    vcardresource.desktop
    
    Environment variable XDG_DATA_DIRS is set to '/usr/share:/etc/opt/kde3/share:/opt/kde3/share'

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Akonadi warnings allways appear at start up

    wrbbt wrote:
    > Hello.
    > When I start up my computer I always get the Akonadi message window
    > with some errors.


    as no one else here seems to have had your problem (or else i'm sure
    they would speak up) i suggest you join and ask somewhere on in the
    KDE forum, http://forum.kde.org/

    --
    DenverD (Linux Counter 282315)
    CAVEAT: http://is.gd/bpoMD
    posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
    2.6.22.19-0.4-default SMP i686
    AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
    CMedia 9761 AC'97 Audio

  3. #3
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Akonadi warnings allways appear at start up

    OK. Thanks anyway.

  4. #4

    Default Re: Akonadi warnings allways appear at start up

    I had the same issue 2 weeks ago after updating KDE. Not sure what happened but it went away on its own.

    *** Thinking about it after the update I had issues with updates after, aswell as searching packages from the repository - I could manually look through the lists though. I logged in under root and allowed the system to update, which took care of the update issue / repository issue. Probably took care of the Akonadi issue since it hasn't happened since around that time.
    Last edited by gdudley6; 04-May-2010 at 21:17. Reason: **** added comment

  5. #5
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,125

    Default Re: Akonadi warnings allways appear at start up

    Quote Originally Posted by DenverD View Post
    wrbbt wrote:
    > Hello.
    > When I start up my computer I always get the Akonadi message window
    > with some errors.


    as no one else here seems to have had your problem (or else i'm sure
    they would speak up) i suggest you join and ask somewhere on in the
    KDE forum, Index page • KDE Community Forums
    -I have the same problem too. It just didn't annoy me enough to post about it.
    Last edited by Prexy; 05-May-2010 at 09:48. Reason: missing tag
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Akonadi warnings allways appear at start up

    Prexy wrote:
    > -I have the same problem too. It just didn't annoy me enough to post
    > about it.



    apparently the two/three share a bug...who is gonna log it and who is
    gonna make comments on it so all the various hardware/software
    questions the devs might need to know is included?

    someone start by searchng to see if the bug is already active, see:
    http://en.opensuse.org/Submitting_Bug_Reports

    --
    DenverD (Linux Counter 282315)
    CAVEAT: http://is.gd/bpoMD
    posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
    2.6.22.19-0.4-default SMP i686
    AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
    CMedia 9761 AC'97 Audio

  7. #7
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Akonadi warnings allways appear at start up

    Quote Originally Posted by DenverD View Post
    who is gonna log it and who is gonna make comments on it so all the various hardware/software questions the devs might need to know is included?

    someone start by searchng to see if the bug is already active, see:
    Submitting Bug Reports - openSUSE
    I've searched and found nothing for opensuse 11.1 (which is the version I run). I've found a bug for 11.2 that maybe is related but it's not exactly the same (https://bugzilla.novell.com/show_bug.cgi?id=555443).

    Before reporting the bug I'll update kde (I cannot do it right now).

    Maybe also before reporting it's useful to know what opensuse and kde versions you (gdudley6 and Prexy) are running.
    I run opensuse 11.1 and kde 4.4.2 (but I plan to install 4.4.3 as soon as possible).

    Do you think it's better to report in opensuse or in kde bugs?

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: Akonadi warnings allways appear at start up

    Did you try to remove the akonadi related files and folders in ~/.kde4/share/config and ~/.kde4/share/apps ? There might simpy be some old settings interfering with new ones.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    upscope NNTP User

    Default Re: Akonadi warnings allways appear at start up

    DenverD wrote:

    > wrbbt wrote:
    >> Hello.
    >> When I start up my computer I always get the Akonadi message
    >> window with some errors.

    >
    > as no one else here seems to have had your problem (or else i'm
    > sure they would speak up) i suggest you join and ask somewhere on
    > in the KDE forum, http://forum.kde.org/
    >

    Now that I can send email again, I have had the problem with
    Akonadi.(Can't register Akonadi server and console with dbus).
    Every time I tried to select a contact, it hung up kmail and
    Kontact. Had to kill Kontact completely to get out of it.It had
    been working sort of. Yesterday I restored ~/.config and ~/.local.
    from a backup and now contacts works and Kmail works, but I still
    get a MySQl error:

    100509 7:10:36 [Note] Plugin 'ndbcluster' is disabled.
    100509 7:10:36 InnoDB: Started; log sequence number 0 25348407
    100509 7:10:37 [Warning] Can't open and lock time zone table:
    Table 'mysql.time_zone_leap_second' doesn't exist trying to live
    without them
    100509 7:10:37 [ERROR] Can't open and lock privilege tables: Table
    'mysql.servers' doesn't exist
    100509 7:10:37 [ERROR] Cannot open mysql.db
    100509 7:10:37 [ERROR] Cannot open mysql.user
    100509 7:10:37 [ERROR] Cannot open mysql.event
    100509 7:10:37 [ERROR] Event Scheduler: An error occurred when
    initializing system tables.
    100509 7:10:37 [Note] /usr/sbin/mysqld: ready for connections.
    Version: '5.1.36-log' socket:
    '/home/finemanruss/.local/share/akonadi/db_misc/mysql.socket'
    port: 0 SUSE MySQL RPM

    I've gone thru the steps on KDEBASE Wiki. Nepomuk is running.

    I assume problem is fact MySQL requires a password and ID. I put
    them in akonadiserverrc but it still did not work.

    Any Idea's on how to proceed? See KDE bug 236593.
    --
    Russ
    | openSUSE 11.2 (2.6.31.12-18-desktop) x86_64 | KDE 4.4.2 release
    241 | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB
    Disc (2) |

  10. #10

    Default Re: Akonadi warnings allways appear at start up

    I had the same problem after updating kde yesterday.
    The update for akonadi and libakonadi seems to remove the warning when starting kmail. Oh I updated kmail also today.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •