Results 1 to 6 of 6

Thread: Expert Partitioner gone haywire

  1. #1

    Question Expert Partitioner gone haywire

    Hi All, I'm trying to install 11.2 on a system where I just made some major partition changes and Expert Partitioner is doing many odd things, including just plain crashing. I could really use some help to figure this out. Here is what I have and did:

    I had 500GB disk with a working Windows 7/OpenSUSE system which had, in this order:

    1 primary NTFS
    1 Extended (with 3 NTFS and one Linux Swap)
    1 primary Linux ext4 (far too small)
    1 primary very large NTFS

    (*long boring and probably irrelevant paragraph warning *)

    I needed a large partition for an OpenSUSE mount point, so I backed up and deleted the very large NTFS partition, then using gparted (from an Ubuntu 9.10 live CD), I deleted that last partition and the two linux partitions (one primary ext4, one logical swap), resized the logical to huge, added back a large NTFS, large ext2 and a swap partition to the extended partition, and added a new ext4 primary partition for my openSUSE install. Then I restored the large NTFS partition which is now logical.
    -- OK, that is a bit convoluted but the point is that I moved lots of stuff around and created new Linux partitions type 83 and 82.

    I should also note that *before* I did all of this, I installed OpenSUSE 11.2 and it recognized the ext and swap partitions and set up GRUB fine for dual boot.

    After the changes, when I went back to reinstall OpenSUSE, Expert Partitioner now shows *every* partition, including the extended partition as "Linux Native" in the type column and the correct file type in the adjacent column. If I continue, the GRUB setup page has no reference to Windows, just 7 "other linux" entries.

    fdisk -l /dev/sda shows the correct file types.

    Thinking that partition table ordering was the problem, I reordered the partition table (fdisk > x > f). Windows was fine with that (after a re-activation) but Expert Partitioner still doesn't understand what is going on.
    Also, it simply crashes and restarts the install process if I click on sda on the left side.

    So the questions...

    1) Is there a way I can get Expert Partitioner to understand the new partition table correctly and have install create a good GRUB dual boot.

    2) I can't manually assign all the correct types because Expert Partitioner has no assignment for an extended partition (type 0F). So if I proceed with the install, will I screw up the entire partition table? (I did make a back up using dd but I'm nervous still).

    Thanks for any insights. I can post the partition table if needed.


  2. #2
    Join Date
    Jun 2008
    Kansas City Area, Missouri, USA

    Default Re: Expert Partitioner gone haywire

    On 04/24/2010 05:56 PM, waltz49 wrote:
    > Thanks for any insights. I can post the partition table if needed.

    Please post the output of 'sudo /sbin/fdisk -l'.

  3. #3

    Default Re: Expert Partitioner gone haywire

    I found the cause of the oddity (though it points out bugs in Expert Partitioner AND Acronis Home 11 AND maybe the installer.

    Apparently parted is used to read the table but fails because when Acronis restored the original large primary partition to a logical partition, it marked it primary, thereby giving me overlapping partitions (ugh!).

    When the installer calls Expert Partitioner, EP does not show an error message like you get when starting Expert Partitioner from YaST. Then the partitioner shows the wrong data and crashes with the bad table.

    I'm working on it... Lets hope the quality of Acronis is better if I have to restore the whole disk.

    Not feeling too good about this at the moment

  4. #4
    Join Date
    Dec 2008

    Default Re: Expert Partitioner gone haywire

    I can't manually assign all the correct types because Expert Partitioner has no assignment for an extended partition (type 0F
    That is correct, you do not mess with type '0F', think of it as a box for the logical volumes. It is not a true partition.

    As 'lwfinger' request , fdisk output is needed.

  5. #5

    Talking Re: Expert Partitioner gone haywire

    Thanks for the quick feedback.

    Problems Solved by using cfdisk to delete the errant primary partition from the extended partition, reinstalling OpenSUSE as normal, letting Windows create a new logical NTFS disk and restoring files to the new logical using file copying in Acronis instead of restore.

    Lessons learned (for future reference):

    - Don't "restore" physical partitions into logical drives using Acronis Home 11. Windows won't care but the partition table gets corrupted. Create an empty partition and "copy" in from a backup instead.

    - For partitioning problems during install, try starting parted with the live CD. It is what showed the message about overlapping partitions. Also be aware that the partitioner in the installer will not warn you about a corrupted partition table.

    - Examine the fdisk -l listing carefully to see if/where overlapping occurs.

    - Use cfdisk to delete the overlapping partition and restore it some other way (copy files off first if necessary).

  6. #6
    Join Date
    Jun 2008

    Default Re: Expert Partitioner gone haywire

    Simply use fdisk for partitioning.
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts