Results 1 to 10 of 10

Thread: warning: running BOINC as root user

  1. #1
    Join Date
    Jun 2008
    Location
    Brisbane, Australia
    Posts
    207

    Default warning: running BOINC as root user

    I've installed BOINC for first time (from suse repos). I'm worried about running BOINC as root. How can this be avoided? I'd first like to exhaust all options with the official opensuse repo version of BOINC. If I am unsuccessful, then I'll try the version from Berkeley website.
    NVIDIA! Listen to your customers! We want Free drivers.
    Petition #1. Petition #2. Use your VOICE! Sign the petitions!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,274

    Default Re: warning: running BOINC as root user

    I do not know much about the project, but I would hesitate to run as root. Is that required? I would even not run as 'myself', but most probably create a special user for it. Is that not an option.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,128

    Default Re: warning: running BOINC as root user

    I've been running different versions of BOINC for years on various platforms, from repos and from Berkeley but I don't think it ever ran from root. Which version are you trying and what does it say about running from root?

    I'm running 6.10.17. Running top, I see boinc, boincmgr and the World Community Grid apps all running as user.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,121
    Blog Entries
    15

    Default Re: warning: running BOINC as root user

    Quote Originally Posted by felipe1982
    I've installed BOINC for first time (from suse repos). I'm worried
    about *running BOINC as root*. How can this be avoided? I'd first like
    to exhaust all options with the official opensuse repo version of BOINC.
    If I am unsuccessful, then I'll try the version from Berkeley website.
    Hi
    You just need to run as your user, it should create a folder in your
    home directory etc. You should just need to run the command run_manager

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 4 days 1:46, 3 users, load average: 0.37, 0.35, 0.32
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  5. #5

    Default Re: warning: running BOINC as root user

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    No, it is not required. On my system I created a 'boincuser' and then run
    boinc from there (in a 'screen' no less so I can reconnect and kill it
    if/when necessary) I'm not sure how you installed BOINC but I did not use
    an RPM. Either way I doubt it matters since it is just a process.

    Create a new user for BOINC stuff (unless you want the graphical stuff
    with your current user, but let's assume you do not).

    Run the boinc manager piece to set things up unless you have a way you
    prefer to do the same.

    Optional: start a 'screen' session from the command line so you can
    reconnect to your process to kill it (nicer sometimes than killing the
    process later via the 'kill' command).

    Start BOINC and disconnect (if using screen). Watch your CPU go crazy. :-)

    Good luck.





    On 04/19/2010 07:26 AM, hcvv wrote:
    >
    > I do not know much about the project, but I would hesitate to run as
    > root. Is that required? I would even not run as 'myself', but most
    > probably create a special user for it. Is that not an option.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.12 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJLzGPhAAoJEF+XTK08PnB5cjMP/0OJURTXCeMMkPBcprZuKPI0
    RU/CcQk5tae1VxwaIIbcE8k3wzhx+5FYW/fXNg1dnHDFHVzASG5ylgJct6GQIxxR
    NkHCriFoMlfUZB+n79C7j7dUZG4edSBhGHpNU3o8qeAnjSSCsYOsQIbglzEyfCz2
    eiNLv7wlL2PzuOqO1tJ4GYDq26iMQn1Tg2n24W3/sq6XYI61BaggONkl6YyRBrUo
    QmBAkUuouOxYkFOn1M9XgbnHZHbSgpBPdP6ZHJidL/V82EaP6F2G0oSTMcTRsOBO
    DzI4O8zem0v4Wtv95R/5nv85LnCdaEPUI5y4Q2lHisMdLuV1EOWXcbnzBFz6BHQ+
    52YvW6sXvP/GHrMCsRmNthBQpKfqtJCd1QEhl6pEBg/SdIxNvvGeF9lfmOtdoviS
    fpL3njg03nbTKDS87PLIIIV2vsrBkl3dfvr1KPk5TRnvIyaPr3jozqwqunj1LcRP
    hdJVAf69QDIFPNySt8DDVkws5JnHr0WqNTOEIbqNyZ4oEiiI1b0IFZ4f2VFsYk5+
    2Qe4PUBpJoeyMtr5ZQS8rTkXeZkhvfzibqGjaNBxVcgmAI0PExcrJlmnbC9GAcoq
    gWTO2SPAn8vbxWF/S0B2p6KWVj5pcxQeneuGiyEEjcNqcY9xIfb4fNWMopXctO6s
    rg9nW0GYFU/RV6QqrySS
    =gu46
    -----END PGP SIGNATURE-----

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,121
    Blog Entries
    15

    Default Re: warning: running BOINC as root user

    Quote Originally Posted by ab@novell.com
    Start BOINC and disconnect (if using screen). Watch your CPU go
    crazy. :-)
    Hi
    GPU here, if your running NVidia, no CPU load.....
    Code:
    Mon 19 Apr 2010 09:19:56 AM CDT||CUDA devices found
    Mon 19 Apr 2010 09:19:56 AM CDT||Coprocessor: GeForce 8600 GTS (1)
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 4 days 2:00, 3 users, load average: 0.00, 0.23, 0.41
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


  7. #7
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: warning: running BOINC as root user

    malcolmlewis adjusted his/her AFDB on Mon 19 April 2010 15:20 to write:

    > GPU here, if your running NVidia, no CPU load.....
    >
    Code:
    > Mon 19 Apr 2010 09:19:56 AM CDT||CUDA devices found
    > Mon 19 Apr 2010 09:19:56 AM CDT||Coprocessor: GeForce 8600 GTS (1)
    >
    >


    I wish somebody would put out some units for the ATI GPU

    All dressed up with nowhere to go.

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  8. #8
    Join Date
    Jun 2008
    Location
    Brisbane, Australia
    Posts
    207

    Default Re: warning: running BOINC as root user

    BOINC version 6.4.5 from suse repos.

    Code:
    #
    #run as ordinary user
    #
    felipe@cheetah:~> pgrep -l boinc
    felipe@cheetah:~> ps aux | grep -i [b]oinc
    felipe@cheetah:~> /etc/init.d/boinc start
    WARNING: boinc-client will be running as root              [WARNING]
    The BOINC client requires initialization.                  [WARNING]
    touch: cannot touch `/var/log/boinc.log': Permission denied
    touch: cannot touch `/var/log/boinc_err.log': Permission denied
    Starting BOINC client as a daemon:  chown: changing ownership of `/var/log/boinc.log': Operation not permitted
    chown: changing ownership of `/var/log/boinc_err.log': Operation not permitted
    #
    # run as root
    #
    felipe@cheetah:~> sudo /etc/init.d/boinc start
    root's password:
    WARNING: boinc-client will be running as root              [WARNING]
    The BOINC client requires initialization.                  [WARNING]
    Starting BOINC client as a daemon:                         [OK]
    felipe@cheetah:~> ps aux | grep -i [b]oinc
    root      1557  0.2  0.3  53592  3708 pts/1    S    10:19   0:00 /usr/bin/boinc
    felipe@cheetah:~>
    felipe@cheetah:~> cat /etc/boinc-client.conf
    #
    # Default variable values for the boinc-client /etc/init.d script
    #
    #BOINCEXE_NAME=boinc_client
    #BOINCCMD_NAME=boinccmd

    # The userid under which boinc_client is run
    #BOINCUSER=boinc

    # The directory in which boinc_client is run
    #BOINCDIR=/var/lib/boinc

    # log files
    #LOGFILE=/var/log/${BOINCEXE_NAME}.log
    #ERRORLOG=/var/log/${BOINCEXE_NAME}_err.log

    # pid file
    #PIDFILE=/var/run/${BOINCEXE_NAME}.pid

    # placement of the lockfile depends upon the operating system
    # it will probably be one of the following:
    #LOCKFILE=/var/lock/subsys/${BOINCEXE_NAME}
    #LOCKFILE=/var/lock/${BOINCEXE_NAME}
    #LOCKFILE=/var/run/${BOINCEXE_NAME}.lock


    # BOINC options: for the command line when running the client.
    # Be aware that --allow_remote_gui_rpc opens up your machine to the world!
    #
    # Add this option if you want to allow boinc manager connections from remote
    # machines
    #BOINCOPTS="--allow_remote_gui_rpc"
    # Add this option if you want to turn off all logging
    #BOINCOPTS="--daemon"
    # Add this option if you want to redirect logging to the files stderrdae.txt
    # and stdoutdae.txt in BOINCDIR rather than LOGFILE and ERRORLOG
    #BOINCOPTS="--redirectio"
    # Add this option if you want to run only when no logins from anywhere are
    # active
    #BOINCOPTS="--check_all_logins"
    # The default is no options.
    #BOINCOPTS=
    #EOF
    The installation of BOINC and deps did *not* automatically create a new `boinc' user and/or `boinc' group.

    However a new user was created during install of mysql, apache, et al.

    I should report this as a bug with novell.

    I will create the user/group manually. Should I specify shell as `/bin/false` and home dir as /var/lib/boinc? Do i also need to change ownership of /var/lib/boinc to `chown boinc:boinc /var/lib/boinc' ?

    I will report a bug about this.

    -- thank you for all your assistance
    Felipe
    NVIDIA! Listen to your customers! We want Free drivers.
    Petition #1. Petition #2. Use your VOICE! Sign the petitions!

  9. #9

    Default Re: warning: running BOINC as root user

    Quote Originally Posted by malcolmlewis View Post
    Hi
    GPU here, if your running NVidia, no CPU load.....
    Code:
    Mon 19 Apr 2010 09:19:56 AM CDT||CUDA devices found
    Mon 19 Apr 2010 09:19:56 AM CDT||Coprocessor: GeForce 8600 GTS (1)
    Is there a way to make it exclusively use the GPU? I can only find options to make it use a mix of CPU and GPU, unless I am probably missing something. I have the same GPU as you, so it's detected and everything.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,121
    Blog Entries
    15

    Default Re: warning: running BOINC as root user

    Quote Originally Posted by i-ghost
    Is there a way to make it exclusively use the GPU? I can only find
    options to make it use a mix of CPU and GPU, unless I am probably
    missing something. I have the same GPU as you, so it's detected and
    everything.
    Hi
    AFAIK, no (it's being used as a coprocessor) all you can do is set how
    it's used in the boinc manager preferences.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 5 days 0:10, 3 users, load average: 3.43, 2.25, 1.18
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •