Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: audio problems - alsa, phonon,dell inspiron with ICH7

  1. #1

    Default audio problems - alsa, phonon,dell inspiron with ICH7

    I have a couple of audio problems that are bugging me.
    The first one:
    I have two backends for phonon: Xine and Gstreamer. :



    Xine has the following devices listed:



    And GStreamer has the following:



    Almost everything works good with Gstreamer except that I cannot skip through song length in amarok(cannot do Fast forward or rewind). I have some looong songs (non-stop remixes) and I want to play at different positions.

    If I select Xine backend, skipping works, but I get a new problem. The PCM slider (which I use as the main slider to work for both Master and LFE (subwoofer) I have) won't work. It won't respond to PCM slider. and The master channel works only if I lower the volume all the way to a little value (around 5%-10%). from withing amarok. If I don't use PCM slider, I cannot lower or raise the volume with one slider. I have to do it manually for both LFE and Master. (See the working sliders below):


    Second problem.
    My kmix will show these sliders everytime my computer boots.and everytime it works.
    working sliders:



    But each time I "logout" and log back in, I get these sliders instead. I tried creating a new user, but the problem persists.
    And the problem is that I do not get any sound at all, regardless of sliding every single sliders all the way up.

    not_working sliders (which I get ONLY but everytime I logout and log in):


    Here is my alsa-info:
    http://www.alsa-project.org/db/?f=41...70d0ff313210b4
    Last edited by wildnux; 18-Apr-2010 at 19:31. Reason: I left some info out.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: audio problems - alsa, phonon,dell inspiron with ICH7

    I don't know, but it looks like you have two sound cards, an Intel and a Sigmatel (my brother used to work for Sigmatel as an accountant). Or, you have an HDMI output and an analog sound chip as well. What sound options do you have in your BIOS setup? Do, you really have two sound cards? One on the motherboard and one you installed yourself? In most cases, you would want to disable one of them some how if you can.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: audio problems - alsa, phonon,dell inspiron with ICH7

    Hmm. I really don't know if I do have two sound cards. This is my Dell Inspiron E1705/9400 Laptop, with ICH7 sound card. (I believe so).

    As I am not an expert, I really am not sure about that. But My laptop has two speakers in front, and a subwoofer in the bottom. I do not have HDMI interface but i have digital video out and s-video out. For audio, I can see one mic, one linein and a headphones out on one side of my Laptop.

    Code:
    head -n 1 /proc/asound/card0/codec*
    yields:
    Code:
    ==> /proc/asound/card0/codec#0 <==
    Codec: SigmaTel STAC9200
    
    ==> /proc/asound/card0/codec#1 <==
    Codec: Conexant ID 2bfa
    I guess, Conexant is for modem?? (not sure )

    Give me some advice please.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: audio problems - alsa, phonon,dell inspiron with ICH7

    Have you looked into the sound hardware function in YaST? Open YaST, Select Hardware then the Sound Icon and see if more than one device is shown. If it shows two, I might disable the one that shows up second by deleting it. Real hardware that is present, but not configured will not be used by the alsa sound system. You can always go back later and reconfigure it if it does not help to be removed.

    I might also suggest you consider disabling pulse-audio and only use alsa. To disable pulse audio you open up a terminal session and enter the command su and then your password. Then enter the terminal command "setup-pulseaudio --disable" which will leave only alsa sound working. Pulse has created problems for lots of folks around in the forum.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: audio problems - alsa, phonon,dell inspiron with ICH7

    I have only one sound card listed in yast (sound):
    82801G(ICH7 Family) High Definition Audio Controller

    and I do not have pulseaudio. I am using Alsa only.

    And I found one more thing. Notice the "default" on the device listed on audio preferences with GStreamer backend in those photo? That is the one which works. If I use HDA Intel (STAC92xx Analog), It has the same problem with both backend.

    Now my question is how do I create the "default" device, or may be I can copy it from GStreamer Backend to Xine backend?

    I want to compare the default device and the HDA Intel device. PCM works with default but not with HDA Intel.

    Can anyone help please? some pointers...I don't even know where those configuration files are for those devices.

  6. #6

    Smile Re: audio problems - alsa, phonon,dell inspiron with ICH7

    At last, solved it. it is a bug:
    https://bugs.kde.org/show_bug.cgi?id=194902

    solved by creating a file .asoundrc in home directory, (can also create /etc/asound.conf instead of .asoundrc for systemwide effect.)
    with the following contents:
    Code:
    pcm.softvolPhonon {           
        type softvol              
        slave.pcm "default:CARD=0"
        control {                 
            name "Phonon"         
            card 0                
        }                         
        min_dB -51.0              
        max_dB 0.0                
        resolution 100            
        hint {                    
            show on               
            description "My Soundcard with extra Volume Control"
        }                                                       
    }

  7. #7

    Default Re: audio problems - alsa, phonon,dell inspiron with ICH7

    Just a quick question though, anyone know how to add mute to PCM? or Phonon (slider) in this case?? I still cannot mute with one key!

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: audio problems - alsa, phonon,dell inspiron with ICH7

    To set the Mute button if you are using KMix, put your mouse over the icon tray speaker, select it and then press the mixer button. In KMix, goto Settings and then Configure Shortcuts. Select the Mute Function on the Left with your mouse, a small window opens up. Select the Custom Bullet, then Select the "None" button which changes to "Input". Press the keyboard Mute button or other custom key stroke and it will be set for the "Master" setting. My mixer also offers to mute each individual input instead or with a different key stroke. Check it out, I am sure you will get the hang of it.

    And, I also am happy to hear you did find the solution to your problem, good troubleshooting on your part.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9

    Default Re: audio problems - alsa, phonon,dell inspiron with ICH7

    It did not work. I tried that with PCM before,and now as per your instructions, but when i press mute button, nothing happens.

    I remember that PCM slider never had mute button before also.BUt I clearly remember that on 10.3, when I pree mute button, it turned my PCM volume to 0 and when I press mute button again (unmute) would restore the value to whatever it was before.

    CAn anyone come up with solution to do the same?

  10. #10

    Default Re: audio problems - alsa, phonon,dell inspiron with ICH7

    Or how can i make both front and LFE mute (when I mute one of those)? That will work too.

    I think that was how opensuse 11.0 handled it!!

    Please let me know if anyone have any ideas.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •