Results 1 to 2 of 2

Thread: cannot retieve digital pics off Olympus D575Z

  1. #1

    Default cannot retieve digital pics off Olympus D575Z

    P4 2.4ghz 2.0 ram openSUSE 11.2 KDE 4.3.5

    CAMERA = olympus D575Zoom
    I am not sure that this post shouldn't be under the hardware section or if this only relates to digikam software.

    Have been using opensuse 11.2/kde4.3.5 for a few months now and for the most part its been good.
    It [machine and digikam] recognized my Canon xTi and I was able to download pics, no problem.
    However, When I plug the usb connection into my Olympus nothing much happens.
    I had no problems whatsoever in opensuse 11.0 with this camera, it worked with out fail.
    So now when I plug the usb cable in and then plug in to the camera, this is what happens:
    The device notifier pops up but the device is not listed.
    If I open a terminal and do [mount -ls] or [lsusb] or [fdisk -l] these are my results:

    Code:
    labud@linux-was9:~> mount -ls
    /dev/sda2 on / type ext3 (rw,acl,user_xattr) [RooT]
    proc on /proc type proc (rw)                       
    sysfs on /sys type sysfs (rw)                      
    debugfs on /sys/kernel/debug type debugfs (rw)     
    udev on /dev type tmpfs (rw)                       
    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
    /dev/sda3 on /home type ext3 (rw,acl,user_xattr) [HomE]
    /dev/sdb1 on /home/250LAB2010 type ext3 (rw) [250LAB2010]
    /dev/sdc1 on /home/320VOL type ext3 (rw) [320VOL]        
    fusectl on /sys/fs/fuse/connections type fusectl (rw)    
    securityfs on /sys/kernel/security type securityfs (rw)  
    /proc on /var/lib/ntp/proc type none (ro,bind)           
    gvfs-fuse-daemon on /home/labud/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=labud)
    Code:
    labud@linux-was9:~> lsusb                                                                    
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub                               
    Bus 001 Device 002: ID 0409:0058 NEC Corp. HighSpeed Hub                                     
    Bus 001 Device 004: ID 03f0:2305 Hewlett-Packard ScanJet 3970c                               
    Bus 001 Device 005: ID 04a9:10c8 Canon, Inc.                                                 
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub                               
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub                               
    Bus 003 Device 002: ID 046d:c316 Logitech, Inc. HID-Compliant Keyboard                       
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub                               
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub                               
    Bus 005 Device 003: ID 07b4:0105 Olympus Optical Co., Ltd Camedia C-310Z/C-700/C-750UZ/C-755/C-765UZ/C-3040/C-4000/C-5050Z/D-560/C-3020Z Zoom Camera

    Code:
    linux-was9:/home/labud # fdisk -l
    
    Disk /dev/sda: 163.9 GB, 163928604672 bytes
    255 heads, 63 sectors/track, 19929 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x0009abe9
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1               1         262     2104483+  82  Linux swap / Solaris
    /dev/sda2   *         263        6789    52428127+  83  Linux
    /dev/sda3            6790       19929   105547050   83  Linux
    
    Disk /dev/sdb: 250.1 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x0beb982e
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1               1       30401   244196001   83  Linux
    
    Disk /dev/sdc: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000dd9be
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdc1               1       38913   312568641   83  Linux
    I did a bit of googling and searched the forum here, but have found no solution yet. When I autodetect my camera in digikam it says it is a C2040Z [which just could mean it uses same driver, I think]. I tried PTP and Mounted camera types but, neither of them works. One solution I read was to buy a card reader because apparently that works. I have tried hooking the camera up to my acer Aspire D150 [running Moblin 2.1] and I can view the pictures on that machine so I know the camera is OK.

    I am at a loss as to where to go from here to get this working. Would anyone have any help for me please?
    Thank You

  2. #2

    Default Re: cannot retieve digital pics off Olympus D575Z

    Two further searches I came across revealed two possible ways to get this camera to be seen.

    1]In Digikam register the camera as PTP.
    Thats in the main Digikam window under Import > Cameras(Add) > Add Camera > Add > click on USB PTP Class Camera

    2]Shut machine down, plug USB device in and restart machine.

    I did both of these things and now it seems to be working, but I am not sure if one or the other or both were the solution.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •