Results 1 to 7 of 7

Thread: After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

  1. #1

    Default After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

    My sound card disappeared from Phonon upon the update and the pulseaudio "sound card" doesn't work.

    Any idea what to do with this? How can I get my sound card back?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

    I also updated to KDE 4.4.2 and my sound card was not present as well. However, I discovered that alsa was un-installed and the yast-sound application was removed during the KDE 4.4.2 update. I got sound back by reinstalling yast-sound and alsa and other related files that showed up when searching on sound and alsa.

    I still do not show anything but plusaudio in the Personnel Settings>Computer Administration>Multimedia section, but sound works just fine in everything. I think the problem is with Phonon & Alsa, and most likely will be working properly by the time openSUSE 11.3 comes out. However, this is one of the issues you can run in to when trying to use the latest KDE version.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

    My update didn't remove any packages, but I just managed to restore the original functionality by using:

    Code:
    setup-pulseaudio --disable

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

    So when you used the command "setup-pulseaudio --disable" did this cause anything to show up in your multimedia section?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

    Quote Originally Posted by jdmcdaniel3 View Post
    So when you used the command "setup-pulseaudio --disable" did this cause anything to show up in your multimedia section?

    Thank You,
    Yes, my soundcard is back.

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

    Well I gave the pulse audio disable command a try and it indeed worked for me as well. For those that might have this problem, here is the solution provided to us by Let_Me_Be.

    Start a Terminal Session:

    Code:
    su
    Password:
    setup-pulseaudio --disable
    You get a lot of action after the command. When complete, log out of KDE to restart a new session and then check to see if your sound card has been restored to your Multimedia section.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: After updating to KDE 4.4.2 from KDE repos, Phonon only displays pulseaudio which doesn't work

    Let_Me_Be, pulseaudio isn't installed by default, at least from 11.2 on. Are you using an older version than 11.2?

    Anyway, glad you got it working but I would just uninstall all of the pulseaudio packages.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •