Results 1 to 5 of 5

Thread: VirtualBox sees all USB ports as unavailable???

  1. #1
    Join Date
    Jan 2009
    Location
    San Diego, Ca.
    Posts
    87

    Default VirtualBox sees all USB ports as unavailable???

    I just set up Suse 11.1 64bit and installed Virtual Box 3.1.6. I had it running previously with no problems, however, this time I can't get it to recognize any USB ports. In fstab I entered the line None /proc/bus/usb usbfs devgid=1000,devmode=664 0 0 and ran mount -a (no go) I loaded Vmware Player and it uses the USB ports perfectly fine (go figure) I added to the "none" line auto,busgid=1000,busmode=0775,devgid= etc. Still a no go - vmware uses them no matter what I have in "fstab" what am I missing with Vbox? what didn't I do right???
    RJ

  2. #2
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: VirtualBox sees all USB ports as unavailable???

    Edit the file /etc/udev/rules.d/10-vboxdrv.rules to look like this:
    KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
    SUBSYSTEM=="usb_device", GROUP="vboxusers", MODE="0664"
    SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="vboxusers", MODE:="0664"
    Notice the ":" in 'MODE:="664"'!
    Then as root run the command:
    Code:
    udevadm trigger
    And start VBox.
    This change will be overwritten the next time you upgrade VBox, making an extra copy 11-vboxdrv.rules will prevent that!

  3. #3
    Join Date
    Jan 2009
    Location
    Orlando, FL
    Posts
    172

    Default Re: VirtualBox sees all USB ports as unavailable???

    Quote Originally Posted by hank_se View Post
    Edit the file /etc/udev/rules.d/10-vboxdrv.rules to look like this:


    Notice the ":" in 'MODE:="664"'!
    Then as root run the command:
    Code:
    udevadm trigger
    And start VBox.
    This change will be overwritten the next time you upgrade VBox, making an extra copy 11-vboxdrv.rules will prevent that!
    Excellent! Thanks so much for this post. I had the same problem, this fixed it immediately. Hopefully, they will change the updates for openSuSE to properly set the rules.
    Desktop - Custom Build | Intel i7-950 | Asus P6X58D Premium MB | openSUSE 13.2 X86_64 | 12GB Ram | NVidia GTX580 | KDE 4.14.8

  4. #4
    Join Date
    Jan 2009
    Location
    San Diego, Ca.
    Posts
    87

    Default Re: VirtualBox sees all USB ports as unavailable???

    Yep! It worked problem solved - Thanks much its really appreciated.
    RJ

  5. #5

    Default Re: VirtualBox sees all USB ports as unavailable???

    Hallo Mr. jonesjr and everybody,
    the problem with the usb support you described I had too: host system at teh moment is still opensuse 11.1, the guest installed in the virtualbox 3.1.4 is a windows XP professional SP3.
    Bevor an upgrade of the virtualbox from 3.1.4 to version 3.1.8 every usb device worked fine: it was recognised from the guest and in could be mounted and umounted by the host as desired.
    But after the upgrade the usb-filter menu was grey, an usb device could not be recognised by the guest.
    I did the same corrections in my configuration in
    /etc/udev/rules.d/10-vboxdrv.rules as follows:
    KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
    SUBSYSTEM=="usb_device", GROUP="vboxusers", MODE="0664"
    SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="vboxusers", MODE:="0664"
    only the ":" had to be added in the third line.
    after triggering my virtual box started as bevor the upgrade and
    the usb devices defined in the filter could all be seen from the
    windows guest.
    Thank you from me to for your help
    nob2klg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •