Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Firefox 3.6.3 to 3.5.9? Automatic Update System

  1. #1
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Default Firefox 3.6.3 to 3.5.9? Automatic Update System

    Today my automatic "Update System" made an remark that seems to me curious:
    !
    Mozillafirefox: Update to version 3.5.9
    firefox35upgrade2262 (noarch)
    !
    mozilla-xulrunner190:Update to version 1.9.0.19

    mozilla-xulrunner190-2261 (noarch)
    As I have already installed Firefox 3.6.3-1.2 (as 3.5.x/his xulrunner/Gecko had caused problems in my Yelp [helpsystem]) I wounder
    what this "security updates" are about.

    In the description of the fist I can see only many files like
    "MozillaFirefox-translations 3.0.[...]" under "New versions" and "Obsolves";
    in the description of the second only like
    "mozilla-xulrunner-translations1.9.0[...]".


    Are these updates really only affecting the translations and a downgrade for me?
    Why are they called "security updates"?

    In Software Manager of YaST I cannot see any upgrades belonging to Mozilla as "Suggested" or "Recommended".
    With the Group "All" and "Upgrades" marked I see ("Installed" to "Available"):
    -mhtml-firefox (0.5-1.25 to 0.5-1.27.2)
    -mozilla-xulrunner 190 (1.9.0.18-1.3 to 1.19.19-0.1.1)
    -mozilla-xulrunner 190-gnomevfs (1.9.0.18-1.3 to 1.9.0.19-1.1)
    -mozilla-xulrunner190-translations (1.9.0.18-0.1.1 to 1.9.0.19-0.1.1)
    and other (non-Mozilla) stuff.

    Can I change something in the automatic update system so it shows me more/more specific updates for the firefox 3.6 stuff?
    As I remember the days before:
    the updates from firefox 3.6.1 to 3.6.2 form there and to 3.6.3 or the ones to MozillaThunderbird 3.[...] to 3.0.4-2.3 had not been shown to me in the automatic Update System ether.

    Greetings
    your puzzled pistazienfresser

    ----
    Using openSuse 11.1 and Gnome 2.24.1 and Kernel Linux 2.6.27.45-01.1-pae (maybe I should update/new install 11.2?)

  2. #2
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Default Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    This morning I updated the (for update marked) translations over the graphical YaST/Software Manager. Now the update applet is quiet. Still firefox 3.6.3 is running. It seems to me it was/had been only a problem of naming the update(s).

    Greetings
    pistazienfresser

  3. #3
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Post Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    From update applet shows firefox 3.5.9 security update, but 3.6 already installed - openSUSE Forums :

    Quote Originally Posted by chief_sealth View Post
    What's the output of

    zypper se -is firefox
    As it maybe chief_sealth's suggestion could help him to help me or another here is my openSuse's output after inserting zypper se -is firefox in the terminal:

    Repository 'openSUSE-11.1-Update' is out-of-date. You can run 'zypper refresh' as root to update it.
    Loading repository data...
    Reading installed packages...

    S | Name | Type | Version | Arch | Repository
    --+------------------------------------+---------+---------------+--------+--------------------------------
    i | MozillaFirefox | package | 3.6.3-1.2 | i586 | openSUSE BuildService - Mozilla
    i | MozillaFirefox | patch | 2052 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 1780 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 1727 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 1499 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 1312 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 1202 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 1135 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 1000 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 860 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 833 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 745 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 591 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 509 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox | patch | 381 | noarch | openSUSE-11.1-Update
    i | MozillaFirefox-branding-upstream | package | 3.6.3-1.2 | i586 | openSUSE BuildService - Mozilla
    i | MozillaFirefox-translations-common | package | 3.6.3-1.2 | i586 | openSUSE BuildService - Mozilla
    i | MozillaFirefox-translations-other | package | 3.6.3-1.2 | i586 | openSUSE BuildService - Mozilla
    i | digitalme-firefox | package | 0.5.2385-2.43 | i586 | openSUSE:11.1
    i | digitalme-firefox | package | 0.5.2385-2.43 | i586 | openSUSE-11.1-Oss
    i | firefox35upgrade | patch | 2262 | noarch | openSUSE-11.1-Update
    i | mhtml-firefox | package | 0.5-1.27.2 | i586 | openSUSE-11.1-Update
    [...]
    Greetings
    pistazienfresser

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    According to the SUSE security news, in 11.1 FF 3.0.x was replaced by 3.5.9 because 3.0 is no longer supported. However you must have installed 3.6.x yourself, which would confuse the updater. So it's not clear which version you finally received, from your posting.

  5. #5
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Default Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    Hi,

    Quote Originally Posted by ken_yap View Post
    So it's not clear which version you finally received, from your posting.
    Quote Originally Posted by pistazienfresser View Post
    Still firefox 3.6.3 is running.
    I had firefox 3.6.3 running before the update via the "big" graphical YaST Software Manager and it keeps on running since that too.

    - MozillaFirefox 3.6.3-1.2 (i586) Installed at: 04/07/2010

    but:
    - mozilla-xulrunner190 1.9.0.19-0.1.1 (i586) Installed at: 04/14/2010
    - mozilla-xulrunner190-gnomevfs 1.9.0.19-0.1.1 (i586) Installed at: 04/14/2010
    - mozilla-xulrunner190-translations 1.9.0.19-0.1.1 (i586) Installed at: 04/14/2010
    [Think that's all.]

    Don't know what would have happened if I had updated via the automatic update applet but I don't know why it should have made much difference.

    Greetings pistazienfresser

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    I know you wrote that 3.6.3 was what you saw in the About, but I meant whether that was in a still running browser and therefore would change next time it is restarted, or whether you ended up files with 2 versions in different directories, or what. So it is not totally clear what kind of mix you ended up with and whether it will have any adverse effects remains to be seen. It looks at though you have 3.6.3 but 3.5.9 supporting libraries.

    However what has not happened is that the repository mislabelled the version as you suggested.

  7. #7
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Default Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    Hi ken_yap,
    Quote Originally Posted by ken_yap View Post
    According to the SUSE security news, in 11.1 FF 3.0.x was replaced by 3.5.9 because 3.0 is no longer supported. [...]
    You mean this?:
    [security-announce] SUSE Security Announcement: Mozilla Firefox 3.5.9 (SUSE-SA:2010:021)
    from Date: Wed, 14 Apr 2010 16:54:51 +0200

    Greetings pistazienfresser

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    Yes, the announcement also went out to those on the security mailing list.

  9. #9
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Default Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    Hi ken_yap,
    thanks for your questions.

    Quote Originally Posted by ken_yap View Post
    [...] but I meant whether that was in a still running browser and therefore would change next time it is restarted,
    It seems to me firefox 3.6.3 has started again after I had booted and start firefox again.

    Under firefox - Help - About Mozilla Firefox: "3.6.3"

    Quote Originally Posted by ken_yap View Post
    It looks at though you have 3.6.3 but 3.5.9 supporting libraries.
    Witch are my "3.5.9 supporting libraries"?

    Are they not needed for something else (thunderbird, yelp ...)?

    Could they cause something bad?

    According to the entry I can see in my YaST in the firefox 3.6.3 it requires:
    [...]
    mozilla-xulrunner192 = 1.9.2.3
    mozilla-xulrunner192-32bit = 1.9.2.3
    MozillaFirefox-branding >= 3.5
    mozilla-xulrunner192 >= 1.9.2.3-1.2
    mozilla-xulrunner192-32bit >= 1.9.2.3-1.2
    [...]

    I have

    <entry kind="package" name="mozilla-xulrunner192-translations-other" epoch="0" ver="1.9.2.3" rel="1.2" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner192-translations-common" epoch="0" ver="1.9.2.3" rel="1.2" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner192-gnome" epoch="0" ver="1.9.2.3" rel="1.2" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner192" epoch="0" ver="1.9.2.3" rel="1.2" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner191-translations-other" epoch="0" ver="1.9.1.9" rel="3.2" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner191-translations-common" epoch="0" ver="1.9.1.9" rel="3.2" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner191-gnomevfs" epoch="0" ver="1.9.1.9" rel="3.2" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner191" epoch="0" ver="1.9.1.9" rel="3.2" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner190-translations" epoch="0" ver="1.9.0.19" rel="0.1.1" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner190-gnomevfs" epoch="0" ver="1.9.0.19" rel="0.1.1" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner190" epoch="0" ver="1.9.0.19" rel="0.1.1" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner181-l10n" epoch="0" ver="1.8.1.19" rel="1.1" arch="i586"/>
    <entry kind="package" name="mozilla-xulrunner181" epoch="0" ver="1.8.1.19" rel="1.1" arch="i586"/>
    <entry kind="package" name="mozilla-nss-certs" epoch="0" ver="3.12.6" rel="4.1" arch="i586"/>
    <entry kind="package" name="mozilla-nss" epoch="0" ver="3.12.6" rel="4.1" arch="i586"/>
    <entry kind="package" name="mozilla-nspr" epoch="0" ver="4.8.4" rel="1.1" arch="i586"/>
    <entry kind="package" name="mozilla-kde4-integration" epoch="0" ver="0.6" rel="25.1" arch="i586"/>

    Thanks
    pistazienfresser

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Firefox 3.6.3 to 3.5.9? Automatic Update System

    I don't know whether the version of the libraries you have would cause problems or not. I guess you're the guinea pig.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •