Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Default app for HTML - error

  1. #1
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Angry Default app for HTML - error

    I have installed Swiftfox, and made it default, and after, removed it. Firefox is set as default, but when I want to open any html file by double clicking, it gives error as swiftfox does not exists.

    I went on right-click and verified, firefox is set as default.
    Then I went to personal settings, gone to Default apps... firefox already there, but I tried to change it to other (flock), setting is disregarded.

    I suspect that link "firefox" is made to swiftfox, but I dont have it anywhere on menu..

    Somewhere this settings is written.. can anyone direct me?
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Default app for HTML - error

    You know I run into kind of the same problem in that HTML files would not load any browser. Oddly, I installed the gnome evolution browser while playing with Banshee and when I ran Firefox the next time, I was told it was not my default browser and should it be. I answered yes and low and behold, HTML files now load Firefox. It is kind of a strange solution, but you might try it.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Default app for HTML - error

    You may be suffering from the same problems I did a while ago trying to convince Evolution (a Gnome app) to use Firefox instead of the default Gnome browser:

    * With YAST, install gconf-editor
    * From a Terminal, run: gconf-editor
    * Navigate to desktop/gnome/url-handlers/http
    * For "Command", enter without quotes: 'firefox %s'
    * Repeat this for desktop/gnome/url-handlers/https
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  4. #4
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Default app for HTML - error

    I do not use Gnome... kde4
    but thanks
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Default app for HTML - error

    You should be able to fix that in Personal settings - Advanced - File Associations.

  6. #6
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Default app for HTML - error

    I did that, as I mentioned it in post above. It's "firefox".

    I think that the problem is that "firefox" points to non-existing swiftfox directory. This setting is written somewhere, but I do not know where. It is not in /home/myuser
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Default app for HTML - error

    Then I went to personal settings, gone to Default apps... firefox already there, but I tried to change it to other (flock), setting is disregarded.
    Thats not the same thing as gogalthorp has suggested

    You should be able to fix that in Personal settings - Advanced - File Associations.
    The latter is directly responsible for KDE selecting the preferred app when an html file is clicked on.

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Default app for HTML - error

    If it was me, I might try to uninstall and then reinstall Firefox OR, you might downgrade Firefox to an older version and then upgrade it back again to the latest version, if you have not already tried that. See if this might cause something good to happen. Further, while you are not using GNOME, it does not hurt, unless you are running low on disk space, to load the two GNOME patterns and allow it to install. Thus making it possible to run GNOME apps in KDE, give you a backup plan should you blow up KDE and it might allow Firefox to heal its self as it did for me.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Default app for HTML - error

    Edit: Already submitted post, and disconnected from Internet.

  10. #10
    Join Date
    Jun 2008
    Location
    Belgrade, Serbia
    Posts
    719

    Default Re: Default app for HTML - error

    Nope... RESOLVED THE PROBLEM

    how stupid....
    Link in the menu for "firefox" pointed to non-existing swiftfox. Seems that all settings by file associations try to locate menu item 1st, and if found, use it.

    Editing the menu shortcut resolved the problem.

    Question for KDE developers: is this the right way to execute things, based on menu item record?
    Emil Beli
    http://www.beli.ws/blog/
    openSUSE 11.4 x64 KDE, ATI 5600, i7 dell inspire laptop

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •