Results 1 to 6 of 6

Thread: kwin effects not enabled at login

  1. #1

    Default kwin effects not enabled at login

    I'm having 2 small problems with kwin effects.

    My first problem is, that the effects aren't enabled when I log in. The weird thing is, that I can enable them by pressing Alt+F12 but I have to press it twice. So I think that the system thinks that the effects are enabled, but for some reason isn't rendering the desktop correctly.

    My second problem is, that I can't seem to get cover switch to work. It's checked in my kwin effects settings, but I keep getting the tabbox.

    My graphics card is an ati hd3650 with the latest fglrx drivers from the ati repositories installed.

    Below are the compositing settings from the kwinrc file if that helps finding the problem

    [Compositing]
    AnimationSpeed=3
    Backend=OpenGL
    CheckIsSafe=true
    DisableChecks=false
    Enabled=true
    GLDirect=true
    GLMode=TFP
    GLTextureFilter=1
    GLVSync=true
    HiddenPreviews=5
    XRenderSmoothScale=false
    Thanks for the help.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: kwin effects not enabled at login

    A good troubleshooting method is to create a new user account and see if the behaviour is the same there. Sometimes .kde4 gets cruddy and may need to be replaced with a new .kde4 folder. But before we do that, try a new account and see if it is the same.
    Login as the new user, try it and report back.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: kwin effects not enabled at login

    Created a new account and also have the same problems in that account. Won't start compositing effects unless I press Alt+F12 twice. Cover switch still showing tabbox.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: kwin effects not enabled at login

    You have checked the box in system settings to enable desktop effects?

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: kwin effects not enabled at login

    Effects have been enabled, but under compositing state is says that compositing has been temporarily disabled.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: kwin effects not enabled at login

    I expect this is an issue with your graphics drivers.
    Unfortunately. ATI is not my field. @oldcpu may be able to help you if he sees this.
    openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •