Results 1 to 8 of 8

Thread: snd_hda_intel передняя панель

  1. #1

    Default snd_hda_intel передняя панель

    Никак не могу завести звук с передней панели (наушники и микрофон). Материнка Интел DQ965GF. Звук встроенный Sigmatel STAC9227 (3 разьема сзади, 2 спереди). Передние разъемы к материнке подключены, когда еще стояла семерка (около полугода назад), то все вполне работало. Звук 5.1 работает. В alsamixer все выкручено на максимум.
    Code:
    magist3r@dhcppc0:/etc/modprobe.d> cat 50-sound.conf
    options snd slots=snd-hda-intel
    # u1Nb.q42dAxRASIA:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=3stack
    magist3r@dhcppc0:/etc/modprobe.d>
    Что еще интересно: поставил audacity - сегфолтится при запуске
    Code:
    magist3r@dhcppc0:~> audacity
    Expression 'stream->capture.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3653
    Ошибка сегментирования
    Может это как-то и связано.

  2. #2
    Join Date
    Nov 2008
    Location
    Saint-Petersburg, Russia
    Posts
    1,113

    Default Re: snd_hda_intel передняя панель

    Вообще обычно передние разъёмы - это просто дубликат задних, просто схема соединения отдаёт им приоритет, если в них вставлен штекер и цепь замыкается. Поэтому довольно странно, что это не работает. Что именно вы не можете "завести", что делаете, как проверяете?
    "Лучше молчать и прослыть дураком, чем открыть рот и развеять все сомнения." Марк Твен.

  3. #3

    Default Re: snd_hda_intel передняя панель

    ну банально - втыкаю наушники, звука нет. втыкаю другие, звука тоже нет. наушники рабочие, проверял. А почему передние именно дубликаты задних, и что управляет приоритетом передние/задние??
    openSUSE 11.3 2.6.34.7-0.5-desktop i686 KDE 4.5.4

  4. #4
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,001
    Blog Entries
    1

    Default Re: snd_hda_intel передняя панель

    Эту тему надо в "железный" раздел.

  5. #5
    Join Date
    Nov 2008
    Location
    Saint-Petersburg, Russia
    Posts
    1,113

    Default Re: snd_hda_intel передняя панель

    Quote Originally Posted by Lazy_Kent View Post
    Эту тему надо в "железный" раздел.
    Воистину так.

    Несколько разъёмов в одном и том же канале - это чисто аппаратная реализация, работающая независимо от операционной системы. Автор, посмотрите на материнке - вдруг там просто джампер какой не так стоит? Когда втыкаете наушники в передний разъём звук из колонок пропадает?
    "Лучше молчать и прослыть дураком, чем открыть рот и развеять все сомнения." Марк Твен.

  6. #6

    Default Re: snd_hda_intel передняя панель

    Нет, передние разъемы - не дубликат задних, хотя обычно так работают.
    Была та же проблема на похожей материнке (DP965LT) в openSUSE 11.1. В том числе поэтому не стал на нее переходить с openSUSE 11.0. На последней все работает. Более новые версии не проверял.

  7. #7
    Join Date
    Nov 2008
    Location
    Saint-Petersburg, Russia
    Posts
    1,113

    Default Re: snd_hda_intel передняя панель

    В таком случае на материнке обычно есть джампер, который этим руководит. У меня можно, переткнув перемычку, развести из стандартной раскладки (передние дублируют задние) звук 5.1 (т.е. перевести все разъёмы в режим вывода), но т.к. опробовать не на чем, то я не пытался это осуществить.
    "Лучше молчать и прослыть дураком, чем открыть рот и развеять все сомнения." Марк Твен.

  8. #8

    Default Re: snd_hda_intel передняя панель

    Так. Чтото дернуло меня проверить микрофон на передней панели - с ним все в порядке! А вот разьем под наушники так и не работает.
    openSUSE 11.3 2.6.34.7-0.5-desktop i686 KDE 4.5.4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •