Results 1 to 7 of 7

Thread: Digital clock is missbehaving

  1. #1
    Join Date
    Apr 2010
    Location
    Ume
    Posts
    3

    Default Digital clock is missbehaving

    Hey, i got this problem, for some reason my digital clock has not changed to summer time and i payed heavily for that, never the less it doesnt go to change in the settings either, and it is bugging me a lot that it doesnt automatically update specially that in the meantime it is one hour ahead ... meaning winter time Helps me! Please.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Digital clock is missbehaving

    Ok exactly what are you talking about. There must be a gizzilian different clock package in Linux. Think you could narrow it down?

  3. #3
    Join Date
    Apr 2010
    Location
    Ume
    Posts
    3

    Default Re: Digital clock is missbehaving

    There is this widget, the digital clock that is on my bar next to all sort of other widgets and it supposed to change to summer time, that is europe stockholm. But it doesnt change automatically cuz it is still wintertime that is one hour ahead and it doesnt work to do setting change clock, it seams like it got it's own little life.

  4. #4
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Digital clock is missbehaving

    macyaway adjusted his/her AFDB on Sun 11 April 2010 00:46 to write:

    >
    > There is this widget, the digital clock that is on my bar next to all
    > sort of other widgets and it supposed to change to summer time, that is
    > europe stockholm. But it doesnt change automatically cuz it is still
    > wintertime that is one hour ahead and it doesnt work to do setting
    > change clock, it seams like it got it's own little life.
    >
    >


    First off you have to understand how many clocks there are on your system,
    how they are set and what can affect the way the display.

    1) The actual hardware clock

    This is the time your computer keeps in the internal hardware, how it is set
    in the BIOS.

    2) there is the setting in Yast for the harwdare clock, this can be set for
    either UTC or LOCAL time

    3) The personal time setting, do not forget that Linux is a multi user
    system so that you could be logging in from a different country so a different
    time zone which you would have setup in your settings so even though you
    would be taking your initial setting from the system ( wherever that is )
    your personal settings would add or subtract the needed amount to set it to
    local time, but only for the period you are logged on, it does not affect the
    actual hardware clock this stays set at UTC.


    If you only use Linux on this system then the easiest way is to set your
    BIOS clock to UTC, the actual setting in Yast for the Hardware clock to UTC
    and keep it synchronised to a time server with no offset and in your personal
    settings to your local timezone, this then would keep you BIOS set with a
    time server to UTC no matter where you are, and the timezone offset would
    kick in when needed.

    However the down side is that if you are dual booting then if your other OS
    does not honour this same way of keeping your time updated then every time
    you reboot from one O/S to the other it will reset the Hardware clock to
    different times.

    So I have my hardware clock in the BIOS set to UTC and my personal time zone
    set to London on my PC`s and all is well, on my laptop if i travel to a
    different timezone I just alter the personal settings and voila it adjust
    automatically for me but the hardware clock still is set to UTC.

    Now not too sure on the way Windows handles this anymore but in the old days
    it would only have one time setting "Local" time so when it adjusted the
    clock for DST or Summer time it would also adjust the BIOS clock so when you
    rebooted to linux it either would be out by that many hours or you would
    have to set the clocks to just Local time both BIOS and Personal so that the
    time was not changed or you could set Windows to not change the clock and
    have windows be out of sync.

    The choice is yours.

    hope this explains it, it is a bit awkward trying to explain in a message
    how it works but once you see why it does it then it is easy to understand.

    HTH


    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Digital clock is missbehaving

    If you are dual booting set the clock to be local in Yast.

  6. #6
    Join Date
    Apr 2010
    Location
    Ume
    Posts
    3

    Thumbs up Re: Digital clock is missbehaving

    awww fanks you papa penguin now i can go rule the wjld!
    Problem is that i got Vista, Suse and Fedora and it is only the suse that is being silly so i recon i'll fiddle around with YaST some more... oddly enough my UTC is giving me 4 hours ahead... and as i discovered it was not winter time summer time issue, it was more that it went ahead 2 hours instead of one... Finally got to grasp that winter time is one hour back, summer time one hour ahead. I had one hour ahead of the summer time. Changed it manually in the end.
    Wll, i wish you a pleasant weekend, thanks for the detailed msg i sure got to know some parts i didn't knew of!

  7. #7
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Digital clock is missbehaving

    macyaway adjusted his/her AFDB on Sun 11 April 2010 12:36 to write:

    >
    > awww fanks you papa penguin now i can go rule the wöjöld!
    > Problem is that i got Vista, Suse and Fedora and it is only the suse
    > that is being silly so i recon i'll fiddle around with YaST some more...
    > oddly enough my UTC is giving me 4 hours ahead... and as i discovered it
    > was not winter time summer time issue, it was more that it went ahead 2
    > hours instead of one... Finally got to grasp that winter time is one
    > hour back, summer time one hour ahead. I had one hour ahead of the
    > summer time. Changed it manually in the end.
    > Wöll, i wish you a pleasant weekend, thanks for the detailed msg i sure
    > got to know some parts i didn't knew of!
    >
    >


    You are more than welcome, hope you had a nice one too.

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •