Results 1 to 5 of 5

Thread: Gnome: disabling "show desktop" shortcut

  1. #1
    Join Date
    Jan 2010
    Location
    Albany, NY USA
    Posts
    118

    Default Gnome: disabling "show desktop" shortcut

    Hi everybody,

    I'm using Gnome on openSUSE 11.2. I can't get rid of the ctrl-alt-d keyboard shortcut in Gnome. I have set it to "disabled" in control center -> keyboard shortcuts, but no luck.

    When I run the gnome-keybindings-properties program from the terminal it dumps these two messages onto stderr:

    (gnome-keybinding-properties:11958): keybinding-properties-WARNING **: No description for key '/apps/compiz/general/allscreens/options/opacity_decrease_key'

    (gnome-keybinding-properties:11958): keybinding-properties-WARNING **: No description for key '/apps/compiz/general/allscreens/options/opacity_increase_key'

    and the following two messages like 20 or so times:

    (gnome-keybinding-properties:11958): Gtk-CRITICAL **: gtk_tree_store_append: assertion `VALID_ITER (parent, tree_store)' failed

    (gnome-keybinding-properties:11958): Gtk-CRITICAL **: gtk_tree_store_set_valist: assertion `VALID_ITER (iter, tree_store)' failed

    I realize this isn't the most critical problem, but I am experimenting with Guile (scheme as a C extension language) which I am editing in Emacs, and even after reassigning "down-list" I keep hitting C-M-d because it's right by C-M-f which I also use constantly, and this minimizes all my windows! And there is nothing on my desktop, I never use the feature intentionally. Maybe I should get a wallpaper that says "HaHa Dummy!" or something of the sort to at least get a chuckle out of it when it happens.

    Anyhow, all help will be appreciated.

    Thanks,
    Malcolm

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,864
    Blog Entries
    15

    Default Re: Gnome: disabling "show desktop" shortcut

    Quote Originally Posted by malcolm81
    Hi everybody,

    I'm using Gnome on openSUSE 11.2. I can't get rid of the ctrl-alt-d
    keyboard shortcut in Gnome. I have set it to "disabled" in control
    center -> keyboard shortcuts, but no luck.

    Anyhow, all help will be appreciated.

    Thanks,
    Malcolm
    Hi
    Are you running desktop effects? If so it needs disabling there as
    well. On Gnome it's in general options -> key bindings.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 11 days 17:36, 4 users, load average: 0.18, 0.25, 0.33
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53


  3. #3
    Join Date
    Jan 2010
    Location
    Albany, NY USA
    Posts
    118

    Default Re: Gnome: disabling "show desktop" shortcut

    Quote Originally Posted by malcolmlewis View Post
    Are you running desktop effects? If so it needs disabling there as
    well. On Gnome it's in general options -> key bindings.
    No I don't think I have them enabled, and it definitely doesn't look like it, but I have disabled the keybinding there as well without at any improvement.

    Thanks,
    Malcolm

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,864
    Blog Entries
    15

    Default Re: Gnome: disabling "show desktop" shortcut

    Quote Originally Posted by malcolm81
    malcolmlewis;2150144 Wrote:
    >
    > Are you running desktop effects? If so it needs disabling there as
    > well. On Gnome it's in general options -> key bindings.
    >


    No I don't think I have them enabled, and it definitely doesn't look
    like it, but I have disabled the keybinding there as well without at any
    improvement.

    Thanks,
    Malcolm
    Hi
    Start gconf-editor apps->metacity->global_keybindings and remove the
    string value via double-click an 'show_desktop'

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 11 days 19:09, 4 users, load average: 1.54, 0.88, 0.50
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53


  5. #5
    Join Date
    Jan 2010
    Location
    Albany, NY USA
    Posts
    118

    Default Re: Gnome: disabling "show desktop" shortcut

    Woohoo! that got it.

    Thanks!
    Malcolm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •