Results 1 to 9 of 9

Thread: lotus notes 8.5 on openSUSE 11.2

  1. #1
    Join Date
    Jun 2009
    Location
    Timisoara, Romania
    Posts
    190

    Question lotus notes 8.5 on openSUSE 11.2

    Hello all,

    I just installed openSUSE 11.2 on my work desktop an in order to get my work mail I installed Lotus Notes 8.5.

    My fist problem was that some dialogs were entirely blank.
    I got the resolution for this problem from a blog post ( OpenSuSE 11.2 and Lotus Notes 8.5 Flavio Preto’s Weblog )

    but now when I open the mail in order to read the the application is crashing without errors.

    Does anyone from here uses lotus notes 8.5 on openSUSE 11.2 on 32 bits?

  2. #2

    Default Re: lotus notes 8.5 on openSUSE 11.2

    I am pretty sure that you have problems with SWT Webbrowserwidget. You need the correct Xulrunner Version for SWT. Install XULRunner and follow the steps in The SWT FAQ to point SWT to use the correct XULRunner.

    Greetings

    Ralf

  3. #3
    Join Date
    Jun 2009
    Location
    Timisoara, Romania
    Posts
    190

    Question Re: lotus notes 8.5 on openSUSE 11.2

    On IBM site ( IBM - Notes 8.5 - Required Linux packages and updates ) I saw that "Notes 8.5 on Linux uses an embedded Xulrunner runtime browser. The Firefox browser is no longer required for Linux clients running Notes 8.5 or greater."

    Quote Originally Posted by petter_r View Post
    I am pretty sure that you have problems with SWT Webbrowserwidget. You need the correct Xulrunner Version for SWT. Install XULRunner and follow the steps in The SWT FAQ to point SWT to use the correct XULRunner.

    Greetings

    Ralf

  4. #4

    Default Re: lotus notes 8.5 on openSUSE 11.2

    Hi,

    I'm having the same problem as ionpetrache.
    According to the link that he posted, I guess that the xulrunner version embedded in the Lotus Notes 8.5 installation package, is compatible with the SWT, which is also embedded(I don't have ).
    I've found that the embedded xulrunner is placed under the following location:

    /opt/ibm/lotus/notes/framework/rcp/eclipse/plugins/com.ibm.rcp.xulrunner.runtime.linux.x86_6.2.0.200811140851/xulrunner

    Is there any workaround that does not imply some knowledge about Java/SWT?

  5. #5

    Default Re: lotus notes 8.5 on openSUSE 11.2

    I've managed to find the cause of this problem.
    The problem is caused by the /usr/lib/browser-plugins/javaplugin.so, which is a symlink to /etc/alternatives/javaplugin, which in turn is a symlink to /usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaPlugin.so

    If I move the javaplugin.so symlink, to another folder, I'm able to run Lotus Notes, and read the emails I have received.

    How can I make Lotus Notes, to ignore the /usr/lib/browser-plugins folder, so that Firefox will still be able to use the /usr/lib/jvm/jre-1.6.0-openjdk/lib/i386/IcedTeaPlugin.so plugin and run Java applets?

  6. #6
    Join Date
    Jan 2010
    Location
    The Netherlands
    Posts
    4

    Default Re: lotus notes 8.5 on openSUSE 11.2

    a bit offtopic:

    Regarding the GTK issue I can confirm the upcomming version of Lotus Notes (8.5.2 not fp2) support GTK+ greater then 2.18.

    I'ts nice to finally have a good looking (qtcurves) notes client again.

  7. #7

    Default Re: lotus notes 8.5 on openSUSE 11.2

    I've removed openjdk and installed java-sun packages and now Lotus Notes does not crash anymore when reading emails.

    @YoupY
    Do you know when Lotus Notes 8.5.2 will be available?
    Thanks

  8. #8

  9. #9

    Default Re: lotus notes 8.5 on openSUSE 11.2

    Lotus Notes 8.5.2 is planned to be available in Q3 2010

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •