Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: problem with the installation of kde4

  1. #1

    Default problem with the installation of kde4

    Hello, I have initiated the installation of kde4 stable since

    KDE/KDE4 - openSUSE # Installation via one click install as I put into that version 4.3.5 web while KDE4 - openSUSE makes me who has the 4.3.4 that this is not strange?

    When I start the installation and then download and install some packages supposedly I get the following message:

    Installing applications
    Unable to install all packages.
    Unable to install the following packages
    kde4-dolphin
    kde4-kdepasswd
    kde4-kdialog
    kde4-keditbookmarks
    kde4-KFind
    kde4-kio_sysinfo-branding-openSUSE
    kde4-kmix
    kde4-konqueror
    kde4-konsole
    kde4-kwin
    kde4-kwrite

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,449

    Default Re: problem with the installation of kde4

    Conflicts can arise when downloading different versions of KDE4. I had this problem after trying out KDE4.4.1 on my spare machine and in the end I reinstalled 11.2 which was immediately updated to 4.3.5.

  3. #3

    Default Re: problem with the installation of kde4

    I have only gnome and two applications kde installed gwenview okular and why I do not understand the problem.

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: problem with the installation of kde4

    Don't use the one-clicker here, it is not recommended to use them when installing several packages at once. The best (and generally only) way is to activate the needed repositories and install via YaST / zypper directly (when installing KDE4, one can use a pattern install, so you won't have to choose every single package).

    Which Version of KDE4 would you like to install? Which version of SuSE do you use?

  5. #5

    Default Re: problem with the installation of kde4

    Using version 11.2 and I want to install kde 4.3.5 Stable

    Thank you.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: problem with the installation of kde4

    Go to Yast Software Management Select Patterns tab select KDE selections install

  7. #7
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: problem with the installation of kde4

    You will first have to add the needed repositories, here's the zypper-way to do it:

    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/ KDE4:Stable
    zypper ar -f http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.2/ KDE4:Stable-Community
    ar = add repository, f = set to autorefresh

    Make sure no other KDE4-repositories are enabled before proceeding.

    As mentioned before, instead of having to choose what packages are needed by KDE4, you can install patterns which will fetch the basic KDE4-environment and some more. The patterns are 'kde4' and 'kde4_basis', and it works like this:

    Code:
    zypper in -t pattern kde4 kde4_basis
    ...and that's pretty much it. You should now be able to switch to KDE from your login-manager (I don't know about GNOMEs GDM, but there should be a menu called "Sessions" or "Options" or something like that to choose the desktop environment). You can find out about the KDE-version you use by entering

    Code:
    kde4-config -version
    ...just to be sure. Use YaST to browse through the two KDE-repositories to see what applications, plasmoids and extras are offered. The command

    Code:
    zypper search -t pattern | grep kde4
    ...will show you what other KDE4-patterns are available.

    Hope it works out.

  8. #8

    Default Re: problem with the installation of kde4

    ok I have it installed and working.

    One more question:

    in gnome I have installed the cairo-dock mac style bar but also is loaded into the kde desktop, runs but with some inconsistency.

    "It mixes both desktop settings? "I can make cairo-dock to run in gnome but not in kde?

    Is there any application similar to cairo-dock kde?

    Thank you.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    37

    Default Re: problem with the installation of kde4

    Quote Originally Posted by gropiuskalle View Post
    You will first have to add the needed repositories, here's the zypper-way to do it:

    Code:
    zypper ar -f http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/ KDE4:Stable
    zypper ar -f http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.2/ KDE4:Stable-Community
    If using openSUSE-11.2 there is no need to add KDE4:Stable.

    OpenSUSE-11.2 has an "official" Novell/SuSE-GmbH update from KDE-4.3.1 to 4.3.5.

    Why recommend a user update to a "KDE4:Stable" repository for 4.3.5 which is NOT supported by Novell/SuSE-GmbH when instead one can use a 4.3.5 from "Update" repository which IS supported by Novell ??

  10. #10
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: problem with the installation of kde4

    I totally forgot about that (and that is due the fact that *usually* packages will not get upgraded via the 'update'-repository - you know that very well, oldcpu), so: sorry, the KDE4:Stable-repo is not needed indeed (unlike the Community-repo, which packages will *not* be upgraded via 'update').

    jony127: remove the KDE4:Stable repo.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •