Results 1 to 8 of 8

Thread: Virtualbox: Opensuse 11.2 64 bit refuses to install

  1. #1
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Virtualbox: Opensuse 11.2 64 bit refuses to install

    I installed the closed source version of virtualbox (last edition) in 11.1 KDE 3.5. When I try to install virtualized Opensuse 11.2 64 bit it tells me my PC is a 32 bit and not capable of doing this.

    a) my PC is actually an AMD64 Athlon with a 64 bit installation of 11.1

    b) the vbox software should in all case be able to run 64 bit OS even on 32bit OS host (if you accept the overhead.

    Where did I do an error in setting up?
    Is this eventually a known issue? Didn't see any indication of this.

    32bit OS run well on this installation. So the issue is limited to 64 bit.

    Thanks
    Just "clicking away" security warnings about a change in repo signature ? Not able to control?
    Then please vote for
    https://features.opensuse.org/312047
    openSUSE should have an efficient web of trust.

  2. #2

    Default Re: Virtualbox: Opensuse 11.2 64 bit refuses to install

    Quote Originally Posted by stakanov View Post
    b) the vbox software should in all case be able to run 64 bit OS even on 32bit OS host (if you accept the overhead.
    It does here (Host 11.1 i586 or x86_64, Guest 11.2 x86_64 or i586), although with Intel CPU, but well, that shouldn't make a difference.

    Quote Originally Posted by stakanov View Post
    Where did I do an error in setting up?
    - Wrong setting in choosing the OS type for the guest.

    - Wrong setting in number of CPUs used (read help of VBox on that).

  3. #3

    Default Re: Virtualbox: Opensuse 11.2 64 bit refuses to install

    Starting an 64 bit operating system with virtual box requieres VT-x or, in your case, the AMD-V CPU extension. Maybe this is not supported by your CPU and this case it is greyed like in my box (sorry, my screenshot is not in english but you should be able to find it).
    (Or maybe the check for activating the acceleration is simply missing)


  4. #4

    Default Re: Virtualbox: Opensuse 11.2 64 bit refuses to install

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Or, if it is supported by your CPU, is not enabled in your BIOS. Chances
    are very good that if it is not explicitly enabled (by you) it is disabled
    by default (I've yet to see a machine otherwise).

    Go into your BIOS and enable Virtualization.

    Good luck.





    On 04/05/2010 04:06 PM, daKump wrote:
    >
    > Starting an 64 bit operating system with virtual box requieres VT-x or,
    > in your case, the AMD-V CPU extension. Maybe this is not supported by
    > your CPU and this case it is greyed like in my box (sorry, my screenshot
    > is not in english but you should be able to find it).
    > (Or maybe the check for activating the acceleration is simply
    > missing)
    >
    > [image: http://i41.tinypic.com/aw5lsj.png]
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.12 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJLumSsAAoJEF+XTK08PnB5NzIQANDxETSnnDImPbBcKLyRTbs4
    CSPjJK4AVfZIR8CJ8k8vbAAQMw4nYVDe6HDFAypFGXUGcP04vCDKLBaFWISDXm90
    FU6vS/wi0RqWftXhOmCsBot+TTwfb87pfOO0dbiCPq+fovppKnrcpji41oxoyIhc
    EJwZQXzbJObcXpReqxGWZgXV9jrbEm5fzlbII7adnzfyYAM823mLQptil8wkYBsk
    V8gaicWQeASFZ2BwlGenurr0C5Fo4W5KGeeSAhggHGzFfCnQer55hmtQBhJPKS/w
    1ekAx92FoAkG0LN6WKxBZzLLlQ9oR58tcFmem9Gmu2+VRGV6jUmCrik2LwlfhUAd
    9F2wtQ1QLOj2IrMyuqTp6K8/hVFaHqRqOgXRmueZNds14Lsx4+LFEvbA7OFy+FQg
    vadZNglg4xgM7W7UqSm58OuQA1bYVoUw2Wj3Ql1RkZGGMh78lZQK93Bw1/zeTCn+
    73AA59WCzb2AdVkORXosLbOZZNkviFRWKRO9afoCFBtx2HXVvAZE0h/fVcGlKQ8c
    XGEopw8nnrmeL3ctwMQYnpbmZ6OicnNHii3+NAu0uHsKB8M9jEiYX9Ml+jeO5EBu
    izhsOWmYoN8/yXTqNTsL9FEdI2W4blrs2kOPhBksHU7TBIBoYsgnv6ovO6AfrAb2
    l0eZNTdhS/H53kJg+Gbp
    =CPEU
    -----END PGP SIGNATURE-----

  5. #5

    Default Re: Virtualbox: Opensuse 11.2 64 bit refuses to install

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Just for completeness, this will affect 64-bit virtualization with a lot
    of technologies including (but not necessarily limited to) KVM, Xen,
    vmware, etc.

    Good luck.





    On 04/05/2010 04:32 PM, ab@novell.com wrote:
    > Or, if it is supported by your CPU, is not enabled in your BIOS. Chances
    > are very good that if it is not explicitly enabled (by you) it is disabled
    > by default (I've yet to see a machine otherwise).
    >
    > Go into your BIOS and enable Virtualization.
    >
    > Good luck.
    >
    >
    >
    >
    >
    > On 04/05/2010 04:06 PM, daKump wrote:
    >
    >> Starting an 64 bit operating system with virtual box requieres VT-x or,
    >> in your case, the AMD-V CPU extension. Maybe this is not supported by
    >> your CPU and this case it is greyed like in my box (sorry, my screenshot
    >> is not in english but you should be able to find it).
    >> (Or maybe the check for activating the acceleration is simply
    >> missing)

    >
    >> [image: http://i41.tinypic.com/aw5lsj.png]

    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.12 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJLumTcAAoJEF+XTK08PnB5VbUQAMAG9VFgMoUgh7OMH9azpYYN
    91NYuJjgvId9wREJBtz1n3CHM30AZ0ub1CNLnm2qelSSod4lrQWsSy8WoUPuWWK2
    B2naebuUlIvzyGG8i2CRhNcDMU8mZMpxsq22dsA8tThY+/L1qgJMjvGk/IwdW7+h
    twHCj4Am3T8cjYIL8HEPFlCCZXhi7NcuiXKVp+DJ6+4e9mCBqFEwmnit/K4dpl/U
    NivF6lkxrW+d9LQfZ4MMj/Ro1l54MAfKvQRfvTWkkUmGnJkS4sgpzbfzMQ4Knbfr
    uKX1uA5OfyniSrZcJxgcFQ11p8fUYA8NVg1jpAzsCEnInrkd3Or5gMBzbfWeeEsa
    F7PohU9YiX3bn+ECdaU4vn/fd0eY0NUlNel6vVh7C+HWFuTLJJ2ETWlnj7d2lQkl
    zzpV2yTfjRsXZ08jFiSAfPJXbtvUv3A6au0ByjKq21RH9rNKE0mJcecj8yLr29xh
    5AaV7FRC33baUbiAXan4t8NmN2wW2ScsdTTnSbR6bOdx/UGHMWFH6oubiOGxpPNy
    NP3+WAW+j11caUo0wrjGrvolRrUISen79QtGwaQ07vYx/nbD60cm3IQmbCPdlXCO
    sELVbc4QQSQ+k7JmZqpiodHWsEQGwq+a83+9uvAeXuIZYVbbvyxMfYxQzEq9j9xQ
    yH2GnmVBFLU7g723qePU
    =xskJ
    -----END PGP SIGNATURE-----

  6. #6
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Re: Virtualbox: Opensuse 11.2 64 bit refuses to install

    This must be an issue with the motherboard, it does not offer to deactivate the virtualization of the AMD Athlon 64.
    Just "clicking away" security warnings about a change in repo signature ? Not able to control?
    Then please vote for
    https://features.opensuse.org/312047
    openSUSE should have an efficient web of trust.

  7. #7

    Default Re: Virtualbox: Opensuse 11.2 64 bit refuses to install

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Just to be clear, ACTIVATION is what you want, and not deactivation. It
    should be an option in the BIOS and if not then either your process or or
    motherboard (or both) is not going to support what you are trying to do.
    It may be called 'AMD-V' somewhere in there. Sorry if not, though. The
    technology has been around for a while and I think most systems have it
    now (AMD or Intel) but it's not required for a host machine to run 64-bit
    so I imagine it's left out of some processors/motherboards for cost reasons.

    Good luck.





    On 04/06/2010 01:36 AM, stakanov wrote:
    >
    > This must be an issue with the motherboard, it does not offer to
    > deactivate the virtualization of the AMD Athlon 64.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.12 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJLu0Z2AAoJEF+XTK08PnB5afkP/1hq080NyfQLu/IcUkC6o2Gr
    8VL7F0u5CUSQfeWG2k/Lg7QvmJ3am1DXd1dFGdaPIGIyErhnNGDcrlvxw2PApMMQ
    eYZ/Bl+6uNWyUN417Oqz0c7dqHfWfEa8iCPYWjW2goaYIKpXu9N4k6+4hz2dD9P6
    cdYUUwEN/g15+povtk2fYHD53OrXhfkJcUTFoEvjYPJWFAmKNcbCXeT8j2RstZS5
    3jAwGlFoCXQ4MVxvkSl/Vr/ozosomIaOEArfQo4Vp0kgYvwvej69V8Pj4awIckQr
    hIA+hW5Me6RQyAv9VsSsIWRMJh6VjYjDz587IOrgtr4+qI/o88Pej69BdGT7h/3U
    oNBybtjKLi4deF7iC8SaIAeoKMCySndrf1M3wi281V8G2HsJoWeToU6LwIDZtpcx
    WnGkT2lht6oTexoESbnWi+nK468Od3lf9Y+KNsZALe/y1CTRKsAeq09FMK6gWnCr
    VLEaUmHjsj+KvVvA+i+VUeJA+BPNJ4aTu/T6nfUzWiKD8m6dQurookNq5wdlGHbA
    IZNbh0QBZa9XYPCkOJHszZUmexdFRLe8iV1IOBYXqz43JzURqq4Jd3QeFhmi5UpI
    gEi3azOYqvzOmmWxyCqd39XPz5rs7uev/Zg5YZRCEd96z+oI1cmnv6J/iDCiKq+e
    vdYwkEAAXX2rZP5lb/pc
    =6hEN
    -----END PGP SIGNATURE-----

  8. #8
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Re: Virtualbox: Opensuse 11.2 64 bit refuses to install

    Quote Originally Posted by ab@novell.com View Post
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Just to be clear, ACTIVATION is what you want, and not deactivation. It
    should be an option in the BIOS and if not then either your process or or
    motherboard (or both) is not going to support what you are trying to do.
    It may be called 'AMD-V' somewhere in there. Sorry if not, though. The
    technology has been around for a while and I think most systems have it
    now (AMD or Intel) but it's not required for a host machine to run 64-bit
    so I imagine it's left out of some processors/motherboards for cost reasons.

    Good luck.





    On 04/06/2010 01:36 AM, stakanov wrote:
    >
    > This must be an issue with the motherboard, it does not offer to
    > deactivate the virtualization of the AMD Athlon 64.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.12 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - Enigmail: A simple interface for OpenPGP email security

    iQIcBAEBAgAGBQJLu0Z2AAoJEF+XTK08PnB5afkP/1hq080NyfQLu/IcUkC6o2Gr
    8VL7F0u5CUSQfeWG2k/Lg7QvmJ3am1DXd1dFGdaPIGIyErhnNGDcrlvxw2PApMMQ
    eYZ/Bl+6uNWyUN417Oqz0c7dqHfWfEa8iCPYWjW2goaYIKpXu9N4k6+4hz2dD9P6
    cdYUUwEN/g15+povtk2fYHD53OrXhfkJcUTFoEvjYPJWFAmKNcbCXeT8j2RstZS5
    3jAwGlFoCXQ4MVxvkSl/Vr/ozosomIaOEArfQo4Vp0kgYvwvej69V8Pj4awIckQr
    hIA+hW5Me6RQyAv9VsSsIWRMJh6VjYjDz587IOrgtr4+qI/o88Pej69BdGT7h/3U
    oNBybtjKLi4deF7iC8SaIAeoKMCySndrf1M3wi281V8G2HsJoWeToU6LwIDZtpcx
    WnGkT2lht6oTexoESbnWi+nK468Od3lf9Y+KNsZALe/y1CTRKsAeq09FMK6gWnCr
    VLEaUmHjsj+KvVvA+i+VUeJA+BPNJ4aTu/T6nfUzWiKD8m6dQurookNq5wdlGHbA
    IZNbh0QBZa9XYPCkOJHszZUmexdFRLe8iV1IOBYXqz43JzURqq4Jd3QeFhmi5UpI
    gEi3azOYqvzOmmWxyCqd39XPz5rs7uev/Zg5YZRCEd96z+oI1cmnv6J/iDCiKq+e
    vdYwkEAAXX2rZP5lb/pc
    =6hEN
    -----END PGP SIGNATURE-----
    Oh, well, i know activation is the issue. It is only that on Gygabite and other boards I did find the "AMD virtualization" function on "disable" or "enable". So I have been mis understandable. I think your intuition is right but not for cost reason. My board (ASRock) has been one of the last 939 mainboards to be produced by them for AMD64, switching then to AM2, and was probably technically not prepared for the technology. Pity but at least I do not search for hours for the reason.
    Linux does get us used to use older hardware because it runs flawlessly. It did for once not come to my mind that it is getting old. Socket AM2, AM2+ and AM3 came by already. I simply did not notice as the system with a good quantity of RAM still runs like build yesterday.
    Thanks for your indications though.
    Just "clicking away" security warnings about a change in repo signature ? Not able to control?
    Then please vote for
    https://features.opensuse.org/312047
    openSUSE should have an efficient web of trust.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •