Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: HowTo autostart kinternet in 11.2/kde4?

  1. #1

    Default HowTo autostart kinternet in 11.2/kde4?

    Hello List, I see there was one unanswered post on this in 08!

    I got autostart working on 11.2/gnome, but I've switch to kde4.3.1.

    Duncan on the kde list suggested to manually save a session, but in the session manager there's not a clue how to manually save a session.

    In gnome I wrote a shell script to start kinternet, but the script has to start after smpppd. That script starts too soon in kde4.

    The reasoon kinternet doesn't start with the "restart on login" box, is a kde3 app.

    Can I get some help here to manually save a session, or to write a script that can wait for smpppd?

    I have already tried kinternet --kicker, but apparetly kicker starts before smpppd.

    The script I wrote starts kinternet but with this error:

    Error - KInternet
    Connection to local and remote server
    refused. Maybe smpppd is not running
    or you are not member of the group "dialout".
    Also check the server settings in
    the dialog "Various Settings".
    OK

    The error to the calling shell looks like this:

    Starting kinternet --kicker
    DCOPClient::attachInternal. Attach failed Could not open network socket
    DCOPClient::attachInternal. Attach failed Could not open network socket
    DCOPClient::attachInternal. Attach failed Could not open network socket
    buildsycoca running...

    Please help on this on! Heboland

  2. #2

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    For KDE4, use qinternet.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    Quote Originally Posted by heboland
    Hello List, I see there was one unanswered post on this in 08!

    I got autostart working on 11.2/gnome, but I've switch to kde4.3.1.

    Duncan on the kde list suggested to manually save a session, but in the
    session manager there's not a clue how to manually save a session.

    In gnome I wrote a shell script to start kinternet, but the script has
    to start after smpppd. That script starts too soon in kde4.

    The reasoon kinternet doesn't start with the "restart on login" box, is
    a kde3 app.

    Can I get some help here to manually save a session, or to write a
    script that can wait for smpppd?

    I have already tried kinternet --kicker, but apparetly kicker starts
    before smpppd.

    The script I wrote starts kinternet but with this error:

    Error - KInternet
    Connection to local and remote server
    refused. Maybe smpppd is not running
    or you are not member of the group "dialout".
    Also check the server settings in
    the dialog "Various Settings".
    OK

    The error to the calling shell looks like this:

    Starting kinternet --kicker
    DCOPClient::attachInternal. Attach failed Could not open network
    socket
    DCOPClient::attachInternal. Attach failed Could not open network
    socket
    DCOPClient::attachInternal. Attach failed Could not open network
    socket
    buildsycoca running...

    Please help on this on! Heboland
    Hi
    Are you running an actual modem or pppoe? You should just be
    able to use the Networkmanager to connect?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 7 days 21:25, 3 users, load average: 0.20, 0.26, 0.26
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53


  4. #4

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    Thanks Akoellh, malcolmlewis,
    I installed qinternet and it is an improvement. It does restart on login from a parent of kinit.

    On login, qinternet gets the same error messages as kinternet and starts without a connection to the server. At that point the only menu option is "reconnect to server".

    I am connecting with a modem directly (/dev/stty0) as modem:0.

    I'm ready to try the network manager if it will work with a dial-up modem.

    Right now I have the Network Devices > Configuration settings set to Ifup and ivpc4 instead of 6. Those setting disable the network manager.

    malcolmlewis, what would you suggest for trying a modem connection with the network manager? Do I have to use ivpc6?

    Heboland

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    Quote Originally Posted by heboland
    Thanks Akoellh, malcolmlewis,
    I installed qinternet and it is an improvement. It does restart on
    login from a parent of kinit.

    On login, qinternet gets the same error messages as kinternet and
    starts without a connection to the server. At that point the only menu
    option is "reconnect to server".

    I am connecting with a modem directly (/dev/stty0) as modem:0.

    I'm ready to try the network manager if it will work with a dial-up
    modem.

    Right now I have the Network Devices > Configuration settings set to
    Ifup and ivpc4 instead of 6. Those setting disable the network manager.

    malcolmlewis, what would you suggest for trying a modem connection with
    the network manager? Do I have to use ivpc6?

    Heboland
    Hi
    You need to stick to IPV4, but there is an application called
    modem-manager which I think you should be using these days. What
    happens if you delete the modem in YaST, set the system back to use the
    NetworkManager. Login as your user and right-click on the
    NetworkManager icon and try setting up there.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 8 days 0:51, 3 users, load average: 0.32, 0.24, 0.28
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53


  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    You can get Kinternet to restart two ways:
    1. Get Kinternet running and an applet appears in the systray. Right click thae applet and choose Settings --> put a X in "start on login to kde"
      or
    2. put kinternet in the autostart directory located at /home/username/.kde4/Autostart
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  7. #7

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    Thank you swerdna,
    I think I've tried both methods you mentioned, both unsuccessfully.

    kde4 ignores the "start on login" box on kinternet, so no restart.

    I used the kde4 > "desktop configuration" > advanced > autostart. In there I use the script section to start a script I wrote that invokes kinternet.

    This invocation starts kinternet on login, but with the connection error I mentioned above. Is the autostart you mentioned different than the one I used?

    Apparently smpppd isn't started yet when autostart calls kinternet. The same problem happens with kinit starting qinternet.

    I can live with qinternet, but I will try network manager yet before I caputulate. Heboland

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    You set the daemon smpppd to start first by going to Yast --> System --> System Services Runlevels --> smpppd set to "enable" = yes

    That might have been the entire problem (maybe). Once you set that, it's possible that kinternet will respond to the first option I gave above.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  9. #9

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    Thanks swerdna, malcolmlewis,

    swerdna, I'll get back to you after I log off and try your suggestion.

    malcolmlewis, I took the first network manager conversion baby step. I changed from Ifup to NM. When the Yast > Network Devices > Newtork Configuration updated, it came up with the error "Network not running".

    I OKed that, but it gives me the impression that I have to be continuously connected. Dial-up here seldom lasts for longer than a half hour. Will I need a continuous connection with NM?

    Heboland

  10. #10

    Default Re: HowTo autostart kinternet in 11.2/kde4?

    Replying to myself,
    swerdna, smpppd was started and running. This is the status from the beginning - didn't change anything!

    Start the smpppd for internet and dial-up connections.
    Service will be started in the following runlevels: 2,3,5.

    Smpppd starts automatically, but apparently after kinternet or qinternet start. What's needed is a script that waits for smpppd.

    If you tell me how to detect smpppd, I'll attempt a script that waits to call qinternet until smpppd is started. The magic has to be a semiphore file or a lock file. Any hints from you?

    malcolmlewis, I see that my baby networking step has had consequences already! Back to Yast > Network > Network Settings, I got this warning:

    Yast2<2>
    Warning
    Network is currently controlled by NetworkManager and its setting cannot be dedited by Yast.
    To edit the setting, use NetworkManager connection editor, or switch the network setup method to Traditionial method with ifup.
    OK

    Can you guide me to NetworkManager? I think I remember seeing it by accident, but haven't been able to find my way back to it aganin. Heboland

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •