Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: OpenSuse 11.2 : Sound not works

  1. #1

    Default OpenSuse 11.2 : Sound not works

    fresh install OpenSuse 11.2 + kde4.
    all updates from updates: repo. Only official.

    under user:

    > alsamixer
    cannot open mixer: Permission denied

    Critical: Cannot open ALSA driver for PCM playback: Permission denied

    run sip client :
    Critical: Cannot open ALSA driver for PCM playback: Permission denied
    Critical: Cannot open ALSA driver for PCM playback: Permission denied
    Twinkle 1.4.2, 25 February 2009

    But under root mixer works :
    sudo alsamixer

    I reconfigure sound card by YaST, but problem still have.

    What I can do for repair sound ?
    What right add to my user (non-root) ?
    (Hardware is working)



    ....

    less /tmp/alsa-info.txt.nXMrU93Uap


    !!################################
    !!ALSA Information Script v 0.4.58
    !!################################

    !!Script ran on: Mon Apr 5 12:33:35 UTC 2010


    !!Linux Distribution
    !!------------------

    Welcome to openSUSE 11.2 "Emerald" - Kernel \r (\l). openSUSE 11.2 (x86_64)


    !!DMI Information
    !!---------------

    Manufacturer:
    Product Name:


    !!Kernel Information
    !!------------------

    Kernel release: 2.6.31.12-0.2-desktop
    Operating System: GNU/Linux
    Architecture: x86_64
    Processor: x86_64
    SMP Enabled: Yes

    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xe8220000 irq 22


    !!PCI Soundcards installed in the system
    !!--------------------------------------

    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)


    !!Advanced information - PCI Vendor/Device/Susbsystem ID's
    !!--------------------------------------------------------

    00:1b.0 0403: 8086:293e (rev 02)
    Subsystem: 8086:3001


    !!Loaded sound module options
    !!--------------------------

    !!Module: snd_hda_intel
    bdl_pos_adj : 1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    ,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
    enable_msi : 0
    id : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NUL
    L>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,
    <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
    index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-
    1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    model : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<
    NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NUL
    L>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
    patch : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<
    NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NUL
    L>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
    position_fix : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
    power_save : 0
    power_save_controller : Y
    probe_mask : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    probe_only : N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N
    single_cmd : N


    !!HDA-Intel Codec information
    !!---------------------------
    --startcollapse--

    Codec: SigmaTel STAC9271D
    Address: 2
    Function Id: 0x1
    Vendor Id: 0x83847627
    Subsystem Id: 0x80863001
    Revision Id: 0x100201
    No Modem Function Group found
    Default PCM:
    rates [0x7e0]: 44100 48000 88200 96000 176400 192000
    bits [0xe]: 16 20 24
    formats [0x1]: PCM
    ...................

    ----------------------

    ~> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-------------------------------------+-----------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | http-download.opensuse.org-33242215 | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
    2 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
    3 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    4 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    5 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    6 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: OpenSuse 11.2 : Sound not works

    evgeniy_10, I can't help you with the truncated in incomplete information provided. But thanks for making the effort as that is more than what most users with a sound problem provide.

    Please provide the information recommended to be provided in the second half of the multimedia stickie, ... and I quote the second half: Welcome to multimedia sub-area - openSUSE Forums
    please post .... the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/alsa-info.sh and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
      ....
    • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here
    Note if you do not get a URL from running /usr/sbin/alsa-info.sh, then instead running it like this:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    and then open up the file /tmp/alsa-info.txt with a text editor and copy and paste it to this web site PasteBin.be and press 'dump' on that site and post here the URL it provides. Just the URL.

    Please do NOT clutter up this thread with excessive posts of script outputs.

    Thanks and good luck.

  3. #3

    Default Re: OpenSuse 11.2 : Sound not works

    solution is simple:

    add user to "audio" group and re-login && restart services.

    Why install scripts don't add user to "audio" group ?

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: OpenSuse 11.2 : Sound not works

    Quote Originally Posted by evgeniy_10 View Post
    solution is simple:

    add user to "audio" group and re-login && restart services.

    Why install scripts don't add user to "audio" group ?
    evgeniy not every (in fact most) hardware needs the user added to group 'audio'. However alsa is developed in the open Source community, and a small number of developers wrote the code in the driver for their hardware requiring the user be part of group "audio". Unfortunately there was not consistency between the many contributers to the driver.

    Hence the problem you encountered.

    At least that is my assessment.

  5. #5

    Default Re: OpenSuse 11.2 : Sound not works

    Thank you guys!

    Adding user to 'audio' group worked for me too.

  6. #6

    Default Re: OpenSuse 11.2 : Sound not works

    I am having trouble on my Dell Laptop D630 ever since I upgraded to 2.6.31 kernel.

    I can set my sound card - play a test sound and then when i save it, I lose sound.

    The last line of output from dmesg :

    HDA Intel 0000:00:1b.0: PCI INT A disabled

    I've seen a lot of conflicting stuff out there and most of it predates the switch from alsaconf to udev... Maybe I need straigtened out here ?

    Any help appreciated.

    http://www.alsa-project.org/db/?f=29...3bb14ce266850b

    knix-laptop:/var/log # cat /etc/modprobe.d/50-sound.conf

    options snd slots=snd-hda-intel
    # u1Nb.0CMh_00Dca3ell Latitude D630
    alias snd-card-0 snd-hda-intel
    knix-laptop:/var/log # rpm -qa '*alsa*'
    alsa-tools-1.0.21-2.5.x86_64
    alsamixergui-0.9.0rc1-743.1.x86_64
    alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
    alsa-plugins-1.0.21-3.3.x86_64
    alsa-utils-1.0.21-3.1.x86_64
    alsa-plugins-pulse-1.0.21-3.3.x86_64
    alsa-oss-32bit-1.0.17-25.2.x86_64
    alsa-docs-1.0.21-3.2.noarch
    alsa-tools-gui-1.0.21-2.5.x86_64
    alsa-plugins-32bit-1.0.21-3.3.x86_64
    alsa-oss-1.0.17-25.2.x86_64
    alsaplayer-0.99.80-1.pm.1.1.x86_64
    kalsatools-1.5.0-598.1.x86_64
    alsa-1.0.21-3.2.x86_64
    alsa-firmware-1.0.20-3.2.noarch
    knix-laptop:/var/log # rpm -qa '*pulse*'
    libpulse-browse0-0.9.21-1.2.1.x86_64
    alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
    pulseaudio-module-bluetooth-0.9.21-1.2.1.x86_64
    pulseaudio-0.9.21-1.2.1.x86_64
    pulseaudio-lang-0.9.21-1.2.1.noarch
    alsa-plugins-pulse-1.0.21-3.3.x86_64
    libpulse-mainloop-glib0-0.9.21-1.2.1.x86_64
    pulseaudio-esound-compat-0.9.21-1.2.1.x86_64
    libpulse0-0.9.21-1.2.1.x86_64
    pulseaudio-module-zeroconf-0.9.21-1.2.1.x86_64
    libxine1-pulse-1.1.17-1.pm.26.2.x86_64
    pulseaudio-module-lirc-0.9.21-1.2.1.x86_64
    pulseaudio-utils-0.9.21-1.2.1.x86_64
    libpulse0-32bit-0.9.21-1.2.1.x86_64
    pulseaudio-module-x11-0.9.21-1.2.1.x86_64
    pulseaudio-module-gconf-0.9.21-1.2.1.x86_64
    pulseaudio-module-jack-0.9.21-1.2.1.x86_64
    knix-laptop:/var/log # rpm -q libasound2
    libasound2-1.0.21-3.2.x86_64
    knix-laptop:/var/log # uname -a
    Linux knix-laptop 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: OpenSuse 11.2 : Sound not works

    Quote Originally Posted by NickyRuggs View Post
    I am having trouble on my Dell Laptop D630 ever since I upgraded to 2.6.31 kernel.

    http://www.alsa-project.org/db/?f=29...3bb14ce266850b
    According to that your sound card is not even detected.

    Do you even get any sound in the yast > hardware > sound configuration ?

    Do you see any error indication in the dmesg of your sound device not being detected ? Do NOT post the dmesg output here. If necessary post it on a pastebin site such as PasteBin.be.

    If you need help doing any of the above please advise.

  8. #8

    Default Re: OpenSuse 11.2 : Sound not works

    Yes I do get sound when I configure it in YAST and choose the "Play test sound" but as soon as I say OK to save it ...it breaks again.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: OpenSuse 11.2 : Sound not works

    Quote Originally Posted by NickyRuggs View Post
    Yes I do get sound when I configure it in YAST and choose the "Play test sound" but as soon as I say OK to save it ...it breaks again.
    Add your regular user to group audio , restart your computer, and try again.

    Do you need help in figuring out how to add a user to a group ?

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: OpenSuse 11.2 : Sound not works

    Quote Originally Posted by NickyRuggs View Post
    as soon as I say OK to save it ...it breaks again.
    what is your criteria for saying it is broken ? ie. what application ? what speaker-test ?

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •