Results 1 to 6 of 6

Thread: Konqueror 4.4.2 (Missing KGET)

  1. #1

    Default Konqueror 4.4.2 (Missing KGET)

    I am having this problem in Konqueror 4.4.2 which I can't put my finger on. Perhaps it is a new bug or perhaps I need to change some setting.

    In Konqueror 4.3.5 I used to have an Icon in my Konqueror toolbars for KGET which had the following items
    * Show Drop Target
    * List All Links
    * List Selected Links

    Strangely this is missing. I used this extensively to download entire web-pages or specific contents (i.e. pictures) as it linked the Tab open in Konqueror with KGET.
    I selected the appropriate Konqueror URL Tab, KGET icon and then "List All links" which popped up a window allowing me to select all or very specific content.

    Presently "Import Links" in KGET does the same but this means I must every time copy the address into Klipper and then it will pick pick it up when klicking on "Import Links". This is not practical and is not the way the feature has been implemented in KDE 3 and 4. Their have been problem with KGET before but considering the state of KDE4, I find it hard to believe that programmers would intentionally remove features which have already been implemented or re-implemented.

    Here is what I tried:
    * I did disable and re-enable "Use as download manager for Konqueror" in KGET. From what I can tell KGET is being used for downloads (I have done a couple)
    * I did restart OpenSUSE 11.2 - I did not think this would resolve anything (More out of Windows habit). I am aware that I could simpple have ended the KDE or xorg session but working with Sun's Virtualbox and having hundreds of tabs open etc. etc. it sometimes helps clearing caches etc. I find that Macromedia Flash web pages eat memory and I don't generally like to waste time figuring out which browser tab is to blame. Usually I just kill nspluginviewer etc. when I experience high CPU usage.
    * I did close and reopen all instances of Konqueror but the reboot would obviously have done the same.
    * Renamed .konqueror under ~/.kde4/share/apps/konqueror/ - It created a new profile with the same problem. I deleted this and put back the old profile in order to restore my previous settings.


    Things I can still try:
    * Un-install and re-install Konqueror and KGet - Perhaps something is being missed during upgrade. Perhaps a de-& re-install will fix things.
    * Find and compare Toolbars location between Konqueror 4.3.5 and 4.4.2. - I have not investigated this yet
    * Your advice...
    * Live with the problem until KDE 4.4.x is mainstream in OpenSUSE.

    The question I am faced with is if this is a bug or mistake on my behalf, OpenSUSE repositories or KDE 4.4.2. If I don't get any answers, I will probably load a virtual machine and see if the problem is being replicated as I do use this a lot. Having upgraded to KDE 4.4.2 I am very happy with overall improvements in functionality and speed. It is not quite as stable as 4.3.5 but I am willing to live with the occasional crash as long as it is not something mayor.

    Any tips, tricks, advice will do.

  2. #2

    Default Re: Konqueror 4.4.2 (Missing KGET)

    Quote Originally Posted by VolkerBause View Post
    I am having this problem in Konqueror 4.4.2 which I can't put my finger on. Perhaps it is a new bug or perhaps I need to change some setting.

    In Konqueror 4.3.5 I used to have an Icon in my Konqueror toolbars for KGET which had the following items
    * Show Drop Target
    * List All Links
    * List Selected Links

    Strangely this is missing.
    Just launched Konqueror, and it's there for me with the entries "Show Drop Target" and "List All Links" (the last one probably only appears when you have selected links). Clicking it brings up KGet just fine.
    Konqueror on Kde 4.4.2 release 234 x64.
    OpenSuse 11.2 x64 + Kde 4.4.2 Release 234

  3. #3

    Default Re: Konqueror 4.4.2 (Missing KGET)

    Good for you. Any idea how I can get mine to display as I have not been able to figure out my problem.

    I have Konqueror 4.4.2-155.6-x86_64. Not sure where you get the 234 version from but based on the information you have send me, it might appear that my version is older and perhaps therefore to blame.

    I would appreciate it if you could post the direct link for the repositories your Konqueror comes from so I could try updating. I will in the mean time re-investigate if I missed an repository (Unlikely) or perhaps if I can detect where yours is from. As far as I am concerned, I used the latest relatively stable version as posted on the OpenSUSE site. It still is in factory though. I added the repositories manually but this should not matter unless the One-Click adds some additional resources (Perhaps Updates) which don't fall under the common KDE 4.4 repositories.

    I also posted another threat regarding missing or non functioning Amarok functionality. According to the moderator his is working and having the features missing in mine. I can only deduct that probably we are using different versions of the same product. No mentioning of the moderator's post indicated which version of Amarok is being used allowing me to come to some conclusion on this. I did update the treat on my reply with my versions and am awaiting feedbackback on the matter.

    All I know is that in the 4.3.5 Version everything worked and that in the present 4.4.2 version I have upgraded to, some things appear to be broken.

    The question remaining is why do I get different versions than you. What repositories do you have setup that I don't. Is this the reason yours is working and mine not.

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Konqueror 4.4.2 (Missing KGET)

    It's in the KDE4 factory repo. I updated a couple days ago to version 234.

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Konqueror 4.4.2 (Missing KGET)

    Sorry, got your post wrong - I read that the KGet-icon was missing in Konqueror, obviously it just lacks certain functionality (right?).

    -- deleted --

  6. #6

    Default Re: Konqueror 4.4.2 (Missing KGET)

    Wrong!

    I believe you got it right the 1st time.

    KGET does also integrate with Konqueror. I can see this because when I go to a web site containing content that needs to be downloaded, it actually does download it with KGET and not with Konqueror.

    I am simply missing the KGET icon which is part of its own toolbar called "mainToolBar <khtml-kget>" which you will find if you go do "Settings" and then "Configure Toolbar". It usually automatically shows up next to (To the Right) of the "Main Toolbar" if you fire up Konqueror.

    While typing this post (Using Firefox because I figured that I might try a couple of things to fix Konqueror), I figured I would try removing everything Konqueror related and re-install. This finally resolved my problem and the KGET icon is back. I decided to leave the rest of the post I was already writing in case somebody else runs into the same trouble as a matter of reference. Everything below the line is what I typed before resolving the issue but had not posted before reaching a conclusion.

    * The only other option that would have remained would have been to fire up one of my Sun Virtualbox machines with OpenSUSE 11.2, upgrade this to KDE 4.4 from the Factory to see what happened. If this had the same problem, their must be a problem with your packages. If not, I sure as hell would have been screwed with no option other than live without KDE 4.4 or wait for updates. What kept me going was the fact that you told me yours is working. This made no sense unless their was a fault in mine or you used different packages. The more obvious in my opinion was that somewhere in my KDE setup their must be a mistake. Fortunately your time and effort paid off because without your assistance I would have been in the blind as I know of nobody else in Windhoek, Namibia that has or uses the latest OpenSUSE has to offer. Sure I have done I few production installation with Samba as Primary Domain Controller etc. etc. but nobody I know out here pushed the envelope.

    Thanks a million for your help and support! It is appreciated and the only way for a Linux community to grow

    OpenSUSE in my opinion remains one of the best distributions out on the bleeding edge and your daily support forums are essential for fellow OpenSUSE enthusiasts, professionals etc. Keep up the good work! As part of my dedication to the project, I do occasionally browse through your forums aiding where I can. I am after 5 years still learning myself but in 5 years I have learned a lot. I love the rapid Linux developments and am very honest when I say that I use Linux for over 80% of my work (I have run my own IT company for 10 years or so).

    ============================

    Also I was a bit confuse with where you got your version of Konqueror 4. Investigating this matter I found that while "Help" and then "About Konqueror" does show the version you mentioned (release 233), the YAST Software Manager actually shows the following:

    konqueror-4.4.2-155.6.x86_64
    konqueror-plugins-lang-4.3.1-2.5.3.noarch
    konqueror-plugins-4.3.1-7.11.x86_64

    Also obtainable by running the following command filter from the konsole:
    rpm -qa | grep konqueror

    Usually I go to the "Software Management" in Yast to establish which version I have as
    a) This tells me the present version information.
    b) I can see if a newer version is available in another repository which the warrants consideration for upgrade
    c) Usually it shows up red if the package has for some reason been removed or downgraded in the package repository it was installed from.
    d) The "Help" "About Project" section might be wrong because somebody (One of the programmers) forgot to update this information. This occasionally happens as per my experience. I studied Business Computing myself and am therefor well aware that we don't live in a perfect world. The idea is to recognise our shortcomings and to move on while trying to improve ourselves.

    I am not sure why the konqueror-plugins are still at version 4.3.1.x but looking at the Yast "Software Management" with a search for "konqueror", it appears to be the most up to date version is installed.

    Other things I tried so far:

    * Create a new Linux user - The idea being that if the problem is based in the user profile, it should be fixed when I log on as a brand new user. This did not resolve the issue.

    * Delete all Konqueror and related packages which might be dependent and re-install with the hope of fixing configuration files which might lead to the problem - I just decided to give this a try and now everything works.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •