Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Could not remove a protected system package

  1. #1
    Join Date
    Feb 2010
    Location
    Kuala Lumpur, Malaysia
    Posts
    146

    Default Could not remove a protected system package

    This happened when I tried to update automatically. Tried using zypper too and failed:

    Code:
    Subprocess failed. Error: RPM failed: error: package krb5-1.7-6.3.1.x86_64 is not installed
    What is wrong here? How do i remove a protected system package?
    Thanks in advance.

  2. #2
    palladium NNTP User

    Default Re: Could not remove a protected system package

    return results of

    Code:
    zypper lr -d
    and, what "protected system package" are you trying to remove as part
    of an 'update'?

    --
    palladium

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,867
    Blog Entries
    14

    Default Re: Could not remove a protected system package

    Quote Originally Posted by izaak86 View Post
    How do i remove a protected system package?
    Thanks in advance.
    You don't, unless you want to destabilize your system on purpose.

    Point now is, that you have to find out which package throws the error.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Feb 2010
    Location
    Kuala Lumpur, Malaysia
    Posts
    146

    Default Re: Could not remove a protected system package

    Here's the output of zypper lr -d
    Code:
    #  | Alias                 | Name                  | Enabled | Refresh | Priority | Type   | URI                                                                      | Service
    ---+-----------------------+-----------------------+---------+---------+----------+--------+--------------------------------------------------------------------------+--------
    1  | Compiz                | Compiz                | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11%3a/XGL/openSUSE_11.2/      |        
    2  | Java                  | Java                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.2/  |        
    3  | Wine                  | Wine                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.2/ |        
    4  | google-chrome         | google-chrome         | No      | Yes     |   99     | rpm-md | http://dl.google.com/linux/rpm/stable/x86_64                             |        
    5  | mozilla               | mozilla               | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/         |        
    6  | openSUSE 11.2 Mozilla | openSUSE 11.2 Mozilla | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/         |        
    7  | openSUSE 11.2-0       | openSUSE 11.2-0       | No      | Yes     |   99     | yast2  | cd:///                                                                   |        
    8  | packman               | packman               | Yes     | Yes     |   99     | rpm-md | http://packman.jacobs-university.de/suse/11.2/                           |        
    9  | repo-debug            | openSUSE-11.2-Debug   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.2/repo/oss/           |        
    10 | repo-non-oss          | openSUSE-11.2-Non-Oss | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/             |        
    11 | repo-oss              | openSUSE-11.2-Oss     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                 |        
    12 | repo-source           | openSUSE-11.2-Source  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/          |        
    13 | repo-update           | openSUSE-11.2-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.2/                                |
    On the contrary, I'm trying to stabilize my system. And this automatic update is not working right. By the way, I'm not trying to remove any protected system package, just following the stated instruction error.

    And just for the record, here's my list of needed patches.
    Code:
    Repository           | Name                       | Version | Category    | Status
    ---------------------+----------------------------+---------+-------------+-------
    openSUSE-11.2-Update | compiz-fusion-plugins-main | 1990    | security    | needed
    openSUSE-11.2-Update | krb5                       | 2188    | security    | needed
    openSUSE-11.2-Update | mcelog                     | 2180    | recommended | needed
    openSUSE-11.2-Update | perl                       | 2185    | recommended | needed
    openSUSE-11.2-Update | yast2-pam                  | 2186    | recommended | needed
    Thanks for the quick reply!

  5. #5
    Join Date
    Feb 2010
    Location
    Kuala Lumpur, Malaysia
    Posts
    146

    Question Re: Could not remove a protected system package

    Can someone help me here?
    Thanks.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Could not remove a protected system package

    Quote Originally Posted by izaak86 View Post
    This happened when I tried to update automatically. Tried using zypper too and failed:

    Code:
    Subprocess failed. Error: RPM failed: error: package krb5-1.7-6.3.1.x86_64 is not installed
    What is wrong here? How do i remove a protected system package?
    Thanks in advance.
    What do you get from

    Code:
    rpm -qi krb5
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Feb 2010
    Location
    Kuala Lumpur, Malaysia
    Posts
    146

    Default Re: Could not remove a protected system package

    The output for
    Code:
    rpm -qi krb5
    is
    Code:
    Name        : krb5                         Relocations: (not relocatable)
    Version     : 1.7                               Vendor: openSUSE
    Release     : 6.4.1                         Build Date: Thu 25 Mar 2010 01:04:07 AM MYT
    Install Date: Sat 27 Mar 2010 03:24:17 PM MYT      Build Host: build21
    Group       : Productivity/Networking/Security   Source RPM: krb5-1.7-6.4.1.src.rpm
    Size        : 1631355                          License: MIT License (or similar)
    Signature   : RSA/8, Thu 25 Mar 2010 01:04:50 AM MYT, Key ID b88b2fd43dbdc284
    Packager    : http://bugs.opensuse.org
    URL         : http://web.mit.edu/kerberos/www/
    Summary     : MIT Kerberos5 Implementation--Libraries
    Description :
    Kerberos V5 is a trusted-third-party network authentication system,
    which can improve your network's security by eliminating the insecure
    practice of clear text passwords.
    
    
    
    Authors:
    --------
        The MIT Kerberos Team
        Sam Hartman <hartmans@mit.edu>
        Ken Raeburn <raeburn@mit.edu>
        Tom Yu <tlyu@mit.edu>
    Distribution: openSUSE 11.2

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Could not remove a protected system package

    What puzzles me, is why you want to remove it?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Feb 2010
    Location
    Kuala Lumpur, Malaysia
    Posts
    146

    Default Re: Could not remove a protected system package

    I shoud have mentioned this earlier, but my thread title "Could not remove a protected system package" is an error that pops up after I tried to do the update.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Could not remove a protected system package

    So forget the auto updater, just quit it.

    Now tell me what happens if you run

    Code:
    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •