Results 1 to 2 of 2

Thread: Tomcat and Opensuse 11.2 installation

  1. #1

    Default Tomcat and Opensuse 11.2 installation

    Hi all, I am having some troubles installing tomcat on a fresh copy of 11.2.

    As a disclaimer, I am a total linux newbie, so feel free to ridicule, call names, and otherwise fling nuggets of verbal poop as long as you then explain to me where I went wrong.

    I began by following the instructions that I found here: Tomcat HOWTO - openSUSE and proceeded to install the requisite packages through YaST, except I chose to install tomcat6 and java 1.6, presuming that they would work equally well to the older versions indicated in the guide.

    My stumbling block came when the guide went on to tell me to download and compile an alternative mod_jk to the one included (even though I hadn't come across one, so I didn't have to uninstall one like the guide suggested.) The link provided in the guide was dead so I found an alternative link through google, and set up the directory structure as suggested.

    The next step tells me that I must run this command:

    ./configure --with-apxs=/usr/sbin/apxs2
    Running it (after installing gcc) yields the following error (after a bunch of presumably successfully running commands):

    need to check for Perl first, apxs depends on it...
    checking for perl... /usr/bin/perl
    could not find /usr/sbin/
    configure: error: You must specify a valid --with-apxs path
    I have tried to create an apxs2 directory in sbin, which isn't allowed. I have also tried running the command without the apxs2 on the end, also to no avail.

    At this moment, I am stumped. Hopefully my mistake is something glaringly obvious to those more versed in the arcane ways of the terminal than I.


  2. #2
    Join Date
    Jun 2008
    Blog Entries

    Default Re: Tomcat and Opensuse 11.2 installation

    Why do you need a custom mod_jk? Doesn't the one supplied in 11.2 work for you?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts