Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: No sound for users, just root

  1. #1
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    14

    Default No sound for users, just root

    Hello,

    I am having trouble with flash player. Well first I had some trouble with my router and rebooted linux. Then, flash wouldn't play sound anymore.

    I updated flash etc but still no sound. Then I tried as root administrator and flash sound works fine there.

    So I checked the sound preferences from the Control Center and found out, all output devices are set to autodetect instead to one of the output devices I have. But when I switched to the user account to change the preferences accordingly, no sound was played at all... *sigh*...

    Also, when I want to use the loudspeaker icon at the bottom to reach the volume control in the user account, I get an error message stating there was some connection refused.

    This is very disturbing. Somebody have a clue?

    Deneck

  2. #2
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    14

    Default Re: No sound for users, just root

    As it seems, I can not edit my post. I forgot the following:

    My Open SuSe Version is 11.1.
    Kernel Linus 2.6.27.45-0.1-default
    GNOME 2.24.1

    Flash Version ist the latest. But I don't think that Flash is the problem.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: No sound for users, just root

    Note that inappropriate use of user account can really mess up your permissions such that sound will not work and other problem symptoms will result (from inappropriate root use). So hopefully your testing with root was just a simply konsole/terminal test and NOT a log in to X.

    Anyway, did you try adding your regular user to group audio? You can do that in YaST.

    After adding your user to group audio, you need to log out of Linux and log back in. Restarting may be the easiest way not to get this wrong, after adding your user to group audio.

  4. #4
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    14

    Default Re: No sound for users, just root

    Thanks for helping

    To see if things work on root I actually hit the "switch user" button. Hope that's not too much of a problem. Anyway, it did not become worse than it was before. Of course this could mean it was all messed up before and rebooting the system while flash was trying to load a movie was the final push it needed.

    I found the audio group, added the user to it and rebooted. Did not change anything.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: No sound for users, just root

    Quote Originally Posted by Deneck View Post
    Thanks for helping

    To see if things work on root I actually hit the "switch user" button. Hope that's not too much of a problem. Anyway, it did not become worse than it was before. Of course this could mean it was all messed up before and rebooting the system while flash was trying to load a movie was the final push it needed.

    I found the audio group, added the user to it and rebooted. Did not change anything.
    OK, then since you are using openSUSE-11.1, try removing libflash-support (but keep flash-player) and restart your browser and check as a REGULAR USER.

    If that does not work then as a REGULAR USER try to play a flash video. Check the PCM volume levels immediately as soon as the video starts to play and move them up if too low. Does that help?

    Advise please if it does not, as there are other things to check.

  6. #6
    palladium NNTP User

    Default Re: No sound for users, just root

    Deneck wrote:
    > Thanks for helping
    >
    > To see if things work on root I actually hit the "switch user" button.
    > Hope that's not too much of a problem.


    logging into any Unix-like OS as root/superuser/ is a no-no, do not do
    it even "just to check" and see if it works...because doing so you
    have nothing you can use..

    dont do it...this is not windoz and root is not administrator..

    logging into KDE/Gnome/etc as root 1) opens you up to several
    different security problems, 2) too many too easy ways to damage your
    system no matter how careful your actions (example: just browsing in
    your home directory while logged into KDE/Gnome/etc as root can lock
    you out later as yourself due to permissions damage), 3) and, anyway
    logging into KDE/etc as root is *never* required to do any and all
    administrative duties..

    so, always log in as yourself, and "become root" by using a root
    powered application (like YaST, File Manager Superuser Mode) or using
    "su -", sudo, kdesu, or gnomesu in a terminal to launch whatever tool
    is needed (like Kwrite to edit a config file)...read more on all that
    here:

    http://en.opensuse.org/SDB:Login_as_root
    http://docs.kde.org/stable/en/kdebas...uide/root.html
    http://tinyurl.com/6ry6yd
    http://tinyurl.com/ydbwssh

    --
    palladium

  7. #7
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    14

    Default Re: No sound for users, just root

    oops, ok. There are many "why?!" questions about the root topic, but for now I guess it's fine if I just do not log in as root anymore.

    thank you for the links!

    Quote Originally Posted by oldcpu View Post
    OK, then since you are using openSUSE-11.1, try removing libflash-support (but keep flash-player) and restart your browser and check as a REGULAR USER.

    If that does not work then as a REGULAR USER try to play a flash video. Check the PCM volume levels immediately as soon as the video starts to play and move them up if too low. Does that help?

    Advise please if it does not, as there are other things to check.
    I did the following:
    - removed libflash-support and libflash-support 32bit
    - went to youtube and: no sound
    - started the PulseAudio Volume Control and to my surprise connection was not refused any more

    However, there is no way to check on PCM volume in that Volume Control.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: No sound for users, just root

    Quote Originally Posted by Deneck View Post
    started the PulseAudio Volume Control and to my surprise connection was not refused any more

    However, there is no way to check on PCM volume in that Volume Control.
    Pulse audio in gnome is IMHO a bit buggy.

    Do you have sound as a regular user in ANY application?

    Out of curiousity, what is the output URL provided by running the diagnostic script (with your PC connected to the internet):
    Code:
    /usr/sbin/alsa-info.sh
    and select the SHARE/UPLOAD option.

  9. #9
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    14

    Default Re: No sound for users, just root

    Hello,

    I do have sound in all applications except shockwave flash in firefox.

    Here is the output URL:
    http://www.alsa-project.org/db/?f=a7...aec7dcb48c6798

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: No sound for users, just root

    Quote Originally Posted by Deneck View Post
    Hello,

    I do have sound in all applications except shockwave flash in firefox.

    Here is the output URL:
    http://www.alsa-project.org/db/?f=a7...aec7dcb48c6798
    OK, I note this:
    Code:
    !!Soundcards recognised by ALSA
    !!-----------------------------
    
     0 [SB             ]: HDA-Intel - HDA ATI SB
                          HDA ATI SB at 0xfe020000 irq 16
     1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                          HDA ATI HDMI at 0xfdbfc000 irq 19
     2 [Audigy2        ]: Audigy2 - Audigy 2 ZS [2001]
                          Audigy 2 ZS [2001] (rev.4, serial:0x20011102) at 0xcf00, irq 21
    From what I can see you have 2 sound devices (I am ignoring the HDMI).

    In some cases in KDE, users will have sound devices selected in a specific order in YaST > Hardware > Sound, but will have a different order selected in KDE's > Configure Desktop Multimedia. This means firefox will try to play sound thru the wrong hardware device and the user will get no sound. I do not know how this works in Gnome, but its possible you have the same problem. I believe you need to ensure you have the same order of device priority in Gnome desktop (pulse audio) settings as you have in YaST.

    Also, some users found in firefox they need to go to Firefox > Edit > Applications > Shockwave Flash file and choose "Use Flash Player (default)"

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •