Results 1 to 5 of 5

Thread: FreeNX and Sound - openSUSE 11.2 & KDE 4.3 - Help

  1. #1

    Unhappy FreeNX and Sound - openSUSE 11.2 & KDE 4.3 - Help

    Followed the openSUSE howto:
    FreeNX Server HOWTO - openSUSE

    I did enable multimedia support in the NX client configuration services tab but no sound coming through NX session.

    configure desktop / multimedia / I have Output Device Preference.

    My sound card is listed and below that is Pulse Audio.
    From reading up on NX I think Pulse Audio has to be the preferred output device but gives error that it does not work and rolls back to sound card it if it is set to preferred.

    I for got how I got it to come up last week but it was an error that pulse audio was not even installed.

  2. #2

    Default Re: FreeNX and Sound - openSUSE 11.2 & KDE 4.3 - Help

    I use NX from my netbook to an HTPC, but it's the closed source package from www.nomachine.org rather than FreeNX.

    I can't remember when I removed it, but PulseAudio is no longer installed on the HTPC (the NX server).
    At the moment it's working well, the only issue I have is that occasionally if I want to play audio from the console I have to log off the remote NX session.

    In System Settings/Multimedia, can you select each of the devices and press the Test button, through the NX session and on the console. Report back any that work.

    While setting it up, I had more problems playing audio through applications (particularly firefox), even though test tones would work.

  3. #3

    Default Re: FreeNX and Sound - openSUSE 11.2 & KDE 4.3 - Help

    My server is on the other side of my home behind our TV. I have it connected via DVI to HDMI adapter. With TV on, and me in the other room, connected via NX, the following happens:

    Section:
    NVidia nForce2 with ACL650F (NVidia nForce2)
    Click TEST
    I can hear the test music sound coming from the server.

    Selection: PulseAudio (the only other "Output Device" available to chose
    "The audio from this play back device does not work. Falling back ti Nvidia nForce2 with ALC650F."

  4. #4

    Default Re: FreeNX and Sound - openSUSE 11.2 & KDE 4.3 - Help

    Sounds like you have a similar setup to me. Strangely, I tried to
    watch a film last night after posting, and it took me half an hour to
    get the audio working again!

    So how is your audio connected? Audio can go over HDMI, but not DVI
    (without a coupler).

    For my setup (AMD/ATI on board sound, connected through the optical
    out), I have to click on 'Show Advanced Devices' and then move the
    Digital Out (Optical) to the top by pressing 'Prefer' - then apply to
    all.
    I've removed pulse, so all the output settings in VLC, mplayer etc are
    set to ALSA/default.

    I don't know if a recent update has broken something, but the only
    player I got working last night was Bangarang. I'll try again
    tonight.

  5. #5

    Default Re: FreeNX and Sound - openSUSE 11.2 & KDE 4.3 - Help

    Right now the HDMI connection has nothing to do with this issue.
    I have the audio out of the server going into to the audio in of the TV. The sound output from the nForce2 works fine.

    I no longer run the server @ run lvl 5. It boots to run lvl 3.
    I ,from a windows computer on the other side of the house, connect @ run lvl 5 with NX client. I am wanting the sound in this NX client session to work. Should work if I could switch sound output to Pulse Audio but Pulse audio is not working as my original post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •