Results 1 to 7 of 7

Thread: Audacity can't locate an ffmpeg library

  1. #1
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,160

    Default Audacity can't locate an ffmpeg library

    I use Audacity quite a lot for conversion of a voice recorder, to convert WMA to FLAC
    When I used it Mar 24 it worked, when used it Mar 26 it didn't.
    I used the locate pointed it to libavcodec.so.52 like it had there & it tells me it can't find it!
    At first I thought it was an update I'd done from the Packman repos
    only when I went to Yast to revert only the most recent update was in there, no prior versions. Yet I Know that ffmpeg was among the updates it was blue when I did it then.
    Other distro's don't have this problem only Suse who or where or what should I do so that Audacity works in Suse again?
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Audacity can't locate an ffmpeg library

    I confess I can not understand your post. Apologies.

    Did you take a look at Reddwarf's 10 step guide (ie the first post): Check your multimedia problem in ten steps - openSUSE Forums

    Note that packages packaged by videolan are often incompatible with packages packaged by Packman and visa versa. Also note many other 3rd party repositories will package multimedia applications that may be incompatible with Packman, videolan and indeed with the baseline official openSUSE.

    Hence I always recommend users stick with 4 and only 4 software repositories. Those are the 3 official repositories: OSS, Non-OSS, and Update. And one and ONLY one 3rd party repository, which is Packman. Just those 4. No others. None.

    On the occasion where one has identified a package from a repository that is NOT one of those 4, then I recommend adding the repository, installing the application, and then IMMEDIATELY removing the 5th repository. This will IMHO save signifcantly on both functional and dependency problems.

    My view is the best way to solve a dependency problem is to never encounter one, and by sticking with the 4 repositories I recommend (OSS, non-OSS, Update and Packman) one goes a long ways toward achieving that.

  3. #3
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,160

    Default Re: Audacity can't locate an ffmpeg library

    oldcpu,
    Glad to see you're here. I've done some things since that post.
    I tried to convert using ffmpeg in Konsole & it also failed there
    in Suse but succeeded in another distro. Now as to the VLC repos, no, not in my case learned my lesson there in 10.2!
    It's looking like there may be an error in the packaging somwhere,Packman's? Because on another machine this same problem with Suse, once again no VLC repos, just Packman all the way & it's a 32bit machine with 11.2. This makes me think it might be a bug perhaps in libavcodec, so do you know who I could contact to ask them to look into it?
    I have those 4 the only additionals I have are for KDE, surely they didn't cause this, Could they?
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Audacity can't locate an ffmpeg library

    Quote Originally Posted by Sagemta View Post
    It's looking like there may be an error in the packaging somwhere,Packman's? Because on another machine this same problem with Suse, once again no VLC repos, just Packman all the way & it's a 32bit machine with 11.2. This makes me think it might be a bug perhaps in libavcodec, so do you know who I could contact to ask them to look into it?
    The packman packagers are very receptive/good for addressing problems. But they can only be contacted via 3 means:
    • (1) email (if one knows the email address of the packager - which one can get from the Packman web site) PackMan :: home
    • (2) IRC freenode channel #packman. They all login here from time to time, but they may or may not see ones complaint.
    • (3) mailing list - the absolute BEST way. They ALL subscribe to the mailing list. In fact, when one sends an email per item(1) it goes to the mailing list, but if one is not subscribed to the mailing list, one may not see the reply. Details on the mailing list: Packman Info Page
    Apologies if that seems to be a "run around" to you, but as you likely know, this forum is just a volunteer forum of openSUSE volunteers/enthusiasts, where Novell has picked up the funding for the hosting server and maintainance of the forum software, but few developers (although we do get some) and few packagers (although we do get some) visit here.

    I hope this helps.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Audacity can't locate an ffmpeg library

    Quote Originally Posted by Sagemta View Post
    I have those 4 the only additionals I have are for KDE, surely they didn't cause this, Could they?
    I typically never add additional KDE, but its possible if you had a multimedia app from KDE that it could have caused this.

    The ONLY time I added an extra KDE was to update my openSUSE-11.2 KDE-4.3.1 to KDE-4.3.4 (which I promptly removed as soon as openSUSE-11.2 was "officially" updated to KDE-4.3.5 in the "official" update repository), and I also added KDE Stable for openSUSE-11.1 so as to update openSUSE-11.1's buggy KDE-4.1.3 to a more stable KDE-4.3.5 (which works great, by the way).
    Code:
    http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.1
    I still have openSUSE-11.1 on one of my six PCs because of an Intel graphic driver issue with the kernel in 11.2, where the issue is not present with the kernel in 11.1.

    I definitely avoid ALL other KDE repositories. I've had too many problems over the years (from 2001 to 2005) with repositories that I should not have touched.

  6. #6
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Audacity can't locate an ffmpeg library

    Hello

    I also use Audacity a great deal but it works alright for me in respect of converting to flac. I just tested it. I checked for the latest packman update on this system and it was done the 25.03.2010. I also noted that ffmpeg (++) was updated at that time. Do not really know if ffmpeg is involved with the mentioned convert operation though, just thought I should mentioned how it works for me.

    Cheers

  7. #7
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,160

    Default Re: Audacity can't locate an ffmpeg library

    Oldcpu,
    You give me "the run around"? No! you don't do stuff like that!
    The info you gave is what I was seeking. Yes it'll help.
    Also after reading that you remove the KDE repos, I may consider this. However I do do testing of KDE so I may have to consider carefully. In the interim I see that Packman has a new update on ffmpeg, I'll be checking it first.

    F_sauce,
    I'm not sure sometimes my PC's are quirky. Since for me this started with an update & I see that Packman has a new ffmpeg I'll see if it ends with this one.
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •