Results 1 to 10 of 10

Thread: openSuSE 11.2 и Nvidia TNT

  1. #1

    Default openSuSE 11.2 и Nvidia TNT

    Здравствуйте!
    Прошу Вашей помощи в решении проблемы.
    Установил openSuSE 11.2 на старую машинку (AthlonXP, nFonce2, TNT2) - все прошло успешно, однако с драйвером "nv" иксы прилично подгружают процессор (при отрисовке). Решил установить проприетарный драйвер Nvidia для очень старых карт (71.86.13 - последний, официально рекомендованный): скачал драйвер, установил исходники ядра и т.д., пропатчил систему и установил драйвер Nvidia. Все прошло успешно, lsmod показывает nvidia, а инсталлятор попросил использовать sax2 для настройки X.
    Вот тут и приключилась неприятность:
    "(II) LoadModule: "nvidia"
    (II) Loading /usr/lib/xorg/modules//drivers/nvidia_drv.so
    dlopen: /usr/lib/xorg/modules//drivers/nvidia_drv.so: undefined symbol: AllocateScreenPrivateIndex
    (EE) Failed to load /usr/lib/xorg/modules//drivers/nvidia_drv.so
    (II) UnloadModule: "nvidia"
    (EE) Failed to load module "nvidia" (loader failed, 7)
    (EE) No drivers available.

    Fatal server error:
    no screens found
    "
    Облазил кучу форумов, но представленные там рецепты не помогли.

    Собрал информацию по проблеме при помощи скрипта nvidia-bug-report.sh, получил архив nvidia-bug-report.log.gz 44kb, в развернутом виде nvidia-bug-report.log - 200kb текста.
    Однако, как сами понимаете, ограничения на тип и объем загружаемых файлов, не позволяют представить оригинал. Разбить на куски.

    Надеюсь и уповаю на Вашу помощь.

  2. #2

    Default Re: openSuSE 11.2 и Nvidia TNT

    Вторая часть лога

  3. #3

    Default Re: openSuSE 11.2 и Nvidia TNT

    Третья (последняя) часть лога

  4. #4
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    2,995
    Blog Entries
    1

    Default Re: openSuSE 11.2 и Nvidia TNT

    Мне кажется, вы неправильно устанавливаете драйвер.
    Сделайте по инструкции: Драйверы NVIDIA — openSUSE

  5. #5
    Join Date
    Mar 2010
    Location
    Samara, Russia
    Posts
    94

    Default Re: openSuSE 11.2 и Nvidia TNT

    Надо ставить на старый дистрибутив. На новом эта видеокарточка не заводится.
    Entia non sunt multiplicanda praeter necessitatem.
    openSUSE 11.3 x86_64 2.6.34.4-6-desktop | KDE 4.5.1 | Asus P5QC | Intel Pentium D CPU 3.40GHz | DDR3 12800 2Gb | NVIDIA GeForce 9600 GSO DDR3 384 Mb

  6. #6

    Default Re: openSuSE 11.2 и Nvidia TNT

    Quote Originally Posted by hanty View Post
    Надо ставить на старый дистрибутив. На новом эта видеокарточка не заводится.
    Добрый день!
    Подскажите, плз., на какой?

  7. #7
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    2,995
    Blog Entries
    1

    Default Re: openSuSE 11.2 и Nvidia TNT

    Из доступных самый старый oS 11.0.
    Возможно, потом удастся обновиться на 11.2.

  8. #8

    Default Re: openSuSE 11.2 и Nvidia TNT

    Quote Originally Posted by Lazy_Kent View Post
    Из доступных самый старый oS 11.0.
    Возможно, потом удастся обновиться на 11.2.
    Отпралял запрос на linux-bugs@nvidia.com и получил следующий ответ:
    "
    Unfortunately, the 71.86.* legacy driver series does not support your
    X.Org X server version 1.6.5. You'll need to either downgrade to a
    supported X server or use a newer GPU that's supported by at least the
    96.43.* legacy driver series.
    "

    Так что действительно, либо X.Org X server даунгрейдить (до какой версии и как ?), либо карту апгрейдить.

  9. #9
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    2,995
    Blog Entries
    1

    Default Re: openSuSE 11.2 и Nvidia TNT

    Даунгрейдить Xorg не получится, т. к. слишком много программ на него завязаны. Карта, действительно, уж очень древняя.

  10. #10
    Join Date
    Mar 2010
    Location
    Samara, Russia
    Posts
    94

    Default Re: openSuSE 11.2 и Nvidia TNT

    Quote Originally Posted by zharovrg View Post
    Подскажите, плз., на какой?
    На 11.0 или 10-ку, где xorg меньше или равен 1.6.5.
    Entia non sunt multiplicanda praeter necessitatem.
    openSUSE 11.3 x86_64 2.6.34.4-6-desktop | KDE 4.5.1 | Asus P5QC | Intel Pentium D CPU 3.40GHz | DDR3 12800 2Gb | NVIDIA GeForce 9600 GSO DDR3 384 Mb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •