Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Screen Saver Feature has never worked

  1. #1
    Join Date
    Feb 2010
    Location
    South Dakota, USA
    Posts
    171

    Default Screen Saver Feature has never worked

    Hi. I have never been able to use the Screen Saver in the Desktop settings, as even clicking on a Screen Saver, crashes the whole Desktop Settings.

    Here is what I get:

    Code:
    Application: systemsettings (1.0)
    KDE Platform Version: 4.4.1 (KDE 4.4.1) "release 228"
    Qt Version: 4.6.2
    Operating System: Linux 2.6.31.12-0.2-default i686
    Distribution: "openSUSE 11.2 (i586)"
    
    -- Information about the crash:
    <In detail, tell us what you were doing  when the application crashed.>
    
    The crash can be reproduced every time.
    
     -- Backtrace:
    Application: System Settings (systemsettings), signal: Segmentation fault
    [KCrash Handler]
    #6  0xb5eb65d4 in XVisualIDFromVisual () from /usr/lib/libX11.so.6
    #7  0xb69e8e7c in ?? () from /usr/lib/libQtGui.so.4
    #8  0xb69e8f1f in ?? () from /usr/lib/libQtGui.so.4
    #9  0xb69f06a1 in QWidgetPrivate::create_sys(unsigned long, bool, bool) () from /usr/lib/libQtGui.so.4
    #10 0xb699f50f in QWidget::create(unsigned long, bool, bool) () from /usr/lib/libQtGui.so.4
    #11 0xa75b8d6b in ?? () from /usr/lib/kde4/kcm_screensaver.so
    #12 0xa75bae26 in ?? () from /usr/lib/kde4/kcm_screensaver.so
    #13 0xa75bb3ae in ?? () from /usr/lib/kde4/kcm_screensaver.so
    #14 0xa75bcb49 in ?? () from /usr/lib/kde4/kcm_screensaver.so
    #15 0xa75c045d in ?? () from /usr/lib/kde4/kcm_screensaver.so
    #16 0xb63ee14d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
    #17 0xb63fcfaa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
    #18 0xa7434b55 in Q3ListView::currentChanged(Q3ListViewItem*) () from /usr/lib/libQt3Support.so.4
    #19 0xa72be768 in Q3ListView::setCurrentItem(Q3ListViewItem*) () from /usr/lib/libQt3Support.so.4
    #20 0xa72c7dfa in Q3ListView::contentsMousePressEventEx(QMouseEvent*) () from /usr/lib/libQt3Support.so.4
    #21 0xa72c8583 in Q3ListView::contentsMousePressEvent(QMouseEvent*) () from /usr/lib/libQt3Support.so.4
    #22 0xa7542636 in K3ListView::contentsMousePressEvent(QMouseEvent*) () from /usr/lib/libkde3support.so.4
    #23 0xa73253a8 in Q3ScrollView::viewportMousePressEvent(QMouseEvent*) () from /usr/lib/libQt3Support.so.4
    #24 0xa7326fb5 in Q3ScrollView::eventFilter(QObject*, QEvent*) () from /usr/lib/libQt3Support.so.4
    #25 0xa72c352f in Q3ListView::eventFilter(QObject*, QEvent*) () from /usr/lib/libQt3Support.so.4
    #26 0xb63e80ae in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
    #27 0xb693d3cd in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
    #28 0xb6944c0e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
    #29 0xb741fb81 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
    #30 0xb63e8dde in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
    #31 0xb6943b54 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
    #32 0xb69d169a in ?? () from /usr/lib/libQtGui.so.4
    #33 0xb69d0c44 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
    #34 0xb69fe2b8 in ?? () from /usr/lib/libQtGui.so.4
    #35 0xb5a064c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
    #36 0xb5a09d98 in ?? () from /usr/lib/libglib-2.0.so.0
    #37 0xb5a09ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
    #38 0xb6415931 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
    #39 0xb69fde0a in ?? () from /usr/lib/libQtGui.so.4
    #40 0xb63e744d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
    #41 0xb63e7899 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
    #42 0xb63eba10 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
    #43 0xb693d4a4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
    #44 0x08055f95 in _start ()
    
    Report to https://bugs.kde.org
    Am I to assume that the user account for KDE Community Forums does not work for https://bugs.kde.org? I could not get it to work;

    But if somebody knows how I can fix this problem, I would sure appreciate and love the feedback - maybe I need to delete one or more files and reboot, or relogin?

    Star_Gazer

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Screen Saver Feature has never worked

    You are using 4.4.1. DO you still have the base Suse repos active you probably have mixed packages.

    Post

    zypper lr -d

  3. #3
    Join Date
    Feb 2010
    Location
    South Dakota, USA
    Posts
    171

    Default Re: Screen Saver Feature has never worked

    Quote Originally Posted by gogalthorp View Post
    You are using 4.4.1. DO you still have the base Suse repos active you probably have mixed packages.
    Yes, but it has been happening since I have been using openSUSE, which I believe has been over a month now, if not two.

    Post

    zypper lr -d
    Code:
    #  | Alias                                 | Name                                   | Enabled | Refresh | Priority | Type   | URI                                                                                    | Service
    ---+---------------------------------------+----------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------------------------+--------
    1  | Google_Linux                          | Google Linux                           | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/rpm/stable/i386                                             |        
    2  | KDE:KDE4:Factory:Desktop              | KDE:KDE4:Factory:Desktop               | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.2/   |        
    3  | download.opensuse.org-STABLE          | openSUSE BuildService - OpenOffice.org | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.2/        |        
    4  | download.opensuse.org-mozilla         | openSUSE BuildService - Mozilla        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/                       |        
    5  | google-chrome                         | google-chrome                          | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/rpm/stable/i386                                             |        
    6  | home:poletti_marco:KDE                | home:poletti_marco:KDE                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/poletti_marco:/KDE/KDE_Factory_11.2/   |        
    7  | http://packman.iu-bremen.de/suse/11.2 | http://packman.iu-bremen.de/suse/11.2  | No      | No      |   99     | rpm-md | http://packman.iu-bremen.de/suse/11.2                                                  |        
    8  | openSUSE_11.2:Contrib                 | openSUSE_11.2:Contrib                  | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE%3a/Factory%3a/Contrib/openSUSE_11.2 |        
    9  | repo-debug                            | openSUSE-11.2-Debug                    | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.2/repo/oss/                         |        
    10 | repo-non-oss                          | openSUSE-11.2-Non-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/                           |        
    11 | repo-oss                              | openSUSE-11.2-Oss                      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                               |        
    12 | repo-source                           | openSUSE-11.2-Source                   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/                        |        
    13 | repo-update                           | openSUSE-11.2-Update                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.2/                                              |
    Thanks.
    Star_Gazer

  4. #4
    Join Date
    Jul 2009
    Location
    Kissimmee, FL
    Posts
    28

    Default Re: Screen Saver Feature has never worked

    Hello Star Gazer,

    Did you ever get this fixed? I am having the same problem.

    Each time I click the 'screen saver' icon in system settings > desktop, system settings crashes.

    Any help would be great. I'm completely at a loss for what to do about this one!

    Here is the KDE Crash Handler report:

    Code:
    Application: System Settings (systemsettings), signal: Segmentation fault
    [KCrash Handler]
    #5  0x00007fb9f294e7c0 in XVisualIDFromVisual () from /usr/lib64/libX11.so.6
    #6  0x00007fb9f4fa50ff in ?? () from /usr/lib64/libQtGui.so.4
    #7  0x00007fb9f4fa5190 in ?? () from /usr/lib64/libQtGui.so.4
    #8  0x00007fb9f4faca56 in QWidgetPrivate::create_sys(unsigned long, bool, bool) () from /usr/lib64/libQtGui.so.4
    #9  0x00007fb9f4f7331b in QWidget::create(unsigned long, bool, bool) () from /usr/lib64/libQtGui.so.4
    #10 0x00007fb9e993561a in ?? () from /usr/lib64/kde4/kcm_screensaver.so
    #11 0x00007fb9e9927581 in ?? () from /usr/lib64/kde4/kcm_screensaver.so
    #12 0x00007fb9e9929730 in ?? () from /usr/lib64/kde4/kcm_screensaver.so
    #13 0x00007fb9e992a0dc in ?? () from /usr/lib64/kde4/kcm_screensaver.so
    #14 0x00007fb9f43b8fbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
    #15 0x00007fb9f43b2f63 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
    #16 0x00007fb9f4f232ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
    #17 0x00007fb9f4f2a57e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
    #18 0x00007fb9f5b1e016 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
    #19 0x00007fb9f43a3ddc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
    #20 0x00007fb9f43cf71d in ?? () from /usr/lib64/libQtCore.so.4
    #21 0x00007fb9f43cc678 in ?? () from /usr/lib64/libQtCore.so.4
    #22 0x00007fb9f0fefdee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
    #23 0x00007fb9f0ff37b8 in ?? () from /usr/lib64/libglib-2.0.so.0
    #24 0x00007fb9f0ff38e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
    #25 0x00007fb9f43cc3a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #26 0x00007fb9f4fb631e in ?? () from /usr/lib64/libQtGui.so.4
    #27 0x00007fb9f43a2712 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #28 0x00007fb9f43a2ae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #29 0x00007fb9f43a4c99 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
    #30 0x000000000040cbd9 in _start ()

  5. #5
    Join Date
    Feb 2010
    Location
    South Dakota, USA
    Posts
    171

    Default Re: Screen Saver Feature has never worked

    Quote Originally Posted by seveninstl View Post
    Hello Star Gazer,

    Did you ever get this fixed? I am having the same problem.

    Each time I click the 'screen saver' icon in system settings > desktop, system settings crashes.

    Any help would be great. I'm completely at a loss for what to do about this one!

    ...
    Hello seveninstl,

    Actually, I gave up the ghost on getting to that problem a while back. HOWEVER, after seeing your post, I decided to try and see if I too was still getting the same problem, and lo and behold, it is NOW working.

    I tested about 3 screen savers via the "test" button, and set them for 1 minute to see if they worked, and they did work.

    Perhaps a recent update included a fix to the problem. I do not know if it due to a new release of KDE and / or something else. The KDE release I now have installed is KDE 4.42 (Release 239).

    Perhaps you should run the 'zypper upd' command in the terminal in root mode, or, if in user mode, 'sudo zypper upd' works me. The Konsole Terminal usually offers the Root Shell on the File Menu.

    Please let me know if that works for you if you run the update(s). I'll mark this issue as solved if that is the case.

    Clifton

  6. #6

    Default Re: Screen Saver Feature has never worked

    Hope this is right place, but I too have a problem with Screen Saver.

    Am using 11.4, and since it was loaded, every time go to set,or view screen saver, when you select any of the available options, the system crashes, and I am invited to send a bug report. Have you tried doing this when you are a complete novice, it will not even recognise my user name.

    See from backtrack? that there appears to be lots of problems with screen savers, but how, being a complete idiot where the various commands are required, see puzzled penguin note.

    Is there really nothing I can do to get a screen saver. Have tried deleting and then restoring in software but no joy.

    Again sorry if wrong place to ask, but at wits end now.

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Screen Saver Feature has never worked

    On 05/28/2011 07:06 PM, leilton wrote:
    >
    > Am using 11.4, and since it was loaded, every time go to set,or view
    > screen saver, when you select any of the available options, the system
    > crashes, and I am invited to send a bug report.


    ok, you say it never worked...is ll.4 the first Linux loaded on this
    machine, ever?

    if not, did you keep the old /home to use in 11.4?

    if you did, what was the previous Linux from which you kept /home?

    what desktop environment and version are you using?

    did you have this screen saver trouble before you installed any software
    after the initial install/update?

    have you ever installed any software from any Factory, Playground or
    Tumbleweed repo?

    are you running openSUSE 11.4 directly on your hardware, or in a VM? if
    in a VM what is the host OS?

    if you use YaST to add a test users, then log out and log back in as the
    new test user, does the screen saver work then?

    did you do this prior to installing 11.4: http://tinyurl.com/2ebcf27

    did you have any errors during install?

    does your machine meet the minimum requirements of 11.4 for RAM, and
    processor?

    what is your graphics chip/driver?

    >
    > See from backtrack?


    what is backtrack?


    > that there appears to be lots of problems with
    > screen savers, but how, being a complete idiot where the various
    > commands are required, see puzzled penguin note.


    commands?
    do you not have a Configure Desktop GUI??


    > Is there really nothing I can do to get a screen saver.


    it "just works" here and has since about 2002....(but i never ever use
    "Random" because it will lock up the machine, eventually!)


    > Have tried deleting and then restoring in software but no joy.


    did you use YaST to delete/restore? if not, explain how you did that..

    what package(s) did you remove and replace, exact name(s) please..

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  8. #8

    Default Re: Screen Saver Feature has never worked

    To answer your questions to the best of my ability, which where Linux is concerned, is very little.

    Suse 11.4 has been installed via a CD I burnt over the Internet. At the time I had a computer expert, he works on and with computers in Norway) help me install same. (I could never manage to connect the wireless internet).

    Between us,everything seemed to be functioning very well (in fact I am more than happy), but, he has gone back to his home, and I have been working my way thru the various systems. (see my various threads on the Forum), and have managed to tackle most of them, but no way can I find what is wrong with Screen Saver.

    Yes, have configured Desktop, even found my favourite candy from KDE.

    Sorry, watching the cup match at same time, and should have said backtrace, comes up when I try to set up scree saver, it list all the various problems there been.

    No, just noted, bit remiss, that 10.3 mib ram

    Used YaST and the items I removed , and replaced, were :

    KDE artwork4-screen
    XScreensaver-data extra

    Sorry to appear to be a bit dense, but really not into computers or technical terms, (old window user), and assumed that as long as I updated, configured, as required, and did not fiddle around too much, I would manage.

    Maybe best if I await the arrival of the man from Norway, whenever that is.

    Sorry if I'm not being much use to you in your efforts to help me.

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Screen Saver Feature has never worked

    On 05/28/2011 10:36 PM, leilton wrote:
    >
    >
    > Suse 11.4 . . . 10.3 mib ram


    please explain how you have 10.3 MiB of RAM and run openSUSE...or, do
    you mean you have 10.3 GiB of RAM...where are you getting that info
    from? please open "My Computer" and reply with the "Total memory (RAM)"
    reported there...

    > Used YaST and the items I removed , and replaced, were :
    >
    > KDE artwork4-screen
    > XScreensaver-data extra


    ok, open YaST, give the root password and go to Software Repositories,
    in the "Enabled" column there should be only four check marks, one for
    each of Updates, Oss, Non-Oss and Packman Repository..

    all of the others need to be disabled and not automatically
    refreshing...to do that, single click on one to change, and then down
    below single left click on the Enabled and Automatically Refresh boxes
    to *remove* the X, then click on the next repo in the list above and
    repeat until you have only those four repos enabled...also, of those
    four only Packman and Updates needs to be refreshed (since oss and
    non-oss are unchanging)

    when you have only the correct four repos enabled and two of those
    refreshing, you will have a total of six checks on the screen, and then
    press "Ok"...

    then go back to the still open YaST and go Software Management, then
    below the search block, in the "Search in" section you will see an X in
    some boxes....add an X to the boxes for "Description" and then type
    "screensaver" in the search box and press the "Search" button...i expect
    you to have three packages installed, the two you name above plus
    "kde4-kgreeter-plugins", if you have those there with a check, then
    single right click each individually and in the pop up menu choose
    "Update" (with the green icon of an arrow and check mark) when you have
    done that click "Accept"..

    *IF* you have more than three packages installed, do NOT do the above
    update, instead report back with what you saw...giving exact package
    names checked as installed..

    on the other hand, after YaST as updated (removed/replaced) those
    packages again, try setting your screen saver using the Configure
    Desktop's > Hardware > Display and Monitor > Screensaver settings window..

    let me suggest that initially set it to "Blank Screen", then press
    "Test" and report the results..

    if that works then you can go crazy...but, i recommend you not select
    "Random" because my experience is that eventually it will find the one
    or two (or ten) screen savers which will lock up your system..

    --
    dd CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10]
    Dual booting with Sluggish Loser7 on Acer Aspire One D255

  10. #10
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Screen Saver Feature has never worked

    Since upgrading to 11.4 I have problems with screensavers (I disabled it).
    It either freeze my screen or (now) it logs me out of the system.

    I hope we will find solution.
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •