Results 1 to 6 of 6

Thread: Why is zypp-backend dropped in kupdateapplet 0.9.11?

  1. #1

    Angry Why is zypp-backend dropped in kupdateapplet 0.9.11?

    Hi,

    in KDE:Factory:Desktop you can find a new version of kupdateapplet. In the changes you can find the following:

    - dropped zypp plugin (bnc: 590192)
    - V 0.9.11

    Sadly I have no access to 590192 in bugzilla, so can anybody tell me why the only real working backend is dropped? The PackageKit-Backend is not showing the updates from 3rd-party-repositories (packman or obs). Is there any possibility to get back the working 0.9.10?

    Greets

  2. #2
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    88

    Default Re: Why is zypp-backend dropped in kupdateapplet 0.9.11?

    Quote Originally Posted by balta3 View Post
    Hi,

    in KDE:Factoryesktop you can find a new version of kupdateapplet. In the changes you can find the following:

    - dropped zypp plugin (bnc: 590192)
    - V 0.9.11

    Sadly I have no access to 590192 in bugzilla, so can anybody tell me why the only real working backend is dropped? The PackageKit-Backend is not showing the updates from 3rd-party-repositories (packman or obs). Is there any possibility to get back the working 0.9.10?

    Greets
    Help pump it up.

    I also want to know what is the exact difference between PackageKit plugin and zypp plugin? If I remember correctly, packagekit was the default option after you start kupdateapplet for the very first time on 11.2. Why is that? Especially most people report Packagekit is no better than zypp plugin even worse.

  3. #3

    Default Re: Why is zypp-backend dropped in kupdateapplet 0.9.11?

    Has nobody an answer for this? Is any KDE 4.4-User using this buggy PackageKit-Backend?

  4. #4
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Why is zypp-backend dropped in kupdateapplet 0.9.11?

    kupdateapplet-zypp is available now. It wasn't updated at the same time as kupdateapplet so I'm guessing it was removed because of dependencies.

    Is that what you mean?

  5. #5

    Default Re: Why is zypp-backend dropped in kupdateapplet 0.9.11?

    As written in the first post, in KDE:Factoryesktop (the only source for KDE 4.4) there isn't any kupdateapplet-zypp, and in the changes for the kupdateapplet you can see that it is dropped.

    The Factory-Repository will become the packages for openSUSE-Factory, and so for openSUSE 11.3. This means, in the next suse-Version everybody has to use PackageKit.

    That's that I'm asking.

  6. #6
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Why is zypp-backend dropped in kupdateapplet 0.9.11?

    Ok, I was wrong. I was using Milestone 4 earlier today and saw kupdateapplet-zypp and got it confused with 11.2. It seems there is no update for the zypp plugin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •