Results 1 to 5 of 5

Thread: Mouse pointer disappear

  1. #1

    Default Mouse pointer disappear

    Hallo:

    I've been using OpenSuse 11.2 for two months.
    I use KDE and sometimes Gnome (both in the same computer).

    Everything was right. But yesterday I updated the system. Then a program (VMPlayer) asked me to recompile some modules (which was done automatically by VMPlayer).

    I restarted the system and then the MOUSE POINTER DISAPPEARED. The mouse works, but can see where it is. It also said to me that kwin was crashing and ask me to choose kwin or metacity.

    If I start system in failsafe mode, I see the mouse, but if I restart in normal mode, it disappears again.

    Also, in normal mode boot, accessing the consoles with CTRL-F1,CTRL-F2, ... doesn't work.

    A strange problem... Can any suggest me what can I do?


    Thanks

  2. #2

    Default Re: Mouse pointer disappear

    Hello torcaz99,

    I restarted the system and then the MOUSE POINTER DISAPPEARED. The mouse works, but can see where it is.
    Do you have this with KDE and GNOME?
    If so it is most likely a problem in your Xorg.conf file.

    Go to the directory /etc/X11.
    Run this command to backup you xorg.conf file:
    Code:
    mv xorg.conf xorg.conf.BU
    Then reboot openSUSE to create a new xorg.conf file.

    Also, in normal mode boot, accessing the consoles with CTRL-F1,CTRL-F2, ... doesn't work.
    KDE intercepts those key combinations.
    Therefore you need to do CTRL+ALT+<FUNCTION KEY>.

    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Mouse pointer disappear

    Quote Originally Posted by Edward_Iii View Post
    Code:
    mv xorg.conf xorg.conf.BU
    Then reboot openSUSE to create a new xorg.conf file.
    One important note: if you have an ATI graphics card and are using the ATI driver, please ensure to run:
    Code:
    aticonfig --initial
    As root in runlevel 3 BEFORE you reboot. Therefore: rename xorg.conf, run aticonfig and then reboot.
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  4. #4

    Default Re: Mouse pointer disappear

    Thanks for the help.

    Finally I've installed all the operating system.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: Mouse pointer disappear

    Reference a disappearing mouse pointer, please also take a look at post#38 and post#45 in this thread (linked here) for possible solutions: openSUSE Graphic Card Practical Theory Guide for Users - Page 2 - openSUSE Forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •