Results 1 to 8 of 8

Thread: Why have all my tty gone to 80x24?

  1. #1
    Join Date
    Jun 2008
    Location
    Norwich, UK
    Posts
    215

    Default Why have all my tty gone to 80x24?

    OpenSUSE 11.1 + latest updates

    When I reboot I can't get my tty resolution back to the 1680x1050 it was
    running at earlier. The grub configuration shows vga=0x348 which is
    1680x1050 and was working a while ago.

    On boot I now get messages telling me that this resolution is invalid and
    offers a selection of resolutions, all of which are 80x#. Even if I select
    80x60, part way through the boot process the resolution switches to 80x25
    and that's what I get for tty1-tty6.

    I think this started with the last kernel update but I'm not sure ...
    I've tried other grub vga values (e.g, 0x318, 0x31B) but I always get the
    same result - invalid resolution and pick an 80x# size which then goes to
    80x25.

    Come on. I've got this nice big monitor and 80x25 looks bloody stupid at
    this size. What can I do to resolve this without reverting to an earlier
    kernel?

    Alan



  2. #2
    palladium NNTP User

    Default Re: Why have all my tty gone to 80x24?

    Fudokai wrote:
    > What can I do to resolve this without reverting to an earlier
    > kernel?


    log a bug report maybe? http://en.opensuse.org/Submitting_Bug_Reports

    --
    palladium

  3. #3
    Join Date
    Jun 2008
    Location
    Norwich, UK
    Posts
    215

    Default Re: Why have all my tty gone to 80x24?

    palladium wrote:

    > Fudokai wrote:
    >> What can I do to resolve this without reverting to an earlier
    >> kernel?

    >
    > log a bug report maybe? http://en.opensuse.org/Submitting_Bug_Reports
    >


    Just to add to the confusion I've just rebooted the machine and this time I
    DIDN'T hit ESC to watch the boot process in detail, I just left it in the
    graphics screen and now I've got my full size screen back!

    As an old-fashioned geek I always preferred to watch the text messages
    scroll past - I may not understand some of them but I have caught some
    system config problems before now. So is watching the text go by the cause?
    Do I want to keep rebooting over and over using different procedures? Would
    I rather have a life?

    It's Ok now so I'll just live with it - I just wish I knew why it happened!

    Alan

  4. #4
    palladium NNTP User

    Default Re: Why have all my tty gone to 80x24?

    Fudokai wrote:
    > I just wish I knew why it happened!


    me too..

    btw, i do not have to push Esc to see what Gawd intended mankind to
    see (the beautiful scroll of stuff happening)!!

    and you can too just, open YaST > System > Bootloader

    highlight the line used to boot openSUSE (*not* the fail safe), click
    edit and CAREFULLY add

    Code:
    splash=0
    on the line labeled "Optional Kernel Command Line Parameter"..

    and click on "Ok"...done, next time you boot you will see it as it
    should be..

    --
    palladium

  5. #5
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: Why have all my tty gone to 80x24?

    Quote Originally Posted by palladium View Post

    Code:
    splash=0
    on the line labeled "Optional Kernel Command Line Parameter"..
    On 11.2, there is already a splash=silent, would that conflict with that second splash=0 as you suggest? Or should I replace the splash=silent with splash=0?
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,877

    Default Re: Why have all my tty gone to 80x24?

    Replace.

    You could also try adding it to the additional parameters line in the grub start screen (before it times out, of course). This won't change your menu.lst grub file (that's what the yast module does), so it's good for testing different boot parameters, as they will be applied to the current boot only.

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,877

    Default Re: Why have all my tty gone to 80x24?

    Note: AFAIK splash=silent is what brings up the nice green graphical progress screen during boot. No splash brings up the "normal" behavior, i.e., the console.

  8. #8
    palladium NNTP User

    Default Re: Why have all my tty gone to 80x24?

    brunomcl wrote:
    > Replace.


    +1

    replace silent with 0

    --
    palladium

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •